Author Topic: Error Upgrading to Roundcube 1.5  (Read 373 times)

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Error Upgrading to Roundcube 1.5
« on: March 24, 2021, 06:29:21 PM »
I just tried upgrading to Roundcube V1.5-beta, but got the following error:

Code: [Select]
[root@mylinuxbox roundcubemail-1.5-beta]# ./bin/installto.sh /var/www/html/webmail
Composer detected issues in your platform:

Your Composer dependencies require a PHP version ">= 7.1.0". You are running 5.6.40.

PHP Fatal error:  Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.1.0". You are running 5.6.40. in /tmp/roundcubemail-1.5-beta/vendor/composer/platform_check.php on line 25
[root@mylinuxbox roundcubemail-1.5-beta]#

The changelog for Roundcube 1.5 indicates that it requires PHP >= 5.5 which I comply with.

The Linux box I'm using has CentOS 7 installed and there are other reasons I'd prefer to hold PHP at 5.6.40. Any idea why it wont install with PHP 5.6.40? Any pointers on how to avoid getting this error without upgrading PHP?

Thanks



Offline alec

  • Hero Member
  • *****
  • Posts: 1,239
Re: Error Upgrading to Roundcube 1.5
« Reply #1 on: March 25, 2021, 02:49:03 AM »
What's different in your composer.json in reference to composer.json-dist? Roundcube is tested using Travis with PHP 5.5 and 5.6 and it works.

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Re: Error Upgrading to Roundcube 1.5
« Reply #2 on: March 25, 2021, 03:51:43 PM »
There are some differences. I'm not sure why, but in both cases  "php": ">=5.4.0 <8",

composer.json:
Code: [Select]
{
    "repositories": [
        {
            "type": "composer",
            "url": "https://plugins.roundcube.net/"
        },
        {
            "type": "vcs",
            "url": "https://git.kolab.org/diffusion/PNL/php-net_ldap.git"
        },
        {
            "type": "composer",
            "url": "https://plugins.roundcube.net"
        }
    ],
    "require": {
        "sabre/vobject": "3.3.3",
        "php": ">=5.4.0 <8",
        "pear/pear-core-minimal": "~1.10.1",
        "pear/auth_sasl": "~1.1.0",
        "pear/net_idna2": "~0.2.0",
        "pear/mail_mime": "~1.10.0",
        "pear/net_smtp": "~1.8.1",
        "pear/crypt_gpg": "~1.6.3",
        "pear/net_sieve": "~1.4.3",
        "roundcube/plugin-installer": "~0.2.0",
        "masterminds/html5": "~2.5.0",
        "endroid/qr-code": "~1.6.5"
    }
}

composer.json-dist:
Code: [Select]
{
    "name": "roundcube/roundcubemail",
    "description": "The Roundcube Webmail suite",
    "license": "GPL-3.0+",
    "repositories": [
        {
            "type": "composer",
            "url": "https://plugins.roundcube.net"
        }
    ],
    "require": {
        "php": ">=5.4.0 <8",
        "pear/pear-core-minimal": "~1.10.1",
        "pear/auth_sasl": "~1.1.0",
        "pear/net_idna2": "~0.2.0",
        "pear/mail_mime": "~1.10.0",
        "pear/net_smtp": "~1.8.1",
        "pear/crypt_gpg": "~1.6.3",
        "pear/net_sieve": "~1.4.3",
        "roundcube/plugin-installer": "~0.2.0",
        "masterminds/html5": "~2.5.0",
        "endroid/qr-code": "~1.6.5"
    },
    "require-dev": {
        "phpunit/phpunit": "^4.8.36 || ^5.7.21"
    },
    "suggest": {
        "kolab/net_ldap3": "~1.1.1 required for connecting to LDAP",
        "mkopinsky/zxcvbn-php": "^4.4.2 required for Zxcvbn password strength driver"
    }
}

Edit1: I've just tried deleting composer.json and renaming composer.json-dist to composer.json but that didn't make any difference.
Edit2: I've also just check file composer.lock and the highest require is "php": ">=5.4.0.0"
Edit3: For what it's worth, I was able to upgrade from 1.4.10 to 1.4.11 without any issue.
« Last Edit: March 25, 2021, 04:11:44 PM by chaser »

Offline alec

  • Hero Member
  • *****
  • Posts: 1,239
Re: Error Upgrading to Roundcube 1.5
« Reply #3 on: March 26, 2021, 02:45:07 AM »
The file in 1.5-beta looks different. https://github.com/roundcube/roundcubemail/blob/1.5-beta/composer.json-dist Please make sure to use this.

I wasn't able to reproduce the issue.

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Re: Error Upgrading to Roundcube 1.5
« Reply #4 on: March 26, 2021, 08:11:22 AM »
The file in 1.5-beta looks different. https://github.com/roundcube/roundcubemail/blob/1.5-beta/composer.json-dist Please make sure to use this.

I wasn't able to reproduce the issue.
I've copied the file over from github and used it to replace both composer.json-dist and composer.json but it hasn't made any difference. I've also disabled all the plugins by commenting out the $config['plugins'] line in config.inc.php but that didn't make any difference either. I'm still getting this:

Code: [Select]
[root@mylinuxbox roundcubemail-1.5-beta]# ./bin/installto.sh /var/www/html/webmail
Composer detected issues in your platform:

Your Composer dependencies require a PHP version ">= 7.1.0". You are running 5.6.40.

PHP Fatal error:  Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.1.0". You are running 5.6.40. in /tmp/roundcubemail-1.5-beta/vendor/composer/platform_check.php on line 25
[root@mylinuxbox roundcubemail-1.5-beta]#

Any other thoughts?

Thanks

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Re: Error Upgrading to Roundcube 1.5
« Reply #5 on: March 26, 2021, 08:28:22 AM »
Just digging into this a bit further...

I downloaded the distribution from here:

https://github.com/roundcube/roundcubemail/releases/download/1.5-beta/roundcubemail-1.5-beta-complete.tar.gz

In that zipped file there is a directory vendor/composer that has a file called platform_check.php. That file contains the check for v7.1.0:

Code: [Select]
<?php

// platform_check.php @generated by Composer

$issues = array();

if (!(
PHP_VERSION_ID >= 70100)) {
    
$issues[] = 'Your Composer dependencies require a PHP version ">= 7.1.0". You are running ' PHP_VERSION '.';
}

if (
$issues) {
    if (!
headers_sent()) {
        
header('HTTP/1.1 500 Internal Server Error');
    }
    if (!
ini_get('display_errors')) {
        if (
PHP_SAPI === 'cli' || PHP_SAPI === 'phpdbg') {
            
fwrite(STDERR'Composer detected issues in your platform:' PHP_EOL.PHP_EOL implode(PHP_EOL$issues) . PHP_EOL.PHP_EOL);
        } elseif (!
headers_sent()) {
            echo 
'Composer detected issues in your platform:' PHP_EOL.PHP_EOL str_replace('You are running '.PHP_VERSION.'.'''implode(PHP_EOL$issues)) . PHP_EOL.PHP_EOL;
        }
    }
    
trigger_error(
        
'Composer detected issues in your platform: ' implode(' '$issues),
        
E_USER_ERROR
    
);
}

In the equivalent 1.4.11 download, it checks for v5.4.8:

Code: [Select]
<?php

// platform_check.php @generated by Composer

$issues = array();

if (!(
PHP_VERSION_ID >= 50408)) {
    
$issues[] = 'Your Composer dependencies require a PHP version ">= 5.4.8". You are running ' PHP_VERSION '.';
}

if (
$issues) {
    if (!
headers_sent()) {
        
header('HTTP/1.1 500 Internal Server Error');
    }
    if (!
ini_get('display_errors')) {
        if (
PHP_SAPI === 'cli' || PHP_SAPI === 'phpdbg') {
            
fwrite(STDERR'Composer detected issues in your platform:' PHP_EOL.PHP_EOL implode(PHP_EOL$issues) . PHP_EOL.PHP_EOL);
        } elseif (!
headers_sent()) {
            echo 
'Composer detected issues in your platform:' PHP_EOL.PHP_EOL str_replace('You are running '.PHP_VERSION.'.'''implode(PHP_EOL$issues)) . PHP_EOL.PHP_EOL;
        }
    }
    
trigger_error(
        
'Composer detected issues in your platform: ' implode(' '$issues),
        
E_USER_ERROR
    
);
}

Am I safe to replace the roundcube 1.5 version of platform_check.php with the older roundcube 1.4.11 version of the file?
« Last Edit: March 26, 2021, 08:34:20 AM by chaser »

Offline alec

  • Hero Member
  • *****
  • Posts: 1,239
Re: Error Upgrading to Roundcube 1.5
« Reply #6 on: March 26, 2021, 10:07:57 AM »

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Re: Error Upgrading to Roundcube 1.5
« Reply #7 on: March 26, 2021, 10:35:07 AM »
Thank you. I'll hold off attempting to upgrade to 1.5-beta until that's been looked into and addressed.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,239
Re: Error Upgrading to Roundcube 1.5
« Reply #8 on: March 27, 2021, 09:13:07 AM »
A workaround might be to execute `composer update --ignore-platform-reqs` before bin/installto.sh, but I didn't try this.

Offline chaser

  • Jr. Member
  • **
  • Posts: 12
Re: Error Upgrading to Roundcube 1.5
« Reply #9 on: March 29, 2021, 06:22:44 AM »
Hmm. That didn't seem to work. I hope it hasn't broken anything else!

Code: [Select]
[root@mylinuxbox roundcubemail-1.5-beta]# composer update --ignore-platform-reqs


  [UnexpectedValueException]
  Unknown package has no name defined ([{"name":"endroid\/qr-code","version":"1.6.6","version_normalized":"1.6.6.0","
  source":{"type":"git","url":"https:\/\/github.com\/endroid\/qr-code.git","reference":"cef5d5b7b904d7bb0708eb744c353
  16364b65fa0"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/endroid\/qr-code\/zipball\/cef5d5b7b904d
  7bb0708eb744c35316364b65fa0","reference":"cef5d5b7b904d7bb0708eb744c35316364b65fa0","shasum":""},"require":{"ext-gd
  ":"*","php":">=5.3.0"},"time":"2016-05-29T07:37:18+00:00","type":"library","extra":{"branch-alias":{"dev-master":"1
  .x-dev"}},"installation-source":"dist","autoload":{"psr-4":{"Endroid\\QrCode\\":"src\/"}},"notification-url":"https
  :\/\/packagist.org\/downloads\/","license":["MIT"],"authors":[{"name":"Jeroen van den Enden","email":"info@endroid.
  nl","homepage":"http:\/\/endroid.nl\/"}],"description":"Endroid QR Code","homepage":"https:\/\/github.com\/endroid\
  /QrCode","keywords":["code","endroid","qr","qrcode"],"support":{"issues":"https:\/\/github.com\/endroid\/qr-code\/i
  ssues","source":"https:\/\/github.com\/endroid\/qr-code\/tree\/1.6.6"},"install-path":"..\/endroid\/qr-code"},{"nam
  e":"guzzlehttp\/guzzle","version":"6.5.5","version_normalized":"6.5.5.0","source":{"type":"git","url":"https:\/\/gi
  thub.com\/guzzle\/guzzle.git","reference":"9d4290de1cfd701f38099ef7e183b64b4b7b0c5e"},"dist":{"type":"zip","url":"h
  ttps:\/\/api.github.com\/repos\/guzzle\/guzzle\/zipball\/9d4290de1cfd701f38099ef7e183b64b4b7b0c5e","reference":"9d4
  290de1cfd701f38099ef7e183b64b4b7b0c5e","shasum":""},"require":{"ext-json":"*","guzzlehttp\/promises":"^1.0","guzzle
  http\/psr7":"^1.6.1","php":">=5.5","symfony\/polyfill-intl-idn":"^1.17.0"},"require-dev":{"ext-curl":"*","phpunit\/
  phpunit":"^4.8.35 || ^5.7 || ^6.4 || ^7.0","psr\/log":"^1.1"},"suggest":{"psr\/log":"Required for using the Log mid
  dleware"},"time":"2020-06-16T21:01:06+00:00","type":"library","extra":{"branch-alias":{"dev-master":"6.5-dev"}},"in
  stallation-source":"dist","autoload":{"psr-4":{"GuzzleHttp\\":"src\/"},"files":["src\/functions_include.php"]},"not
  ification-url":"https:\/\/packagist.org\/downloads\/","license":["MIT"],"authors":[{"name":"Michael Dowling","email
  ":"mtdowling@gmail.com","homepage":"https:\/\/github.com\/mtdowling"}],"description":"Guzzle is a PHP HTTP client l
  ibrary","homepage":"http:\/\/guzzlephp.org\/","keywords":["client","curl","framework","http","http client","rest","
  web service"],"support":{"issues":"https:\/\/github.com\/guzzle\/guzzle\/issues","source":"https:\/\/github.com\/gu
  zzle\/guzzle\/tree\/6.5"},"install-path":"..\/guzzlehttp\/guzzle"},{"name":"guzzlehttp\/promises","version":"1.4.0"
  ,"version_normalized":"1.4.0.0","source":{"type":"git","url":"https:\/\/github.com\/guzzle\/promises.git","referenc
  e":"60d379c243457e073cff02bc323a2a86cb355631"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/guzzle\
  /promises\/zipball\/60d379c243457e073cff02bc323a2a86cb355631","reference":"60d379c243457e073cff02bc323a2a86cb355631
  ","shasum":""},"require":{"php":">=5.5"},"require-dev":{"symfony\/phpunit-bridge":"^4.4 || ^5.1"},"time":"2020-09-3
  0T07:37:28+00:00","type":"library","extra":{"branch-alias":{"dev-master":"1.4-dev"}},"installation-source":"dist","
  autoload":{"psr-4":{"GuzzleHttp\\Promise\\":"src\/"},"files":["src\/functions_include.php"]},"notification-url":"ht
  tps:\/\/packagist.org\/downloads\/","license":["MIT"],"authors":[{"name":"Michael Dowling","email":"mtdowling@gmail
  .com","homepage":"https:\/\/github.com\/mtdowling"}],"description":"Guzzle promises library","keywords":["promise"]
  ,"support":{"issues":"https:\/\/github.com\/guzzle\/promises\/issues","source":"https:\/\/github.com\/guzzle\/promi
  ses\/tree\/1.4.0"},"install-path":"..\/guzzlehttp\/promises"},{"name":"guzzlehttp\/psr7","version":"1.7.0","version
  _normalized":"1.7.0.0","source":{"type":"git","url":"https:\/\/github.com\/guzzle\/psr7.git","reference":"53330f475
  20498c0ae1f61f7e2c90f55690c06a3"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/guzzle\/psr7\/zipbal
  l\/53330f47520498c0ae1f61f7e2c90f55690c06a3","reference":"53330f47520498c0ae1f61f7e2c90f55690c06a3","shasum":""},"r
  equire":{"php":">=5.4.0","psr\/http-message":"~1.0","ralouphie\/getallheaders":"^2.0.5 || ^3.0.0"},"provide":{"psr\
  /http-message-implementation":"1.0"},"require-dev":{"ext-zlib":"*","phpunit\/phpunit":"~4.8.36 || ^5.7.27 || ^6.5.1
  4 || ^7.5.20 || ^8.5.8 || ^9.3.10"},"suggest":{"laminas\/laminas-httphandlerrunner":"Emit PSR-7 responses"},"time":
  "2020-09-30T07:37:11+00:00","type":"library","extra":{"branch-alias":{"dev-master":"1.7-dev"}},"installation-source
  ":"dist","autoload":{"psr-4":{"GuzzleHttp\\Psr7\\":"src\/"},"files":["src\/functions_include.php"]},"notification-u
  rl":"https:\/\/packagist.org\/downloads\/","license":["MIT"],"authors":[{"name":"Michael Dowling","email":"mtdowlin
  g@gmail.com","homepage":"https:\/\/github.com\/mtdowling"},{"name":"Tobias Schultze","homepage":"https:\/\/github.c
  om\/Tobion"}],"description":"PSR-7 message implementation that also provides common utility methods","keywords":["h
  ttp","message","psr-7","request","response","stream","uri","url"],"support":{"issues":"https:\/\/github.com\/guzzle
  \/psr7\/issues","source":"https:\/\/github.com\/guzzle\/psr7\/tree\/1.7.0"},"install-path":"..\/guzzlehttp\/psr7"},
  {"name":"kolab\/net_ldap3","version":"v1.1.3","version_normalized":"1.1.3.0","source":{"type":"git","url":"https:\/
  \/gitlab.com\/roundcube\/net_ldap3.git","reference":"e1835e36fa5d3434f9804670fc3cdd16992ec66a"},"dist":{"type":"zip
  ","url":"https:\/\/gitlab.com\/api\/v4\/projects\/roundcube%2Fnet_ldap3\/repository\/archive.zip?sha=e1835e36fa5d34
  34f9804670fc3cdd16992ec66a","reference":"e1835e36fa5d3434f9804670fc3cdd16992ec66a","shasum":""},"require":{"pear\/n
  et_ldap2":">=2.0.12","php":">=5.3.3"},"time":"2019-10-21T11:18:59+00:00","type":"library","installation-source":"di
  st","autoload":{"classmap":["lib\/"]},"notification-url":"https:\/\/packagist.org\/downloads\/","license":["GPL-3.0
  +"],"authors":[{"name":"Jeroen van Meeuwen","email":"vanmeeuwen@kolabsys.com","role":"Lead"},{"name":"Aleksander Ma
  chniak","email":"machniak@kolabsys.com","role":"Developer"},{"name":"Thomas Bruederli","email":"roundcube@gmail.com
  ","role":"Developer"}],"description":"A successor of the PEAR:Net_LDAP2 module providing advanced functionality for
   accessing LDAP directories","homepage":"http:\/\/git.kolab.org\/pear\/Net_LDAP3\/","keywords":["PEAR","ldap","vlv"
  ],"install-path":"..\/kolab\/net_ldap3"},{"name":"masterminds\/html5","version":"2.7.4","version_normalized":"2.7.4
  .0","source":{"type":"git","url":"https:\/\/github.com\/Masterminds\/html5-php.git","reference":"9227822783c75406cf
  e400984b2f095cdf03d417"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/Masterminds\/html5-php\/zipba
  ll\/9227822783c75406cfe400984b2f095cdf03d417","reference":"9227822783c75406cfe400984b2f095cdf03d417","shasum":""},"
  require":{"ext-ctype":"*","ext-dom":"*","ext-libxml":"*","php":">=5.3.0"},"require-dev":{"phpunit\/phpunit":"^4.8.3
  5"},"time":"2020-10-01T13:52:52+00:00","type":"library","extra":{"branch-alias":{"dev-master":"2.7-dev"}},"installa
  tion-source":"dist","autoload":{"psr-4":{"Masterminds\\":"src"}},"notification-url":"https:\/\/packagist.org\/downl
  oads\/","license":["MIT"],"authors":[{"name":"Matt Butcher","email":"technosophos@gmail.com"},{"name":"Matt Farina"
  ,"email":"matt@mattfarina.com"},{"name":"Asmir Mustafic","email":"goetas@gmail.com"}],"description":"An HTML5 parse
  r and serializer.","homepage":"http:\/\/masterminds.github.io\/html5-php","keywords":["HTML5","dom","html","parser"
  ,"querypath","serializer","xml"],"support":{"issues":"https:\/\/github.com\/Masterminds\/html5-php\/issues","source
  ":"https:\/\/github.com\/Masterminds\/html5-php\/tree\/2.7.4"},"install-path":"..\/masterminds\/html5"},{"name":"pe
  ar\/auth_sasl","version":"v1.1.0","version_normalized":"1.1.0.0","source":{"type":"git","url":"https:\/\/github.com
  \/pear\/Auth_SASL.git","reference":"db1ead3dc0bf986d2bab0dbc04d114800cf91dee"},"dist":{"type":"zip","url":"https:\/
  \/api.github.com\/repos\/pear\/Auth_SASL\/zipball\/db1ead3dc0bf986d2bab0dbc04d114800cf91dee","reference":"db1ead3dc
  0bf986d2bab0dbc04d114800cf91dee","shasum":""},"require":{"pear\/pear_exception":"@stable"},"require-dev":{"phpunit\
  /phpunit":"@stable"},"time":"2017-03-07T14:37:05+00:00","type":"library","installation-source":"dist","autoload":{"
  psr-0":{"Auth":".\/"}},"notification-url":"https:\/\/packagist.org\/downloads\/","include-path":[".\/"],"license":[
  "BSD"],"authors":[{"name":"Anish Mistry","email":"amistry@am-productions.biz","role":"Lead"},{"name":"Richard Heyes
  ","email":"richard@php.net","role":"Lead"},{"name":"Michael Bretterklieber","email":"michael@bretterklieber.com","r
  ole":"Lead"}],"description":"Abstraction of various SASL mechanism responses","support":{"issues":"http:\/\/pear.ph
  p.net\/bugs\/search.php?cmd=display&package_name[]=Auth_SASL","source":"https:\/\/github.com\/pear\/Auth_SASL"},"in
  stall-path":"..\/pear\/auth_sasl"},{"name":"pear\/console_commandline","version":"v1.2.3","version_normalized":"1.2
  .3.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Console_CommandLine.git","reference":"331b295d00c9f
  a2dae30fe14538d430d72d954c6"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/pear\/Console_CommandLin
  e\/zipball\/331b295d00c9fa2dae30fe14538d430d72d954c6","reference":"331b295d00c9fa2dae30fe14538d430d72d954c6","shasu
  m":""},"require":{"ext-dom":"*","ext-xml":"*","pear\/pear_exception":"^1.0.0","php":">=5.3.0"},"require-dev":{"phpu
  nit\/phpunit":"*"},"time":"2020-04-16T15:04:15+00:00","type":"library","installation-source":"dist","autoload":{"ps
  r-0":{"Console":".\/"},"exclude-from-classmap":["tests\/"]},"notification-url":"https:\/\/packagist.org\/downloads\
  /","include-path":[""],"license":["MIT"],"authors":[{"name":"Richard Quadling","email":"rquadling@gmail.com"},{"nam
  e":"David Jean Louis","email":"izimobil@gmail.com"}],"description":"A full featured command line options and argume
  nts parser.","homepage":"https:\/\/github.com\/pear\/Console_CommandLine","keywords":["console"],"support":{"issues
  ":"http:\/\/pear.php.net\/bugs\/search.php?cmd=display&package_name[]=Console_CommandLine","source":"https:\/\/gith
  ub.com\/pear\/Console_CommandLine"},"install-path":"..\/pear\/console_commandline"},{"name":"pear\/console_getopt",
  "version":"v1.4.3","version_normalized":"1.4.3.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Console
  _Getopt.git","reference":"a41f8d3e668987609178c7c4a9fe48fecac53fa0"},"dist":{"type":"zip","url":"https:\/\/api.gith
  ub.com\/repos\/pear\/Console_Getopt\/zipball\/a41f8d3e668987609178c7c4a9fe48fecac53fa0","reference":"a41f8d3e668987
  609178c7c4a9fe48fecac53fa0","shasum":""},"time":"2019-11-20T18:27:48+00:00","type":"library","installation-source":
  "dist","autoload":{"psr-0":{"Console":".\/"}},"notification-url":"https:\/\/packagist.org\/downloads\/","include-pa
  th":[".\/"],"license":["BSD-2-Clause"],"authors":[{"name":"Andrei Zmievski","email":"andrei@php.net","role":"Lead"}
  ,{"name":"Stig Bakken","email":"stig@php.net","role":"Developer"},{"name":"Greg Beaver","email":"cellog@php.net","r
  ole":"Helper"}],"description":"More info available on: http:\/\/pear.php.net\/package\/Console_Getopt","support":{"
  issues":"http:\/\/pear.php.net\/bugs\/search.php?cmd=display&package_name[]=Console_Getopt","source":"https:\/\/git
  hub.com\/pear\/Console_Getopt"},"install-path":"..\/pear\/console_getopt"},{"name":"pear\/crypt_gpg","version":"v1.
  6.4","version_normalized":"1.6.4.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Crypt_GPG.git","refer
  ence":"7aa6a2a2b0017acb7eb9adf109ee4bfee0bf1d2f"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/pear
  \/Crypt_GPG\/zipball\/7aa6a2a2b0017acb7eb9adf109ee4bfee0bf1d2f","reference":"7aa6a2a2b0017acb7eb9adf109ee4bfee0bf1d
  2f","shasum":""},"require":{"ext-mbstring":"*","pear\/console_commandline":"*","pear\/pear_exception":"*","php":">=
  5.4.8"},"require-dev":{"phpunit\/phpunit":"^4.8.36 || ^5.7.21 || ^6 || ^7"},"suggest":{"ext-posix":"May require the
   posix PHP extension"},"time":"2020-03-22T11:49:18+00:00","bin":["scripts\/crypt-gpg-pinentry"],"type":"library","i
  nstallation-source":"dist","autoload":{"classmap":["Crypt\/"]},"notification-url":"https:\/\/packagist.org\/downloa
  ds\/","include-path":[".\/"],"license":["LGPL-2.1"],"authors":[{"name":"Michael Gauthier","email":"mike@silverorang
  e.com"},{"name":"Nathan Fredrickson","email":"nathan@silverorange.com"},{"name":"Aleksander Machniak","email":"alec
  @alec.pl"}],"description":"Provides an object oriented interface to the GNU Privacy Guard (GnuPG). It requires the
  GnuPG executable to be on the system.","homepage":"https:\/\/github.com\/pear\/Crypt_GPG","keywords":["PGP","encryp
  tion","gnupg","gpg"],"support":{"issues":"http:\/\/pear.php.net\/bugs\/search.php?cmd=display&package_name[]=Crypt_
  GPG","source":"https:\/\/github.com\/pear\/Crypt_GPG"},"install-path":"..\/pear\/crypt_gpg"},{"name":"pear\/mail_mi
  me","version":"1.10.9","version_normalized":"1.10.9.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Ma
  il_Mime.git","reference":"1e7ae4e5258b6c0d385a8e76add567934245d38d"},"dist":{"type":"zip","url":"https:\/\/api.gith
  ub.com\/repos\/pear\/Mail_Mime\/zipball\/1e7ae4e5258b6c0d385a8e76add567934245d38d","reference":"1e7ae4e5258b6c0d385
  a8e76add567934245d38d","shasum":""},"require":{"pear\/pear-core-minimal":"*"},"time":"2020-06-27T08:35:27+00:00","t
  ype":"library","installation-source":"dist","autoload":{"psr-0":{"Mail":".\/"}},"notification-url":"https:\/\/packa
  gist.org\/downloads\/","include-path":[".\/"],"license":["BSD-3-clause"],"authors":[{"name":"Cipriano Groenendal","
  email":"cipri@php.net","role":"Lead"},{"name":"Aleksander Machniak","email":"alec@php.net","role":"Lead"}],"descrip
  tion":"Mail_Mime provides classes to create MIME messages","homepage":"http:\/\/pear.php.net\/package\/Mail_Mime","
  support":{"issues":"http:\/\/pear.php.net\/bugs\/search.php?cmd=display&package_name[]=Mail_Mime","source":"https:\
  /\/github.com\/pear\/Mail_Mime"},"install-path":"..\/pear\/mail_mime"},{"name":"pear\/net_ldap2","version":"v2.2.0"
  ,"version_normalized":"2.2.0.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Net_LDAP2.git","reference
  ":"38f1b22a96dfbd7ec53852f0e1e7ec1a9a5eb0e8"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/pear\/Ne
  t_LDAP2\/zipball\/38f1b22a96dfbd7ec53852f0e1e7ec1a9a5eb0e8","reference":"38f1b22a96dfbd7ec53852f0e1e7ec1a9a5eb0e8",
  "shasum":""},"require":{"ext-ldap":"*","pear\/pear-core-minimal":"^1.10.1"},"time":"2015-10-30T20:34:22+00:00","typ
  e":"library","installation-source":"dist","autoload":{"classmap":["Net\/"]},"notification-url":"https:\/\/packagist
  .org\/downloads\/","include-path":["."],"license":["LGPL-3.0"],"description":"Object oriented interface for searchi
  ng and manipulating LDAP-entries","homepage":"http:\/\/pear.php.net\/package\/Net_LDAP2","keywords":["PEAR","ldap"]
  ,"support":{"issues":"http:\/\/pear.php.net\/bugs\/search.php?cmd=display&package_name[]=Net_LDAP2","source":"https
  :\/\/github.com\/pear\/Net_LDAP2"},"install-path":"..\/pear\/net_ldap2"},{"name":"pear\/net_sieve","version":"1.4.4
  ","version_normalized":"1.4.4.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Net_Sieve.git","referenc
  e":"5bd8f14db4684f75aee468c0ff8c5ff5175f4716"},"dist":{"type":"zip","url":"https:\/\/api.github.com\/repos\/pear\/N
  et_Sieve\/zipball\/5bd8f14db4684f75aee468c0ff8c5ff5175f4716","reference":"5bd8f14db4684f75aee468c0ff8c5ff5175f4716"
  ,"shasum":""},"require":{"pear\/net_socket":"~1.2","pear\/pear-core-minimal":"~1.10"},"require-dev":{"phpunit\/phpu
  nit":"~5.7.15"},"suggest":{"pear\/auth_sasl":"Install optionally via your project's composer.json"},"time":"2018-09
  -09T07:09:54+00:00","type":"library","installation-source":"dist","autoload":{"classmap":[".\/"]},"notification-url
  ":"https:\/\/packagist.org\/downloads\/","license":["BSD-2-Clause"],"authors":[{"name":"Anish Mistry","email":"amis
  try@am-productions.biz","role":"Lead"},{"name":"Richard Heyes","email":"richard@php.net","role":"Lead"},{"name":"Ja
  n Schneider","email":"jan@horde.org","role":"Lead"},{"name":"Damian Fernandez Sosa","email":"damlists@cnba.uba.ar",
  "role":"Lead"},{"name":"Aleksander Machniak","email":"alec@alec.pl","role":"Lead"}],"description":"More info availa
  ble on: http:\/\/pear.php.net\/package\/Net_Sieve","support":{"issues":"http:\/\/pear.php.net\/bugs\/search.php?cmd
  =display&package_name[]=Net_Sieve","source":"https:\/\/github.com\/pear\/Net_Sieve"},"install-path":"..\/pear\/net_
  sieve"},{"name":"pear\/net_smtp","version":"1.9.2","version_normalized":"1.9.2.0","source":{"type":"git","url":"htt
  ps:\/\/github.com\/pear\/Net_SMTP.git","reference":"18b5dbaa049bee5f6d02c9a4318db02472e2c922"},"dist":{"type":"zip"
  ,"url":"https:\/\/api.github.com\/repos\/pear\/Net_SMTP\/zipball\/18b5dbaa049bee5f6d02c9a4318db02472e2c922","refere
  nce":"18b5dbaa049bee5f6d02c9a4318db02472e2c922","shasum":""},"require":{"pear\/net_socket":"@stable","pear\/pear-co
  re-minimal":"@stable","php":">=5.4.0"},"require-dev":{"phpunit\/phpunit":"*"},"suggest":{"pear\/auth_sasl":"Install
   optionally via your project's composer.json"},"time":"2020-08-13T01:26:09+00:00","type":"library","installation-so
  urce":"dist","autoload":{"psr-0":{"Net":".\/"}},"notification-url":"https:\/\/packagist.org\/downloads\/","include-
  path":[".\/"],"license":["BSD-2-Clause"],"authors":[{"name":"Jon Parise","email":"jon@php.net","homepage":"https:\/
  \/www.indelible.org","role":"Lead"},{"name":"Chuck Hagenbuch","email":"chuck@horde.org","role":"Lead"}],"descriptio
  n":"An implementation of the SMTP protocol","homepage":"https:\/\/pear.github.io\/Net_SMTP\/","keywords":["email","
  mail","smtp"],"support":{"issues":"https:\/\/github.com\/pear\/Net_SMTP\/issues","source":"https:\/\/github.com\/pe
  ar\/Net_SMTP"},"install-path":"..\/pear\/net_smtp"},{"name":"pear\/net_socket","version":"v1.2.2","version_normaliz
  ed":"1.2.2.0","source":{"type":"git","url":"https:\/\/github.com\/pear\/Net_Socket.git","reference":"bbe6a12bb4f705
  9dba161f6ddd43f369c0ec8d09"}

<snip>

[root@mylinuxbox roundcubemail-1.5-beta]#