Author Topic: Error Upgrading to Roundcube 1.5  (Read 2815 times)

Offline chaser

  • Jr. Member
  • **
  • Posts: 19
Re: Error Upgrading to Roundcube 1.5
« Reply #15 on: August 19, 2021, 04:51:20 AM »
Code: [Select]
  2.1. Install PHP dependencies using composer:
    - get composer from https://getcomposer.org/download/
    - rename the composer.json-dist file into composer.json
    - if you want to use LDAP address books, enable the LDAP libraries in your
      composer.json file by moving the items from "suggest" to the "require"
      section (remove the explanation texts after the version!).
    - run `php composer.phar install --no-dev`
before running composer you might want to delete the composer.lock file and the vendor dir current in the roundcube folder. composer will regenerate these.
Sorry. Only just seen your reply. I've tried that, and it did seem to update some files, but I still get the same error:

Code: [Select]
[root@freepbx webmail]# php composer.phar install --no-dev
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information
Warning from https://packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies
  - Installing roundcube/plugin-installer (0.2.0)
    Downloading: 100%

  - Installing pear/pear_exception (v1.0.2)
    Downloading: 100%

  - Installing pear/auth_sasl (v1.1.0)
    Downloading: 100%

  - Installing ralouphie/getallheaders (3.0.3)
    Downloading: 100%

  - Installing psr/http-message (1.0.1)
    Downloading: 100%

  - Installing guzzlehttp/psr7 (1.8.2)
    Downloading: 100%

  - Installing guzzlehttp/promises (1.4.1)
    Downloading: 100%

  - Installing symfony/polyfill-php72 (v1.19.0)
    Downloading: 100%

  - Installing symfony/polyfill-intl-normalizer (v1.19.0)
    Downloading: 100%

  - Installing paragonie/random_compat (v2.0.20)
    Downloading: 100%

  - Installing symfony/polyfill-php70 (v1.19.0)
    Downloading: 100%

  - Installing symfony/polyfill-intl-idn (v1.19.0)
    Downloading: 100%

  - Installing guzzlehttp/guzzle (6.5.5)
    Downloading: 100%

  - Installing pear/console_getopt (v1.4.3)
    Downloading: 100%

  - Installing pear/pear-core-minimal (v1.10.11)
    Downloading: 100%

  - Installing pear/mail_mime (1.10.10)
    Downloading: 100%

  - Installing pear/net_socket (v1.2.2)
    Downloading: 100%

  - Installing pear/net_smtp (1.9.2)
    Downloading: 100%

  - Installing pear/console_commandline (v1.2.3)
    Downloading: 100%

  - Installing pear/crypt_gpg (v1.6.5)
    Downloading: 100%

  - Installing pear/net_sieve (1.4.5)
    Downloading: 100%

  - Installing masterminds/html5 (2.7.5)
    Downloading: 100%

  - Installing endroid/qr-code (1.6.6)
    Downloading: 100%

Writing lock file
Generating autoload files
[root@freepbx webmail]# cd /tmp/roundcubemail-1.5-rc
[root@freepbx roundcubemail-1.5-rc]# ./bin/installto.sh /var/www/html/webmail
PHP Parse error:  syntax error, unexpected '?' in /tmp/roundcubemail-1.5-rc/vendor/symfony/polyfill-php72/Php72.php on line 185
Fatal error: Please check the Roundcube error log and/or server error logs for more information.
[root@freepbx roundcubemail-1.5-rc]#

Any further thoughts?

Offline alec

  • Hero Member
  • *****
  • Posts: 1,300
Re: Error Upgrading to Roundcube 1.5
« Reply #16 on: August 19, 2021, 02:17:54 PM »
Don't composer-update the old installation but the new one, i.e. run this inside of your /tmp/roundcubemail-1.5-rc

Offline elsophia

  • Newbie
  • *
  • Posts: 5
Re: Error Upgrading to Roundcube 1.5
« Reply #17 on: August 20, 2021, 04:52:06 AM »
Please kindly help,  I am having this error, "Could not save new password" whenever users are trying to change password

Offline alec

  • Hero Member
  • *****
  • Posts: 1,300
Re: Error Upgrading to Roundcube 1.5
« Reply #18 on: August 20, 2021, 04:59:11 AM »
Look into the error log!

Offline chaser

  • Jr. Member
  • **
  • Posts: 19
Re: Error Upgrading to Roundcube 1.5
« Reply #19 on: August 21, 2021, 08:10:42 AM »
Don't composer-update the old installation but the new one, i.e. run this inside of your /tmp/roundcubemail-1.5-rc
Ah. That perhaps how I managed to break my current 1.4.11 installation. Updating the Calendar and Tasklist plugs fixed that, though!

So, just to be clear, I'm trying to upgrade my 1.4.11 to the 1.5-RC version. I have untarred the complete package to /tmp/roundcubemail-1.5-rc and when I try the upgrade from that directory (./bin/installto.sh /var/www/html/webmail) it fails with the dependency error I reported previously. If I try to run the composer-update in the /tmp/roundcubemail-1.5-rc directory I get the following error:

Code: [Select]
[root@freepbx roundcubemail-1.5-rc]# php composer.phar install --no-dev
Could not open input file: composer.phar
[root@freepbx roundcubemail-1.5-rc]# ls
bin            composer.json-dist  index.php  LICENSE  program      SECURITY.md  temp
CHANGELOG.md   composer.lock       INSTALL    logs     public_html  skins        UPGRADING
composer.json  config              installer  plugins  README.md    SQL          vendor
[root@freepbx roundcubemail-1.5-rc]#

Offline chaser

  • Jr. Member
  • **
  • Posts: 19
Re: Error Upgrading to Roundcube 1.5
« Reply #20 on: December 06, 2021, 03:47:03 PM »
To close out this thread, I've just downloaded and upgraded to v1.5.1 without any problems. Thanks for fixing whatever was actually wrong  ;D.