Author Topic: 500 Internal Server Error  (Read 5436 times)

Offline exaurdon

  • Newbie
  • *
  • Posts: 4
500 Internal Server Error
« on: May 19, 2008, 09:45:19 PM »
I get a 500 internal server error with roundcube. I deleted .htaccess, nothing. Then I created a blank copy, still didn't work.

I turned off friendly errors on IE and just get a blank screen and the logs dir of roundcube is empty.

Using Apache2, Php5, and Ubuntu Server, MySql, etc.

Offline evb

  • Jr. Member
  • **
  • Posts: 34
500 Internal Server Error
« Reply #1 on: May 20, 2008, 01:38:21 AM »
If you copy a standard phpinfo.php file (to get the information about the php installation) in your root of roundcube and you call it, do you see the php information?

Offline exaurdon

  • Newbie
  • *
  • Posts: 4
500 Internal Server Error
« Reply #2 on: May 20, 2008, 02:07:33 AM »
Yeah. Just fine. I have other sites that use PHP including Serendipity and they all work fine.

Offline evb

  • Jr. Member
  • **
  • Posts: 34
500 Internal Server Error
« Reply #3 on: May 20, 2008, 04:40:54 AM »
Did you pass the installer script completely successful?

Offline exaurdon

  • Newbie
  • *
  • Posts: 4
500 Internal Server Error
« Reply #4 on: May 20, 2008, 05:06:50 AM »
Yeah, no problems during install.

Offline evb

  • Jr. Member
  • **
  • Posts: 34
500 Internal Server Error
« Reply #5 on: May 20, 2008, 06:43:50 AM »
Ok.
And you did delete all .htacces files? (just verifying :D)

And the logs of the apache server?

Offline exaurdon

  • Newbie
  • *
  • Posts: 4
500 Internal Server Error
« Reply #6 on: May 20, 2008, 06:59:30 AM »
[Tue May 20 03:55:03 2008] [error] [client 96.26.212.118] PHP Notice:  _doQuery: [Error message: Could not execute statement]\n[Last executed query: PREPARE MDB2_STATEMENT_mysq$
[Tue May 20 03:55:03 2008] [error] [client 96.26.212.118] PHP Fatal error:  Call to undefined method stdClass::parse() in /var/www/mail/program/include/main.inc on line 1241

Offline evb

  • Jr. Member
  • **
  • Posts: 34
500 Internal Server Error
« Reply #7 on: May 20, 2008, 07:13:02 AM »
Apparently there is a problem with your mysql database.
Did you create de roundcube database when in the installer script?
Was it successfull? Do you see the database and table in your mysql server?
Do you see entries in these tables?