Author Topic: Unsupported PHP version  (Read 247 times)

Offline Dan Nelson

  • Newbie
  • *
  • Posts: 3
Unsupported PHP version
« on: August 30, 2021, 09:51:09 AM »
I've upgraded from Debian 9 to 10 and now I get this error message when I try to login to Roundcube;

Unsupported PHP version. Required PHP >= 5.4 and < 8.0. You might need to manually install the phpX.Y package (for X.Y < 8.0) as well as phpX.Y-{cli,intl,json,mbstring}.

A 'php --version' command returns 7.4.
Any help would be greatly appreciated.

Dan

Offline dwasifark

  • Jr. Member
  • **
  • Posts: 11
Re: Unsupported PHP version
« Reply #1 on: August 30, 2021, 03:34:21 PM »
I've upgraded from Debian 9 to 10 and now I get this error message when I try to login to Roundcube;

Unsupported PHP version. Required PHP >= 5.4 and < 8.0. You might need to manually install the phpX.Y package (for X.Y < 8.0) as well as phpX.Y-{cli,intl,json,mbstring}.

A 'php --version' command returns 7.4.
Any help would be greatly appreciated.

I had a similar problem when upgrading from Debian 10 to 11.  It turned out to be two problems:  1) Some remnants of the old version of PHP were still installed, so there were nominally two versions of PHP on the system, and 2) The web server (nginx in my case) was trying to use the old version of php[x.x]-fpm.sock.

I would try removing PHP completely and reinstalling just the version you want, presumably 7.4.  If you're using nginx, have a look at the config files in sites-enabled and make sure the fastcgi_pass parameter specifies /var/run/php/php7.4-fpm.sock.  Also try setting up a page containing just the line <?php phpinfo(); ?> and see if you can navigate to that from your browser.