SVN Releases > Issues & Bugs

Server Error: UID THREAD: internal error occurred


I have a Virtual Machine Debian server running Roundcube with everything fine. I use this server as my primary email server. I copied the primary server to a remote host, with some network configuration change, as a backup server in case the primary server is down. Once every 4 hours, I run a rsync from the primary server to the backup server. This procedure used to work well until recently I had to rebuild the backup server.

The issue is, on the backup server, when I open the roundcube page, an error message popped up showing "Server Error: UID THREAD: internal error occurred. Refer to server log for more information. [Timestamp] (0.061 + 0.000 + 0.060 secs)." I tried to delete the dovecot.index file and let it rebuild, but that does not fix.

I have one admin user not synced, and that user account is fine without the same issue at the backup server.

Does anyone have clue on what the issue is? Thanks a lot!


OK, I figured it out. The issue is the permissions on the user's Maildir folders/files.

When I ran rsync, I ran as root with the following command:

rsync -tr sourceFolder destinationFolder

That causes all synced files/folders to be owned by root and thus cannot be read by each user, including the dovecot* files.

The fix is to add "a" to the rsync option, so to be

rsync -atr sourceFolder destinationFolder


[0] Message Index

Go to full version