Third Party Contributions > API Based Plugins

Upgrading to Global Address Book 2.01



I recently tried upgrading from Global Address Book v1.11 to v2.01, but all the contacts disappear when I do that. If I revert back, they reappear. In the v2.01 file I've set the following to match the values in v1.11:

'name' => 'Global Addresses',
'user' => 'global_addressbook_user',

Can anyone tell me what I'm doing wrong?


Check the users table in the database and see if there are 2 globaladdressbook users listed.

Ah. I had the following 3 different users listed:


I've updated the file to:

'user' => '[global_addressbook_user]',

which actually matched the username in the v1.11 config file (I had missed the square brackets when I had read it initially, duh) and that's fixed it! My contacts have re-appeared. Can I just delete the other two users from the table?

Edit 1: I've deleted the two unused global_addressbook_user entries from the table without any apparent issue!
Edit 2: I've corrected the 3 listed users in the table!



[0] Message Index

Go to full version