Author Topic: Can't send mail via Roundcube on Chrome - on Safari works fine  (Read 484 times)

Offline djreed

  • Newbie
  • *
  • Posts: 5
Can't send mail via Roundcube on Chrome - on Safari works fine
« on: December 02, 2021, 06:47:43 PM »
Hello Friends,

I'm new here so If my post is in wrong plase please forgive me. Let me know where to add.

I made a long research and haven't find any solution to my case. I found a lot of cases where users can't send email from RC. Usually problem was with server name configuration. My case seems different.

I have postfix+dovecot+rspam and roundcube.

When I login on Chrome to RC. I can do it. Messages are displayed from Inbox folder - everything seems fine. When i want to replay or create new message - JS/AJAX (?) pop-up in right lower corner appeared, and display: Connection Error (Failed to reach server). Nothing interesting in LOG information - even don't know where to start.

Safari not reporting any problem - everything works like a charm. I can see messages after login, I can send them new or replay
Same with Computer Client (Mail on Mac) - when setup, everything works.

Why then I can't send mail via RC ? Any ideas?

Here is my config.inc.php for RC

Code: [Select]
<?php

//$config = [];

$config['db_dsnw'] = 'mysql://USERNAME*:PASSWORD*@localhost/roundcube';

$config['default_host'] = 'tls://mail.domain*.com';

$config['smtp_server'] = 'tls://mail.domain*.com';

$config['smtp_port'] = 587;

$config['smtp_user'] = '%u';

$config['smtp_pass'] = '%p';

$config['support_url'] = '';

$config['product_name'] = 'Roundcube Webmail';

$config['des_key'] = 'HERE_IS_A_KEY*';

// ----------------------------------
// PLUGINS
// ----------------------------------
// List of active plugins (in plugins/ directory)
$config['plugins'] = array('managesieve','password','archive','zipdownload');
// Configure managesieve plugin
$rcmail_config['managesieve_port'] = 4190;
// Configure password plugin
$config['password_driver'] = 'sql';
$config['password_db_dsn'] = 'mysql://USER*:PASS*@localhost/postfixadmin';
$config['password_query'] = 'UPDATE mailbox SET password=%c WHERE username=%u';

// skin name: folder from skins/
$config['skin'] = 'elastic';

* - data with asterisk has been anonymized ;)

I'll appreciate any clue how to solve this problem
« Last Edit: December 02, 2021, 07:01:24 PM by djreed »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,699
    • http://SKaero.com/
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #1 on: December 02, 2021, 10:03:30 PM »
This is most likely a problem with the web server, what is the error in the browser console?

Offline djreed

  • Newbie
  • *
  • Posts: 5
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #2 on: December 03, 2021, 02:33:28 AM »
There is nothing in console - what helped me to solve a problem. No errors. Everything seems fine :(


I checked roundcube_error.log - is nothing there. Empty. In access log i can see logs - so permissions are correct i believe.

Here are my virtual_host config for apache2 directive:

Code: [Select]
<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerName mail.domain.com
ServerAlias www.mail.domain.com
ServerAdmin myemail@domain.com
DocumentRoot /var/www/html/roundcubemail/
ErrorLog ${APACHE_LOG_DIR}/roundcube_error.log
CustomLog ${APACHE_LOG_DIR}/roundcube_access.log combined

<Directory />
        Options FollowSymLinks
        AllowOverride All
</Directory>

<Directory /var/www/html/roundcubemail/>
        Options FollowSymlinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
</Directory>


Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/mail.domain.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mail.domain.com/privkey.pem
</VirtualHost>
</IfModule>

Where mail.domain.com occur, there is a real my domain ofcourse :)
« Last Edit: December 03, 2021, 02:36:29 AM by djreed »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,699
    • http://SKaero.com/
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #3 on: December 03, 2021, 03:54:48 AM »
So does the error happen when you try to go to the compose screen? I don't see any attempts to load that in the console logs you shared.

Offline djreed

  • Newbie
  • *
  • Posts: 5
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #4 on: December 03, 2021, 05:36:10 AM »
No. This error happen when I already compose message and going to send it. Just after press Send button. It look like JS dosen't work - but it somehow works because Error pop-up appered.


Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,699
    • http://SKaero.com/
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #5 on: December 03, 2021, 04:16:43 PM »
I don't see it trying to connect to the server and I don't see any JS error so I can't really give any support. Is there anyway you could PM me a test account I could try?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,699
    • http://SKaero.com/
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #6 on: December 03, 2021, 05:19:46 PM »
I've tested with the account you sent and I was able to send a email on both Chrome 96.0.4664.55 and 98.0.4744.0. Since I didn't encounter any problem I'm thinking it maybe a Chrome extension that is causing the problem, have you tired testing in Incognito?

Offline djreed

  • Newbie
  • *
  • Posts: 5
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #7 on: December 04, 2021, 02:59:52 AM »
Wow You are hero. I also did a test on Incognito mode. (I would swear that i did it on the beginning also but ... mayby not) This time I did test once again. On Incognito - message has been sent. I started to turned off extensions on my Chrome and finallu found guilty one --- Dark Mode (A global dark theme for the web
- Version 0.4.2)

Thank you for your support. Case closed at least here

P.S. Test account has been deactivated :)

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,699
    • http://SKaero.com/
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #8 on: December 04, 2021, 03:15:43 AM »
Glad the problem is resolved, I wonder how the dark mode extension managed to block a sending api request.

Offline djreed

  • Newbie
  • *
  • Posts: 5
Re: Can't send mail via Roundcube on Chrome - on Safari works fine
« Reply #9 on: December 04, 2021, 05:09:27 AM »
Don't have any idea but I reported a bug on Dark Mode Extensions developer site. We will see how situation will develop