Author Topic: Update to 1.5.2 from 1.4.11 gets internal server error  (Read 200 times)

Offline Avian2

  • Newbie
  • *
  • Posts: 2
Update to 1.5.2 from 1.4.11 gets internal server error
« on: January 02, 2022, 12:27:16 AM »
I have Roundcube installed on Ubuntu 20.04.3 LTS, with all updates. When I upgraded from 1.4.11 to 1.5.2 tonight, I get an internal server error. When I switch back to 1.4.11, the error goes away. When I look at the errors.log file, it seems to be complaining about missing classes: Spoofchecker and rcmail_oauth.

Code: [Select]
[02-Jan-2022 00:08:11 America/New_York] PHP Fatal error:  Uncaught Error: Class 'Spoofchecker' not found in /var/lib/roundcube_1.5.2/program/lib/Roundcube/rcube_spoofchecker.php:50
Stack trace:
#0 /var/lib/roundcube_1.5.2/program/actions/mail/index.php(1400): rcube_spoofchecker::check()
#1 /var/lib/roundcube_1.5.2/program/actions/mail/index.php(523): rcmail_action_mail_index::address_string()
#2 /var/lib/roundcube_1.5.2/program/actions/mail/list.php(123): rcmail_action_mail_index::js_message_list()
#3 /var/lib/roundcube_1.5.2/program/include/rcmail.php(275): rcmail_action_mail_list->run()
#4 /var/lib/roundcube_1.5.2/index.php(283): rcmail->action_handler()
#5 {main}
  thrown in /var/lib/roundcube_1.5.2/program/lib/Roundcube/rcube_spoofchecker.php on line 50
[02-Jan-2022 00:08:57 America/New_York] PHP Fatal error:  Uncaught Error: Class 'rcmail_oauth' not found in /var/lib/roundcube_1.5.2/program/include/rcmail.php:150
Stack trace:
#0 /var/lib/roundcube_1.5.2/program/include/rcmail.php(86): rcmail->startup()
#1 /var/lib/roundcube_1.5.2/index.php(43): rcmail::get_instance()
#2 {main}
  thrown in /var/lib/roundcube_1.5.2/program/include/rcmail.php on line 150

Has anyone else encountered this? How do I fix it?

Thanks,

Bob

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,657
Re: Update to 1.5.2 from 1.4.11 gets internal server error
« Reply #1 on: January 02, 2022, 03:57:49 AM »
Since version 1.5 the php-intl extension is now required as part of your PHP setup
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline Avian2

  • Newbie
  • *
  • Posts: 2
Re: Update to 1.5.2 from 1.4.11 gets internal server error
« Reply #2 on: January 02, 2022, 01:02:20 PM »
Thanks - I'd enabled it in php.ini, but didn't realize it wasn't installed. Sudo apt-get install php7.4_intl installed it and all works now.

Thanks!

Bob