Author Topic: Error in DDL upgrade  (Read 1065 times)

Offline duy_dang2110

  • Jr. Member
  • **
  • Posts: 16
Error in DDL upgrade
« on: January 30, 2022, 03:24:43 AM »
Hi , I tried to uppgrade roundcube to version 1.5.2 , but when I run the installto.sh script I got into an DDL upgrade issue . Has anyone had this issue and is there a way to fix it, thanks

NOTICE: New .htaccess file saved as .htaccess.new.
NOTICE: The 'installer' directory still exists. You should remove it after the upgrade.

Running update script at target...
Executing database schema update.
Updating database schema (2020020101)... [FAILED]
ERROR: Error in DDL upgrade 2020020101: [1025] Error on rename of './roundcubemail/cache' to './roundcubemail/#sql2-46e0-2' (errno: 152)
All done.


Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,733
Re: Error in DDL upgrade
« Reply #1 on: January 30, 2022, 05:19:28 AM »
Sounds like it could be the same as this issue. Check your existing database schema is correct.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline duy_dang2110

  • Jr. Member
  • **
  • Posts: 16
Re: Error in DDL upgrade
« Reply #2 on: January 30, 2022, 07:45:12 AM »
Sounds like it could be the same as this issue. Check your existing database schema is correct.

thank you, appreciate it