Author Topic: Managesieve Plugin appears to be broken after 1.6.0-rc upgrade  (Read 274 times)

Offline dweimer

  • Jr. Member
  • **
  • Posts: 10
    • http://www.dweimer.net/
After upgrading to 1.6.0-rc I can't use the managesieve plugin.

[27-Jun-2022 10:08:56 -0500]: <48af0189> PHP Error: This server doesn't support any authentication methods. (GET /webmail/?_task=settings&_action=plugin.managesieve)
[27-Jun-2022 10:08:56 -0500]: <48af0189> PHP Error: Unable to connect to managesieve on localhost:4190 in /usr/local/www/webmail/plugins/managesieve/lib/Roundcube/rcube_sieve_engine.php on line 221 (GET /webmail/?_task=settings&_action=plugin.managesieve)
[27-Jun-2022 10:08:56 -0500]: <48af0189> PHP Error: Not currently in AUTHORISATION state (GET /webmail/?_task=settings&_action=plugin.managesieve)

If I revert back to 1.5.3 it works fine, confirmed all settings, and tried playing around with different options but nothing appears to have any impact.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,310
Re: Managesieve Plugin appears to be broken after 1.6.0-rc upgrade
« Reply #1 on: June 27, 2022, 12:11:28 PM »
$config['managesieve_host'] = 'tls://localhost:4190';

Offline dweimer

  • Jr. Member
  • **
  • Posts: 10
    • http://www.dweimer.net/
Re: Managesieve Plugin appears to be broken after 1.6.0-rc upgrade
« Reply #2 on: June 27, 2022, 01:20:00 PM »


Thanks, that fixed it, this was set lower in the configuration file:

$config['managesieve_usetls'] = true;

I guess either that is no longer applying or the fall back port of 4190, is not working anymore.