Author Topic: Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working  (Read 412 times)

Offline DoppelMoppel

  • Newbie
  • *
  • Posts: 6
  • Roundcube fan
Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working
« on: September 08, 2022, 10:47:38 AM »
I just tried upgrading Roundcube from 1.5.3 to 1.6.0. the installto.sh script ran without errors. But when I then try to launch the Roundcube site, I get this error from apache:

Code: [Select]
[Thu Sep 08 16:40:48.460523 2022] [php7:error] [pid 140000] [client 192.168.1.2:61284] PHP Fatal error:  require(): Failed opening required '/var/www/roundcube/vendor/composer/../symfony/polyfill-php72/bootstrap.php' (include_path='/var/www/roundcube/vendor/pear/auth_sasl:/var/www/roundcube/vendor/pear/console_getopt:/var/www/roundcube/vendor/pear/net_idna2:/var/www/roundcube/vendor/pear/net_ldap2:/var/www/roundcube/vendor/pear/net_socket:/var/www/roundcube/vendor/pear/pear_exception:/var/www/roundcube/vendor/pear/pear-core-minimal/src:/var/www/roundcube/vendor/pear/console_commandline:/var/www/roundcube/vendor/pear/mail_mime:/var/www/roundcube/vendor/pear/net_smtp:/var/www/roundcube/vendor/pear/crypt_gpg:/var/www/roundcube/program/lib:.:/usr/share/php') in /var/www/roundcube/vendor/composer/autoload_real.php on line 75
Apparently I am missing the file /var/www/roundcube/vendor/composer/../symfony/polyfill-php72/bootstrap.php
Where can I get it from?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,735
Re: Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working
« Reply #1 on: September 09, 2022, 10:51:55 AM »
What version of PHP are your running? 1.6.0 requires a minimum of 7.3
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline DoppelMoppel

  • Newbie
  • *
  • Posts: 6
  • Roundcube fan
Re: Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working
« Reply #2 on: September 09, 2022, 11:36:53 AM »
Code: [Select]
# php -v
PHP 7.4.3 (cli) (built: Aug 17 2022 13:29:56) ( NTS )

That should not be a problem, I hope.

I want to do the update, because I want to bring this machine to Ubuntu 22.04 - which comes with PHP 8. Before I do this, I'm trying to make sure my sites can play along well even with PHP 8. Roundcube is the last contestant.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,735
Re: Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working
« Reply #3 on: September 10, 2022, 05:49:19 AM »
Is your web server running the same PHP version? When you did the update did you run composer update as well?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline DoppelMoppel

  • Newbie
  • *
  • Posts: 6
  • Roundcube fan
Re: Upgrade from 1.5.3 to 1.6.0 allegedly successful, but not working
« Reply #4 on: September 10, 2022, 06:24:57 AM »
Yes, the webserver runs in the same VM with the same PHP version. And yes, as suggested in the doc, I did run the composer update as well.