Author Topic: Stuck at login page  (Read 4270 times)

Offline evb

  • Jr. Member
  • **
  • Posts: 34
Stuck at login page
« on: May 16, 2008, 04:22:10 PM »
For the past week I tried to get a working roundcube installation, but no luck :(

So first my installation:
- Windows 2000 with IIS5.0
- php 5.2.5
- hmailserver 4.4.1-B273
- mysql 5.0
- roundcube 0.1.1

--> the hmailserver is working, I'm using it for the moment with a Outlook express client
--> php is working with squirrelmail

Installation of roundcube:
- did pass the installer setup without any problems : everything ok, could log to the IMAP server, could connect to the database and send a email
- first problem was the use of IIS5.0 with the http 405 problem - resource not allowed : this is a IIS5.0 bug, it is due to the form action="./" without a file name. The solution is to change every html file with action="./" to action="./index.php"
- after this I got the login page, but when logging in with my IMAP login and password, I got sql errors in the roundcube database, complaining about fields not null allowed :
       table : identities : fields 'organization', 'reply-to' set 'default' as value
field 'signature' null allowed
       table : contacts : fields 'firstname', 'surname' and 'vcard' set 'default' as value
- after this I'm still stuck at the login screen, but
--> my IMAP user is created in the roundcube database, together with a identity
--> I see a successfull login in my IMAP server, followed directly by a logout??

So I searched this forum and found several people with the same problem.
I tried the proposed solutions:
- setting session.auto_start to false (is already so in my php installation)
- changing the database driver from mdb2 to db : no change
- I did the test to see if the browser was able to set the session : was OK
- If I encode a wrong login and password, I get the message: login failed and I see an entry in the roundcube logfile : this is normal

I'm running out of ideas.
Squirrelmail is running without any problem on the same machine.
I like very much the layout of roundcube, but ....
I programmed in the past in php, but that is a long time ago.
I installed HAPEdit to look a bit in the code, but it was really long time ago :o

Offline rsfeller

  • Newbie
  • *
  • Posts: 8
any fix?
« Reply #1 on: May 17, 2008, 01:08:46 AM »
I got RoundCube to install on IIS 5.0 but cannot get past the login screen!

anything I try fails and I have no idea what is supposed to go in the server field!?!?!

Ideas?

Shawn

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,524
Stuck at login page
« Reply #2 on: May 17, 2008, 08:01:15 AM »
Quote from: rsfeller;12065

anything I try fails and I have no idea what is supposed to go in the server field!?!?!

The hostname of your imap server should go in the server field. If you only use one you can specify this in $rcmail_config['default_host'] in your config file. The box will then be removed from the login screen.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline evb

  • Jr. Member
  • **
  • Posts: 34
Stuck at login page
« Reply #3 on: May 18, 2008, 02:06:20 PM »
hello rsfeller, did you try the idea of JohnDoh?
Did it work for you?
Can you pass the login screen?

Offline evb

  • Jr. Member
  • **
  • Posts: 34
Stuck at login page
« Reply #4 on: May 19, 2008, 05:39:15 AM »
When searching this forum I found several people with the same problem.
Nobody did find a solution? They all did leave the project? :( :eek:

I'm running now SquirrelMail for the moment in the same configuration, but the layout is not very beautifull. But it works, the installation did take 5 minutes and I did no adaptation to the existing php/IIS configuration (Joomla test site already running on it) to be able to run it.
I found new layouts like NutsMail running on SquirrelMail with beautifull layouts, but they are commercial ...
Because the webmail must run at home (the goal is to be able to see the emails on any running machine for the whole family), I want to avoid that, we have already plenty of other costs :rolleyes:
But, ok, if I don't find a solution to run Roundcube, the price of the Nutsmail skins are acceptable....

Offline evb

  • Jr. Member
  • **
  • Posts: 34
Stuck at login page
« Reply #5 on: May 23, 2008, 03:41:05 PM »
I have found the problem thanks to the support pages on Squirrelmail.
Like said, I'm running on IIS5.0 (windows2000) and php 5.2.5.

PHP is configured in IIS as CGI/FASTCGI
When reading the known problems on the squirrelmail support pages, I stumbed on the Login Faild support page (http://squirrelmail.org/wiki/LoginFails)
There they where talking that sometimes users could not log in squirrelmail because php was using CGI and not ISAPI.
So I reconfigured the IIS server to use ISAPI (go to IIS, default web site, properties, tab home directory, configuration, scroll to .php and edit to use C:\PHP\php5isapi.dll.)
After that roundcube was working!   :D:D