Roundcube Community Forum


Port config changes, 1.4 -> 1.6

Started by NFG, September 08, 2023, 04:06:16 AM

Previous topic - Next topic


I recently updated from an antiquated 1.4.x to 1.6.2, and to my surprise, I couldn't send emails anymore.  I dove into the config, searched for all the answers, and beat my head against a problem that couldn't be solved.

The error was basically unhelpful, the error logs didn't include anything beyond 'couldn't connect'.  TLS wouldn't connect to the server at all (the server saw no attempt made) and SSL would connect, but the server reported 'SSL direct-connect failure from <IP>'. 

Debug logs didn't help, and it wasn't until I noticed that it was attempting to connect on port 465 (which I don't use at all) instead of the port I told it to use (125, for legacy reasons) that I realized it was ignoring the port I set.  My old 1.4 config had this:

$config['smtp_server'] = '[IP ADDRESS]';
$config['smtp_port'] = 125;

But 1.6 ignored the smtp_port option entirely.  The thing that finally worked, was this:

$config['smtp_server'] = '[IP ADDRESS]:125';

I didn't feel like wasting that hour, but I did feel pretty awesome when I finally kicked this thing's ass back into line.

Anyway, that happened.  Thought you might want to know.  ¯\_(ツ)_/¯