Author Topic: RC w/ 1&1 Socket Error  (Read 4829 times)

Offline abisconti3

  • Newbie
  • *
  • Posts: 2
RC w/ 1&1 Socket Error
« on: March 19, 2008, 10:34:29 PM »
Hello,
I am attempting to install Roundcube on a 1&1 shared hosting account. I am following the installer and everything is OK except for sockets. Support keeps telling me something about being able to enable them using a directive in the php.ini file but they don't know how to do it. Any ideas how I can fix the socket issue? Thanks.

Offline igor

  • Jr. Member
  • **
  • Posts: 13
Re: RC w/ 1&1 Socket Error
« Reply #1 on: March 20, 2008, 01:38:13 AM »
some issue on all-inkl.com
but after ignoring this message by changing index.php?_step=1 to index.php?_step=3 I could test the socket connection with an refused on ssl and an php_error without ssl (but the socket connection was successful)
Quote

Fatal error: Call to undefined function decrypt_passwd() in /www/htdocs/mail/nightlymail/program/include/rcube_smtp.inc on line 105

so I change to the latest svn-version and theres no socket warning in the installer (theres no point socket ;-) )
but again the problem with decrypt_passwd()

so try the latest svn version, maybe it works
« Last Edit: June 21, 2008, 05:42:00 AM by igor »

Offline cdubouloz

  • Newbie
  • *
  • Posts: 3
Re: RC w/ 1&1 Socket Error
« Reply #2 on: March 22, 2008, 05:45:58 PM »
Hi abisconti3,

I've the same problem ???, and tried with the last svn and get still the same error :(.

It's works for you now with the svn version?

Thanks,

Cédric Dubouloz

Offline till

  • Jr. Member
  • **
  • Posts: 49
Re: RC w/ 1&1 Socket Error
« Reply #3 on: March 22, 2008, 05:54:27 PM »
If you configure smtp auth, you will need to supply a test user for the installer to try it.

Did you guys do that, or not?

Offline igor

  • Jr. Member
  • **
  • Posts: 13
Re: RC w/ 1&1 Socket Error
« Reply #4 on: March 23, 2008, 05:22:22 AM »
I'm using my normal E-Mail-User for testing it, with the regular pw

Offline cdubouloz

  • Newbie
  • *
  • Posts: 3
Re: RC w/ 1&1 Socket Error
« Reply #5 on: March 24, 2008, 05:45:46 PM »
Quote from: cdubouloz
Hi abisconti3,

I've the same problem ???, and tried with the last svn and get still the same error :(.

It's works for you now with the svn version?

Thanks,



Hi till

It can be due to the fact that mcrypt is not installed?
Cédric Dubouloz

Offline cdubouloz

  • Newbie
  • *
  • Posts: 3
Re: RC w/ 1&1 Socket Error
« Reply #6 on: March 24, 2008, 06:01:06 PM »
Cédric Dubouloz

Offline dansloan

  • Newbie
  • *
  • Posts: 3
RC w/ 1&1 Socket Error
« Reply #7 on: July 31, 2008, 04:49:20 PM »
I am using 1 and 1 and am having the same issue, but...

I went on to the step two ( I had to type 2 into the address bar) and everything seem to be working.

I can't get that link to work.(http://roundcubeforum.net/forum/inde...11172#msg11172 )