Author Topic: Sending  (Read 2891 times)

Offline Deftone

  • Newbie
  • *
  • Posts: 3
Sending
« on: August 10, 2006, 06:49:36 AM »
Friends,

I just upgraded de round Cube to the latest beta and I have problems wirth sending mails.
Every e-mail I try to send I get faild sending mail?
What did I wrong.

Here is de code

Code: [Select]
// system error reporting: 1 = log; 2 = report (not implemented yet), 4 = show, 8 = trace
$rcmail_config['debug_level'] = 1;

// enable caching of messages and mailbox data in the local database.
// this is recommended if the IMAP server does not run on the same machine
$rcmail_config['enable_caching'] = TRUE;

// lifetime of message cache
// possible units: s, m, h, d, w
$rcmail_config['message_cache_lifetime'] = '10d';

// automatically create a new RoundCube user when log-in the first time.
// a new user will be created once the IMAP login succeeds.
// set to false if only registered users can use this service
$rcmail_config['auto_create_user'] = TRUE;

// the mail host chosen to perform the log-in
// leave blank to show a textbox at login, give a list of hosts
// to display a pulldown menu or set one host as string.
// To use SSL connection, enter ssl://hostname:993
$rcmail_config['default_host'] = array('mail.domain.com', 'mail.domain.com', 'mail.domain.com');

// TCP port used for IMAP connections
$rcmail_config['default_port'] = 143;

Offline Deftone

  • Newbie
  • *
  • Posts: 3
Re: Sending
« Reply #1 on: August 10, 2006, 07:49:24 AM »
When I look into the error log I see this one

Code: [Select]
[10-Aug-2006 13:40:42] PHP Warning: in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in /home/test/domains/domain.com/public_html/post/program/include/main.inc on line 1367
Line 1367 is

Code: [Select]
 
if (in_array($attrib['command'], $MAIN_TASKS))


Offline area51

  • Newbie
  • *
  • Posts: 8
Re: Sending
« Reply #2 on: August 15, 2006, 11:36:32 PM »
ok guys im kinda new at this so bear with me i have roundcube beta 2 installed to rcmail.area51web.net ok i and do anything i need but when i send mail it says it failed now there is something in the config files for virtual something

// Path to a virtuser table file to resolve user names and e-mail addresses
$rcmail_config['virtuser_file'] = '';

// Query to resolve user names and e-mail addresses from the database
// %u will be replaced with the current username for login.
// The query should select the user's e-mail address as first col
$rcmail_config['virtuser_query'] = '';

do i need to do saomething to these variables

i have courier-imap on my suse 10 dedicated server with plesk 8 on it to shed some more light on the subjest i am a beginning adminstrator so bare with me here