Author Topic: Problem by installation  (Read 4263 times)

Offline stefan-becker

  • Newbie
  • *
  • Posts: 5
Problem by installation
« on: September 12, 2008, 01:05:52 PM »
Hi,

i have a new server and so i want to install rc on the new server. It's version 0.2. But the installer said, that "iilConnection:  NOT OK(Failed to load lib/imap.inc)". The file is available on /program/lib. What's the problem?

Best regards,

Stefan
« Last Edit: September 12, 2008, 07:03:27 PM by stefan-becker »

Offline stefan-becker

  • Newbie
  • *
  • Posts: 5
Problem by installtion
« Reply #1 on: September 14, 2008, 01:49:42 PM »
Ok, i have copy the folder lib in the root folder. I have zero errors, but on the next page i get this error:

product_name
    Fatal error: Class 'html_inputfield' not found in /usr/share/psa-horde/installer/config.php on line 74

What's that?

Stefan

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
Problem by installtion
« Reply #2 on: September 16, 2008, 05:37:46 AM »
You need PHP 5.2.x. ".htaccess" files must be allowed. Also check your include_path settings in php.ini. PHP function "set_include_path" must be enabled.

iniset.php
Code: [Select]

// RC include folders MUST be included FIRST to avoid other
// possible not compatible libraries (i.e PEAR) to be included
// instead the ones provided by RC
$include_path = INSTALL_PATH . PATH_SEPARATOR;
$include_path.= INSTALL_PATH . 'program' . PATH_SEPARATOR;
$include_path.= INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
$include_path.= INSTALL_PATH . 'program/include' . PATH_SEPARATOR;
$include_path.= ini_get('include_path');

if (set_include_path($include_path) === false) {
  die('Fatal error: ini_set/set_include_path does not work.');
}


See the code above which is responsible for correct includes. You can't just modify the folder structure ...

-Roland
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline stefan-becker

  • Newbie
  • *
  • Posts: 5
Problem by installtion
« Reply #3 on: September 17, 2008, 06:55:22 AM »
OK, i have found a problem with the .htaccess file in this folder. Ok i've enabled .htaccess for tis folder. But i didn't found set_include_path in bei php.ini. I've PHP 5.2.6.

I found this Forum http://forum.webhostlist.de/forum/3-x-allgemein/95732-probleme-mit-set_include_path-und-confixx_mhost-conf.html and than this Articel on http://trac.roundcube.net/ticket/1484675

So, Roundcube doesn't work with PHP 5.2.6? This is not a plus for Roundcube!

Best regards

Stefan
« Last Edit: September 17, 2008, 04:46:45 PM by stefan-becker »