Author Topic: Login Failed?!  (Read 1884 times)

Offline ridgedale

  • Newbie
  • *
  • Posts: 3
Login Failed?!
« on: November 10, 2008, 04:35:41 PM »
I have an installation running in a customer's hosting account with Powweb. The installation appeared to be processed without any error/problem. However whenever a user tries to login to their mail account they eventually get a Login Failed error message.

I have checked the config files to see that they are consistent with another installation I have running one of Powweb's other servers and can see nothing that is inconsistent.

Even with system error reporting set to:

Code: [Select]
$rcmail_config['debug_level'] = 8;

... there are no errors!

I would be grateful for any pointers that might help to resolve the issue.

The version of RoundCube provided by Powweb is v.0.1-beta, btw.

Thanks in advance.

Offline JabbaTek

  • Jr. Member
  • **
  • Posts: 20
Login Failed?!
« Reply #1 on: November 10, 2008, 04:42:17 PM »
Is this attempt the first time you have tried to login into RoundCube since installing it?  What database engine are you using (i.e. MySQL, MSSQL, etc)

Offline ridgedale

  • Newbie
  • *
  • Posts: 3
Login Failed?!
« Reply #2 on: November 11, 2008, 02:05:24 AM »
Thanks for your reply, JabbaTek.

I have repeatedly tried to login since installing RoundCube (- Powweb's automated install script where I just had to fill out a few fields and click install) using any of the active email accounts which are all working with SquirrelMail. The database is MySQL v.5.0.45, and the installed Perl is v.5.8.8 and PHP is v.4.4.7. All running on a Debian Linux server.

It almost appears to me that the accounts are not being created in the MySQL database even though the auto create user code in main.inc.php is set to:

Code: [Select]
$rcmail_config['auto_create_user'] = TRUE;

Any pointers to resolve this would be greatly appreciated.

Offline JabbaTek

  • Jr. Member
  • **
  • Posts: 20
Login Failed?!
« Reply #3 on: November 11, 2008, 07:28:08 PM »
open up the Users table in your RoundCube database.  make sure that all of the columns except UserID are set to allow null.