Author Topic: ebay emails are not read I think it may be due to the encoding of the source.  (Read 4924 times)

Offline desertadmin

  • Jr. Member
  • **
  • Posts: 36
Hello,

It appears that ebay emails are not presented properly in the roundcube webmail with the latest fixes(Ver 281 2006-07-24). I have the latest version as of the 7.26.06 and it still does not want to open any emails from ebay.

I think the problem is that of the source code I think that it may not like ISO-8859-1

Here is the source of the email when I view it from http://www.mail2web.com .. All important information is left out of this email but the source is still in tact.

Any suggestions would be wonderful.


-DesertAdmin
-------source follows--------------

Return-path:
Received: from mx34.sjc.ebay.com (mxpool18.ebay.com [IP REMOVED]) by
 (Vircom SMTPRS 4.2.181) with SMTP id for ;
 Wed, 26 Jul 2006 13:54:47 -0600
Received: from sr-wpay002 (sr-wpay002.smf.ebay.com [IP REMOVED])
   by mx34.sjc.ebay.com (8.13.5/8.13.5) with ESMTP id k6QJs9XF018409
   for ; Wed, 26 Jul 2006 12:54:38 -0700
DomainKey-Signature: a=rsa-sha1; s=dk; d=ebay.com; c=nofws; q=dns;
   h=message-id:from:reply-to:to:subject:mime-version:
   content-type:x-ebay-mailtracker;
   b=sEmmzDnhRjXDzVZpNFoQqInPdH9i13MlF1HlUDS6eeU7rS/XLCugud7HZjmGd+GEX
   jCm1SC6dMiFOxD0zg3wvnDNg+cxXMVD0nvrG2lsbM1ZOxrT8aNJuvJ+xrYZbMtXQ3mn
   st8GtwUnAZdwh79EmuJ+kLum+yT6VfMKy2Q1nkg=
Date: Wed, 26 Jul 2006 12:54:38 -0700
Message-ID: <99744910.11539d78851.JavaMail.ebayapp@sr-wpay002>
From: "eBay Member: ebayuser"
Reply-To: reply@reply.com
To: email@email.com
Subject: Your invoice for eBay purchases - item #1d545, DALLAS MAVERICKS LARGE DIRK NOWITSKI SLEEVELESS T-SHIRT
Mime-Version: 1.0
Content-Type: multipart/alternative; boundary=1d69903.1153943678851.JavaMail.ebayapp.sr-wpay002
X-eBay-MailTracker: 10025.471.0.0

--1828469903.1153943678851.JavaMail.ebayapp.sr-wpay002
Content-Type: text/plain;charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

-----------------------------------------------------------------
eBay sent this message to NAME (NAMENAME).=20
Your registered name is included to show this message originated from eBay.=
=20
Learn more: http://pages.ebay.com/help/confidence/name-userid-emails.html
-----------------------------------------------------------------

Dear ebay customer,


Thank you for your purchase. The total for your item below is .This revised=
 invoice contains items you have purchased from OTHER NAME, but which are no=
t marked as paid yet. Click the Pay Now button to pay for all your purchase=
s now.

---REST OF EMAIL IS REMOVED------------

Offline desertadmin

  • Jr. Member
  • **
  • Posts: 36
Hmm I wonder if this is a type of XSS (http://www.cgisecurity.com/articles/xss-faq.shtml ) defense? Could it be that this is a cross site scripting prevention or something that is not allowed on the Roundcube webmail side? If I even signup with ebay and have a confirmation email sent to me it seems to just be stuck on the loading of the webpage.. eventually it will dispaly a blank page. This is the exact same situation that occurs on Firefox as well as IE6 with all of the SPs.

If any oen has an idea or a clue as to how to work around this I would be very happy to entertain any ideas as what to do.

I am an ISP admin of a small ISP and we have only a mere 900 plus email boxes with a great use of webmail. We are perfect for discovering issues because so many of our clients use webmail with good feedback.

We have tried to display the emails as text only and it seems to still hang. But when any other webmail is used like mail2web it works.

Any ideas?

-Sincerely,
DesertAdmin

Offline EricS

  • Jr. Member
  • **
  • Posts: 45
That message doesn't look like proper MIME:

Content-Type: multipart/alternative; boundary=1d69903.1153943678851.JavaMail.ebayapp.sr-wpay002
X-eBay-MailTracker: 10025.471.0.0

--1828469903.1153943678851.JavaMail.ebayapp.sr-wpay002
Content-Type: text/plain;charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable


Notice that the boundary identifier in the header doesn't match the one in the body.

Offline desertadmin

  • Jr. Member
  • **
  • Posts: 36
oops sorry whn I copied it I accidentally changed that part by accident. I was trying to remove certain parts of the email contents to keep it private but I rember accidentally fat fingering that line.

But yeah the proper number is the one with out the d in it.

-DesertAdmin

Offline trolley

  • Jr. Member
  • **
  • Posts: 19
I had the same problem with an Amazon email.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,566
    • http://SKaero.com/
This needs to be moved to Issues & Bugs

Offline desertadmin

  • Jr. Member
  • **
  • Posts: 36
Just checking in to see if any progress was made on this. It appears that their are other emails that are of html type that can not be seen. I was told that Amazon.com emaisl can not be read either. If you have this exact same problem please post and share your expernice because I.m starting to think that maybe it is just me. I have a SVN version of late July.

Thank you.
-Eric

Offline maildaemon

  • Newbie
  • *
  • Posts: 4
Please help to make roundcube devs aware of this...
« Reply #7 on: August 30, 2006, 12:40:55 AM »
There has been no progress that I can detect on solving this problem.

Its been raised a number of times in this forum under different titles
(searching for 'blank' finds some).

I've commented on my experiences to date in a few forum topics,
and raised a bug, plus added comments on another bug. I raised
the bug as high priority as it renders most email unreadable for
a lot of people.

Alas, so far I have had no luck in attracting the attention of any developers
on this one - I suspect that they dont even know its in there.

If anyone knows a Roundcube developer that they can tap on the sholder
to point out this problem, I'd really appreciate it.

(I have had a go myself but no luck so far)

Cheers.
Paul

Offline desertadmin

  • Jr. Member
  • **
  • Posts: 36
Ok well acutally the SVN revision that we are up to now is 326. Which acutally had many changes perfomed. I actually can now read emails from eBay as well as Borders and WellsFargo. We can also see amazon.com emails now. So something was fixed but now simple HTML emails are being sorta presented as blank unless you use the view source code to see the contents. I guess we traded one problem for another. But the majority of the email HTML issues have been fixed it seems.

-Sincerely,
DesertAdmin