Author Topic: RoundCube News: Release Candidate for 0.3  (Read 16245 times)

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
RoundCube News: Release Candidate for 0.3
« on: July 27, 2009, 12:00:04 PM »
After getting plenty of feedback for the plugin API which was published in version 0.3-beta we now released an almost-ready version of RoundCube. The reason why this not yet a stable release are some pervasive changes on the IMAP backend in order to improve performance. We'd like our dear users to extensively test this release candidate and submit errors to our bug tracker. The 0.3-stable release will follow soon... (0 comments)

More...
 
  

Offline sckramer

  • Jr. Member
  • **
  • Posts: 17
Error after login:
« Reply #1 on: July 28, 2009, 01:46:24 AM »
PHP Notice: Could not convert string from X-ROMAN8 to UTF-8. Make sure iconv/mbstring is installed or lib/utf8.class is available. in C:\inetpub\wwwroot\rc\roundcubemail_cds\beta\program\include\bugs.inc on line 86

not sure what this is coming from, the beta 0.3 works, its on the same machine etc... actually one level down from \beta

iis7 php 5.2.10

Thanks!

edit: I tried other accounts, then also cleared my inbox, and got logged in, but it must becoming from certain emails... I cant view some folders, etc-- red error at the top--
« Last Edit: July 28, 2009, 02:17:29 AM by sckramer »

Offline alec

  • Hero Member
  • *****
  • Posts: 1,154
RoundCube News: Release Candidate for 0.3
« Reply #2 on: July 28, 2009, 09:06:27 AM »
Quote from: sckramer;20289
PHP Notice: Could not convert string from X-ROMAN8 to UTF-8. Make sure iconv/mbstring is installed or lib/utf8.class is available. in C:\inetpub\wwwroot\rc\roundcubemail_cds\beta\program\include\bugs.inc on line 86

X-ROMAN8 must be converted to ROMAN8. In such form it's handled by iconv in my system. Fixed in r2804.

Offline sckramer

  • Jr. Member
  • **
  • Posts: 17
RoundCube News: Release Candidate for 0.3
« Reply #3 on: July 28, 2009, 01:00:12 PM »
cool, still can't view 1 folder, I can't tell what the error is... just the vague red server error at top... how do i enable logging? the main config file has it enabled, but no files are anywhere--

thanks!!

Offline sckramer

  • Jr. Member
  • **
  • Posts: 17
RoundCube News: Release Candidate for 0.3
« Reply #4 on: July 28, 2009, 01:18:23 PM »
using: svn 2804

I found the bad email... yes it's a wierd unix log email, but still... it broke it:






Return-Path: root@ams.ams.com
X-Spam-Checker-Version: SpamAssassin 3.2.3 (2007-08-08) on MD2.cdshq.local
X-Spam-Level:
X-Spam-Status: No, score=-1.8 required=6.3 tests=AWL,BAYES_00,RDNS_NONE
   shortcircuit=no autolearn=ham version=3.2.3
Received: from ams.ams.com ([68.109.239.198])
   by mail.clevelanddata.com
   ; Tue, 28 Jul 2009 01:00:13 -0400
Received: (from root@localhost) by ams.ams.com (8.7.1/8.7.1) id BAA14204 for root; Tue, 28 Jul 2009 01:00:11 -0400 (EDT)
Date: Tue, 28 Jul 2009 01:00:11 -0400 (EDT)
From: root@ams.ams.com
Message-Id: <200907280500.BAA14204@ams.ams.com>
To: root@ams.ams.com
Subject: see /var/sam/log/br_log
Mime-Version: 1.0
Content-Type: text/plain; charset=X-roman8
Content-Transfer-Encoding: 7bit

Full backup failed on ams : Tue Jul 28 01:00:10 EDT 2009 .
For more information, see the log file /var/sam/log/br_log.

Output from fbackup:

br_backup: Invoking fbackup. See /var/sam/log/br_log for details.
fbackup(1004): session begins on Tue Jul 28 01:00:09 2009
fbackup(3040): output file /dev/rmt/1m encountered an I/O error
fbackup(3019): would you like to enter a new output file?
fbackup(3004): writer aborting
fbackup(1002): Backup did not complete : Reader or Writer process exit

Offline hazlett

  • Jr. Member
  • **
  • Posts: 17
date:timezone
« Reply #5 on: July 30, 2009, 10:02:57 AM »
When installing 0.3 I get the following message and it seems my server is not able to host this version.  I have had several previous versions and am now running Roundcube very well.

################################

Checking php.ini/.htaccess settings
file_uploads:  OK
session.auto_start:  OK
zend.ze1_compatibility_mode:  OK
mbstring.func_overload:  OK
suhosin.session.encrypt:  OK
date.timezone:  NOT OK(cannot be empty and needs to be set)

###############################

I do not have access to php.ini and I would edit the htaccess file if I knew how.

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
RoundCube News: Release Candidate for 0.3
« Reply #7 on: July 30, 2009, 10:52:35 AM »
installer/check.php:

line 17:

$ini_checks 
= array('file_uploads' => 1'session.auto_start' => 0
     
'zend.ze1_compatibility_mode' => 0'mbstring.func_overload' => 0
     
'suhosin.session.encrypt' => 0'date.timezone' => '-NOTEMPTY-'); 


Remove: , 'date.timezone' => '-NOTEMPTY-'
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline bart

  • Newbie
  • *
  • Posts: 1
suhosin.session.encrypt
« Reply #8 on: July 31, 2009, 06:39:48 AM »
i would like to upgrade too - i am really enjoying roundcube! but the config sais "suhosin.session.encrypt" is set to "1" -> which should be 0..

ini_set('suhosin.session.encrypt', 1); does not seem to work on my server (for security reasons perhaps?)
(I set this in /installer/index.php right after ini_set('display_errors', 1) - if the pass would have been passed, i would write it in /index.php)

is it neccessary to have this set to 0? what happens if I remove the flag from check.php like date.timezone ?

thanks

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
RoundCube News: Release Candidate for 0.3
« Reply #9 on: August 02, 2009, 06:20:28 AM »
Posted via Mobile Device
Please contact user lacri for advice.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline Roenbaeck

  • Newbie
  • *
  • Posts: 3
RoundCube News: Release Candidate for 0.3
« Reply #10 on: August 09, 2009, 01:23:33 PM »
After upgrading from 0.2.2 to 0.3-rc1 it seems that if I open roundcubemail on mylaptop, then put it in standby for a few hours and start it again, roundcubemail will display "Server Error" instead of detecting a timed out session.

Offline mattoo

  • Newbie
  • *
  • Posts: 7
RoundCube News: Release Candidate for 0.3
« Reply #11 on: August 10, 2009, 09:16:52 AM »
same for me for both :

Quote
Checking php.ini/.htaccess settings
file_uploads:  OK
session.auto_start:  OK
zend.ze1_compatibility_mode:  OK
mbstring.func_overload:  OK
suhosin.session.encrypt:  NOT OK(is '1', should be '0')
date.timezone:  NOT OK(cannot be empty and needs to be set)


how should I proceed ? Please help, my webmail is now down... :(

Offline mattoo

  • Newbie
  • *
  • Posts: 7
RoundCube News: Release Candidate for 0.3
« Reply #12 on: August 10, 2009, 09:19:55 AM »
Quote from: Roenbaeck;20465
After upgrading from 0.2.2 to 0.3-rc1 it seems that if I open roundcubemail on mylaptop, then put it in standby for a few hours and start it again, roundcubemail will display "Server Error" instead of detecting a timed out session.


on my side it's turning to "server error" right after the opening of the main mail list

Offline Roenbaeck

  • Newbie
  • *
  • Posts: 3
RoundCube News: Release Candidate for 0.3
« Reply #13 on: August 10, 2009, 09:22:30 AM »
Forwarded mails from Apple Mail are truncated in 0.3-rc1 (and perhaps earlier versions too). Complete contents can only been viewed using "Show Source".

The source looks like this:
Code: [Select]

[... mail path etc. snipped ...]

Content-Type: multipart/alternative; boundary=Apple-Mail-8-1016496817
Mime-Version: 1.0 (Apple Message framework v936)

[... X-DSPAM-headers snipped ...]

--Apple-Mail-8-1016496817
Content-Type: text/plain;
charset=WINDOWS-1252;
format=flowed;
delsp=yes
Content-Transfer-Encoding: quoted-printable

Begrunda detta!

Vidarebefordrat brev:

> Fr=E5n: Someone <someone@somewhere.se>
> Datum: fr 3 jul 2009 14.43.18 GMT+02:00
> Till: Someone Else <someone.else@mac.com>
> =C4mne: SV: VB: Klart
>
> Ja=85 det d=E4r med ftp var inte bra.
>
> /S
>

--Apple-Mail-8-1016496817
Content-Type: text/html;
charset=WINDOWS-1252
Content-Transfer-Encoding: quoted-printable

<html><body style=3D&quot;word-wrap: break-word; -webkit-nbsp-mode: space; =
-webkit-line-break: after-white-space; &quot;>
[... lots of HTML containing the same information as above snipped ...]
<font face=3D&quot;Helvetica&quot; size=3D&quot;3&quot; =
style=3D&quot;font: 12.0px Helvetica&quot;><b>SV: VB: Klart =
</b></font></div><div style=3D&quot;margin-top: 0px; margin-right: 0px; =
margin-bottom: 0px; margin-left: 0px; min-height: 14px; &quot;><br /></div> =
</div><span class=3D&quot;Apple-style-span&quot; style=3D&quot;border-collapse: =
separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: =
medium; font-style: normal; font-variant: normal; font-weight: normal; =
letter-spacing: normal; line-height: normal; orphans: 2; text-align: =
auto; text-indent: 0px; text-transform: none; white-space: normal; =
widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; =
-webkit-border-vertical-spacing: 0px; =
-webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: =
auto; -webkit-text-stroke-width: 0px; &quot;><div lang=3D&quot;SV&quot; link=3D&quot;blue&quot; =
vlink=3D&quot;purple&quot; style=3D&quot;word-wrap: break-word; -webkit-nbsp-mode: =
space; -webkit-line-break: after-white-space; &quot;><o:smarttagtype =
namespaceuri=3D&quot;urn:schemas-microsoft-com:office:smarttags&quot; =
name=3D&quot;PersonName&quot;><div class=3D&quot;Section1&quot;><div style=3D&quot;margin-top: =
0cm; margin-right: 0cm; margin-bottom: 0.0001pt; margin-left: 0cm; =
font-size: 12pt; font-family: 'Times New Roman'; &quot;><font size=3D&quot;2&quot; =
color=3D&quot;navy&quot; face=3D&quot;Arial&quot;><span style=3D&quot;font-size: 10pt; =
font-family: Arial; color: navy; &quot;>Ja=85 det d=E4r med ftp var inte bra. =
[... lots of HTML containing the same information as above snipped ...]

--Apple-Mail-8-1016496817--


Nothing after the words "VB: Klart" is shown in the regular views of the mail (using IE 8.0.6001). My iPhone using IMAP on the same mailbox shows the mail just fine.
« Last Edit: August 10, 2009, 09:26:30 AM by Roenbaeck »

Offline Roenbaeck

  • Newbie
  • *
  • Posts: 3
RoundCube News: Release Candidate for 0.3
« Reply #14 on: August 12, 2009, 09:26:33 AM »
For several HTML-mails, clicking "Display images" does not show the actual images, only placeholders.