Roundcube Community Forum


Shortned Login username

Started by Saint, July 26, 2006, 10:32:26 AM

Previous topic - Next topic


When I want to use RoundCube I have to type in "" as my username, when I'd rather just have to type in "user". I know this isn't a problem specific to RoundCube but I think there was a similar problem where the user used the virtuser table to fix his problem.

Can I use the virtuser table to fix my problem?

Also, I can't find the virtuser table. I go to etc/ and theres just and .boxtrapper there.


Or you can use the config file:
// the mail host chosen to perform the log-in
// leave blank to show a textbox at login, give a list of hosts
// to display a pulldown menu or set one host as string.
// To use SSL connection, enter ssl://hostname:993
$rcmail_config['default_host'] = array('' => 'Domain'
'' => 'Domain 2'

// TCP port used for IMAP connections
$rcmail_config['default_port'] = 143;

// Automatically add this domain to user names for login
// Only for IMAP servers that require full e-mail addresses for login
// Specify an array with 'host' => 'domain' values to support multiple hosts
$rcmail_config['username_domain'] = array('' => '',
'' => ''

// This domain will be used to form e-mail addresses of new users
// Specify an array with 'host' => 'domain' values to support multiple hosts
$rcmail_config['mail_domain'] = array('' => '',
'' => ''

Whatever tickles your fancy...


How can you do it? If an example I have a username for login: 1111111 and the email address is, how to modify that? Does this also goes to multiple domains? Your script is great!!!


Well here's the thing:

If you want to use just the username prior to the @ symbol, use the above code.

To use an alias or different username, you'll have to use either virtuser_query or the virtuser_table entries. The virtuser table, I'm not sure about. The query would look something like:
SELECT emailaddress
FROM users
WHERE alias = '$inputalias'
LIMIT 0, 1


Thanks in advance for any help you can offer.

I am trying to append my domain the @****.org to the user name portion. We are only using RC for this domain and don't require an array. I have tried just about every combination...except for the correct one :D




I tried that method and it is shows @ ***.org when is should be ****.org. the first character is missing where is it getting the server info from... it worked when i typed the whole address before i made the change so I can't be sure.



If you only want one domain use:

$rcmail_config['default_host'] = '';
$rcmail_config['username_domain'] = '';


actually i had it wrong...i had in both places but when I changed it...I still got login failed. any other suggestions


Hmm... i'm seeing this issue too.... I'll have to take some time to track it down. My logs say the domain name I'm looking for is unavailable even though Thunderbird uses it. I'll have to look into it....