Author Topic: plugin warnings  (Read 1569 times)

Offline turqayyilmaz

  • Newbie
  • *
  • Posts: 2
plugin warnings
« on: August 06, 2009, 11:04:32 AM »
Hi;

i have install myroundcube.

i tried to setup Remote IMAP Accounts but i had that warnings

 PHP Warning:  Invalid argument supplied for foreach() in /home/detaybil/public_html/release/myplugins/collection/usersettings/functions.inc on line 262
[06-Ağu-2009 17:51:06] PHP Warning:  Invalid argument supplied for foreach() in /home/detaybil/public_html/release/myplugins/collection/usersettings/functions.inc on line 87
[06-Ağu-2009 17:51:06] PHP Warning:  in_array() [function.in-array]: Wrong datatype for second argument in /home/detaybil/public_html/release/program/include/main.inc on line 1152
[06-Ağu-2009 17:51:06] PHP Warning:  Invalid argument supplied for foreach() in /home/detaybil/public_html/release/myplugins/collection/usersettings/functions.inc on line 182

could you say how fix it?

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
plugin warnings
« Reply #1 on: August 06, 2009, 11:49:04 AM »
Either you disable logging warnings in apache (log_level) or you insert a check things passed to foreach on indicated files/lines are type array. If not skip the loop.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline turqayyilmaz

  • Newbie
  • *
  • Posts: 2
plugin warnings
« Reply #2 on: August 06, 2009, 12:03:58 PM »
Quote from: rosali;20436
Either you disable logging warnings in apache (log_level) or you insert a check things passed to foreach on indicated files/lines are type array. If not skip the loop.

i want to use plugins but i'm not using plugins for these warning?

could you help me for plugins?