Author Topic: special folders and character set issues  (Read 2116 times)

Offline exoder27

  • Newbie
  • *
  • Posts: 5
special folders and character set issues
« on: November 12, 2009, 05:35:03 PM »
I've seen similar questions come up from before, but haven't seen any ideal solutions, so I figured I'd post this separately.  I recently upgraded to .3 from .2 and ran into two major things that I'm hoping you all know how to fix.

1)  Special folder functionality seems to be turned off.  Sent and Trash both still exist for accounts, however, I have to go in and enable both through preferences so that sent messages and trash go to the right place.  I have hundreds and hundreds of users, and I'd really rather not tell them all to go and do this.  Is there an easy way to make all accounts' special folders function correctly?

2)  There seems to be some weird character set issues going on, mainly that emails from hotmail (though I know there's other places too, but hotmail has been the most prevalent) show up blank in Roundcube.  I found another post saying it was a character set issue, and had a couple fixes, but I haven't seen any specific fixes for 0.3.  Has anyone else run into that and do you know a way to fix it?

Thanks so much!

Morgan
--
Morgan Foster
morgan@agathongroup.com

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,543
    • http://SKaero.com/
special folders and character set issues
« Reply #1 on: November 12, 2009, 11:04:14 PM »
Did you use to new configuration files in /config?

Offline exoder27

  • Newbie
  • *
  • Posts: 5
special folders and character set issues
« Reply #2 on: November 13, 2009, 12:10:59 PM »
Oh good call.  I had been using the config files from my 0.2 install copied over, so I switched that up to using the 0.3 files instead, and still no good.  Same issue with special folders not being automatically set.  I see this in the config file:

--------------------------------------------------
$rcmail_config['drafts_mbox'] = 'Drafts';

// store spam messages in this mailbox
$rcmail_config['junk_mbox'] = 'Junk';

// store sent message is this mailbox
// leave blank if sent messages should not be stored
$rcmail_config['sent_mbox'] = 'Sent';

// move messages to this folder when deleting them
// leave blank if they should be deleted directly
$rcmail_config['trash_mbox'] = 'Trash';
--------------------------------------------------

but the special folders still aren't setup by default (and the character set issue is still a problem, but I don't have specific evidence at the moment).

Any ideas?

Offline exoder27

  • Newbie
  • *
  • Posts: 5
special folders and character set issues
« Reply #3 on: November 16, 2009, 05:20:28 PM »
Did anyone have any further ideas on this to help me out?  If it seems pretty localized to just me I understand, but has anyone encountered this before?  Thanks!

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,543
    • http://SKaero.com/
special folders and character set issues
« Reply #4 on: November 16, 2009, 11:19:16 PM »
I am guessing that the folders have a different name, In the table user in the database look at the preferences for a user that has setup the special folders and see what the folder name is.

Offline exoder27

  • Newbie
  • *
  • Posts: 5
special folders and character set issues
« Reply #5 on: November 19, 2009, 11:20:03 AM »
Huh, I'm likely missing something, but here's the "preferences" section from the users table of someone with the special folders enabled:

a:10:{s:16:"message_sort_col";s:4:"date";s:18:"message_sort_order";s:4:"DESC";s:8:"timezone";d:-5;s:10:"dst_active";b:1;s:8:"pagesize";i:20;s:10:"prettydate";b:1;s:11:"prefer_html";b:1;s:10:"htmleditor";b:0;s:12:"preview_pane";b:0;s:14:"draft_autosave";i:300;}

And here's one with special folders not enabled:

a:7:{s:11:"drafts_mbox";s:0:"";s:9:"sent_mbox";s:0:"";s:9:"junk_mbox";s:0:"";s:10:"trash_mbox";s:11:"INBOX.Trash";s:20:"default_imap_folders";a:2:{i:0;s:5:"INBOX";i:1;s:11:"INBOX.Trash";}s:16:"message_sort_col";s:4:"date";s:18:"message_sort_order";s:4:"DESC";}

I don't really see anything in the first one that would suggest special folders being enabled, yet they are enabled, and the second example seems to have special folder language in it, yet they are not enabled.

Could you help me decipher that?  If there's really no way to force all accounts on my server to have special folder behavior enabled, then I guess I'll just deal with it, I'm just really hoping to not have to ask all of my clients to go in and enable that.

Also, were there any further thoughts about the character set issues I mentioned?  The issue there was emails from hotmail and a couple other places showing up completely blank in roundcube.  I believe it's a character set discrepancy somewhere, but I haven't found a very good solution.  Has anyone run into that before?

Thanks so much.