Author Topic: Login Hangs  (Read 4744 times)

Offline no1tmorrow

  • Newbie
  • *
  • Posts: 1
Login Hangs
« on: September 25, 2006, 08:54:04 AM »
So I have installed it (hopefully correctly.) and when I fill in the wrong login info is gives the message login failed Authentication error... But when I enter the correct info it just sits there (waiting....) I have waited for over 5 minutes and nothing happens. Anybody have any ideas?


Thanks in Advance
Thom

Offline yllar

  • Full Member
  • ***
  • Posts: 106
Re: Login Hangs
« Reply #1 on: September 25, 2006, 02:22:21 PM »
what's in your logs ?
irc://irc.freenode.net:6667/#roundcube

Offline bfrench

  • Newbie
  • *
  • Posts: 2
Login Hangs
« Reply #2 on: January 06, 2010, 12:11:44 AM »
I have the same problem periodically.  Everything works fine for a while and then hangs on login with correct credentials.  Nothing appears in the log (roundcube or apache).  I've tried various browsers with no luck.  Sometimes clearing the session table in the db helps, other times I have to restart the apache server and then it works fine?  Again, nothing is appearing in the logs.  Were there any suggestions as to what might be the cause.

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #3 on: January 10, 2010, 04:20:46 AM »
Exact same problem here.  Everything went great during the installation.  The install reported everything as OK and happily sent test emails from the Install test page.  I can see the login page now, and I try to login with incorrect credentials and get an authentication error, but if I enter correct credentials the login page halts and loads the page endlessly.  I never see anything except a frozen login page [not completely frozen, I can still click ok, but it doesn't do squat].  Any tips?

Thanks!

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,636
    • http://SKaero.com/
Login Hangs
« Reply #4 on: January 10, 2010, 04:25:34 AM »
Can you get you enable imap_debug option in Roundcube and check logs/imap file.

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #5 on: January 10, 2010, 04:33:10 AM »
Quote from: skaero;24489
Can you get you enable imap_debug option in Roundcube and check logs/imap file.


I haven't done that but I'm using hMailServer as my email server on Windows Server 2003 and I just started a log in hMailServer and tried to log in.  I entered my correct login info for myname@mydomain.com into roundcube webmail.  Here's what I saw in hMailServer logs.  Looks like it logs out right away, not sure if this is normal.  Nothing else in the logs after 5 minutes or so and roundcube is still at the login page showing "Waiting..." down in the taskbar of the browser.

"TCPIP"   3892   "2010-01-10 01:27:03.448"   "TCPConnection - Posting AcceptEx on 0:0"
"DEBUG"   3892   "2010-01-10 01:27:03.464"   "Creating session 34"
"IMAPD"   3892   34   "2010-01-10 01:27:03.464"   "127.0.0.1"   "SENT: * OK ::Welcome::"
"IMAPD"   3892   34   "2010-01-10 01:27:03.464"   "127.0.0.1"   "RECEIVED: cp01 CAPABILITY"
"IMAPD"   3892   34   "2010-01-10 01:27:03.464"   "127.0.0.1"   "SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk[nl]cp01 OK CAPABILITY completed"
"IMAPD"   3892   34   "2010-01-10 01:27:03.464"   "127.0.0.1"   "RECEIVED: a001 LOGIN "myname@mydomain.com" ***"
"IMAPD"   3892   34   "2010-01-10 01:27:03.495"   "127.0.0.1"   "SENT: a001 OK LOGIN completed"
"IMAPD"   3892   34   "2010-01-10 01:27:03.573"   "127.0.0.1"   "RECEIVED: I LOGOUT"
"IMAPD"   3892   34   "2010-01-10 01:27:03.573"   "127.0.0.1"   "SENT: * BYE Have a nice day[nl]I OK Logout completed"
"DEBUG"   3940   "2010-01-10 01:27:03.589"   "Closing TCP/IP socket"
"DEBUG"   3940   "2010-01-10 01:27:03.589"   "Ending session 34"

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #6 on: January 11, 2010, 01:15:20 AM »
Here's the IMAP log after I enable IMAP logging and view the log after trying my correct username and password in webmail.  Still endless load.  Here's the log generated:

[10-Jan-2010 22:10:09 -0800]: S: * OK ::Welcome::
[10-Jan-2010 22:10:09 -0800]: C: cp01 CAPABILITY
[10-Jan-2010 22:10:09 -0800]: S: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk
[10-Jan-2010 22:10:09 -0800]: S: cp01 OK CAPABILITY completed
[10-Jan-2010 22:10:09 -0800]: C: a001 LOGIN "myname@mydomain.com" "***"
[10-Jan-2010 22:10:09 -0800]: S: a001 OK LOGIN completed
[10-Jan-2010 22:10:09 -0800]: C: ns1 NAMESPACE
[10-Jan-2010 22:10:09 -0800]: S: * NAMESPACE (("" ".")) NIL (("#Public" "."))
[10-Jan-2010 22:10:09 -0800]: S: ns1 OK namespace command complete
[10-Jan-2010 22:10:09 -0800]: C: ghd LIST "" ""
[10-Jan-2010 22:10:09 -0800]: S: * LIST (/NoSelect) "." ""
[10-Jan-2010 22:10:09 -0800]: S: ghd OK LIST completed
[10-Jan-2010 22:10:09 -0800]: C: I LOGOUT

Again, the back end is hMailServer.  IMAP access using my phone, email client, anything else, works great.  Just working on getting webmail to login and show me my account.

Thanks!

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,636
    • http://SKaero.com/
Login Hangs
« Reply #7 on: January 11, 2010, 01:52:39 AM »
Does it happen with the SVN?

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #8 on: January 11, 2010, 07:40:20 AM »
Quote from: skaero;24511
Does it happen with the SVN?


I must apologize, but I'm not familiar with what SVN is.  What is that and how can I find out if it works with it or not?

Thanks!

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
Login Hangs
« Reply #9 on: January 11, 2010, 07:53:08 AM »
/trunk ? Roundcube Webmail

See the "zip archive" link. Here you always find the most recent Roundcube developement version.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #10 on: January 12, 2010, 02:43:08 AM »
I'm really sorry but I can't find the download link for a zip file for those files in development from the link you gave me.  I'm still unable to login.  Exact same issues as below.  I type in the incorrect login information and I get a message at the top saying the login information wasn't right, authentication failed, but if I enter correct information, I just get stuck at an endless waiting screen.  Not sure what to do from here.  I'm really just trying to get webmail up for my hMailServer install.  Roundcube looks like the nicest designed solution by FAR so I'm really looking forward to using it.

If I do manage to get a hold of a zip file of the newer development files, did you want me to just replace the entire web app I have on my mail/web server except the 2 config files?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,636
    • http://SKaero.com/
Login Hangs
« Reply #11 on: January 12, 2010, 03:40:41 AM »
Here is a direct link to the zip: http://trac.roundcube.net/changeset/3198/trunk?old_path=%2F&format=zip upload the roundcubemail folder to your server, it would be bettor if you do a fresh install I think somethings in the database have changed.

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #12 on: January 19, 2010, 08:46:45 PM »
Problem fixed!  Turns out Roundcube was correctly configured the whole time.  The problem was our gateway's antivirus software was acting up.  I uninstalled the antivirus software and all is working perfectly.  Thanks!

Offline link470

  • Jr. Member
  • **
  • Posts: 13
Login Hangs
« Reply #13 on: April 15, 2010, 09:06:59 PM »
Fixed the problem ages ago, but forgot to come back here.  The problem was caused at my firewall level.  There was antivirus on the firewall that was scanning every request made and was slowing things down dramatically.  As soon as the antivirus software was removed, all worked perfectly.  Problem solved!

EDIT:

Wow, just realized I double posted.  I forgot the responses on the Roundcube forums were flipped upside down so I totally didn't see that I had already replied awhile ago.  My bad :D
« Last Edit: April 15, 2010, 09:09:14 PM by link470 »