Author Topic: Roundcube and PHP 5.3  (Read 4632 times)

Offline dennylin93

  • Jr. Member
  • **
  • Posts: 17
Roundcube and PHP 5.3
« on: April 12, 2010, 08:24:41 AM »
Hi, I just tried upgrading to PHP 5.3 today and RC stopped working. I'll try to debug this tomorrow when I have time.

Does anyone know if 0.3.1 supports PHP 5.3?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,385
Roundcube and PHP 5.3
« Reply #1 on: April 12, 2010, 09:04:04 AM »
I think there were some problems with 0.3.1 and PHP5.3 which were fixed in the trunk. 0.4-beta should be released in a little over a week and will include these fixes.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline dziobak

  • Full Member
  • ***
  • Posts: 184
Roundcube and PHP 5.3
« Reply #2 on: April 12, 2010, 03:21:44 PM »
svn works fine on php-5.3.2

Offline dennylin93

  • Jr. Member
  • **
  • Posts: 17
Roundcube and PHP 5.3
« Reply #3 on: April 14, 2010, 08:41:52 AM »
Thanks. I'll try out 0.4-beta when it comes out.

Offline kondybas

  • Jr. Member
  • **
  • Posts: 36
Roundcube and PHP 5.3
« Reply #4 on: April 15, 2010, 05:00:01 AM »
Quote from: JohnDoh;26736
I think there were some problems with 0.3.1 and PHP5.3 which were fixed in the trunk. 0.4-beta should be released in a little over a week and will include these fixes.


I've stuck with impossibility to attach file to the message after update to PHP 5.3.2

httpd-errors.log full of such:

[Thu Apr 15 11:27:08 2010] [error] [client 192.168.0.1] PHP Warning:  date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EEST/3.0/DST' instead in /usr/local/www/roundcube/config/main.inc.php on line 80, referer: http://192.168.0.1/mail/?_refresh=1&_mbox=INBOX&_task=mail

Offline kondybas

  • Jr. Member
  • **
  • Posts: 36
Roundcube and PHP 5.3
« Reply #5 on: April 15, 2010, 05:06:56 AM »
Quote from: dziobak;26743
svn works fine on php-5.3.2


Please point me to the working SVN. Have no possibility to wait for 0.4...

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,600
    • http://SKaero.com/
Roundcube and PHP 5.3
« Reply #6 on: April 15, 2010, 05:44:51 AM »

Offline kondybas

  • Jr. Member
  • **
  • Posts: 36
Roundcube and PHP 5.3
« Reply #7 on: April 15, 2010, 07:52:17 AM »
Quote from: skaero;26807
Here a direct link to download it: http://trac.roundcube.net/changeset/3491/trunk?old_path=%2F&format=zip


Oh, man...

You can't even imagine how desperate I was!

Thanks a million for hint and for RC at all!

Offline dennylin93

  • Jr. Member
  • **
  • Posts: 17
Roundcube and PHP 5.3
« Reply #8 on: April 24, 2010, 08:21:29 PM »
This patch should make RC 0.3.1 work with PHP 5.3: mysqli-0.3.1.php.patch.
« Last Edit: April 24, 2010, 08:26:07 PM by dennylin93 »

Offline nb91

  • Newbie
  • *
  • Posts: 9
Roundcube and PHP 5.3
« Reply #9 on: August 10, 2010, 05:03:05 AM »
Hi,

I install the last version of Roundcube 0.3.1-2 on Linux distribution (Fedora 13) but I have an issue.

In fact, when I want to log on my email box via Roundcube, I have an error message about IMAP connexion.
I see the logs and I have this message :

[09-Aug-2010 10:41:21] PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/share/pear/MDB2.php on line 2596

[09-Aug-2010 10:41:21] PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/share/pear/MDB2.php on line 2941


Roundcube works on PHP 5.3,  I don't know why I can't log on.

Thank you for your help.

Best regards

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
Roundcube and PHP 5.3
« Reply #10 on: August 10, 2010, 05:08:29 AM »
Recent version is v0.4 stable. Please update.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline nb91

  • Newbie
  • *
  • Posts: 9
Roundcube and PHP 5.3
« Reply #11 on: August 10, 2010, 05:14:42 AM »
Hi,

Yes but I want to install with package (yum) and now it's not available...