Author Topic: 0.4beta way slower than 0.3  (Read 2117 times)

Offline Granada

  • Jr. Member
  • **
  • Posts: 34
0.4beta way slower than 0.3
« on: June 08, 2010, 02:18:45 AM »
Hi everybody,

I am using two parallel installed versions of RC, one is 0.3.1 and the other is 0.4beta. Both installations have their own tables in my database and are (as far as possible) configured the same way, quite out of the box with only very few plugins enabled.
The server is not the fastest, thus showing these performance issues very well.

Logging into RC 0.3.1 gives me the message list nearly in an instant, selecting a single mail is also very fast, the preview opens right after selecting the mail. Doing the same in RC 0.4beta I can nearly wait forever until the message list appears. Selecting a single mail also takes an eternity and sometimes I get the strange error that there were no mails in the selected mailbox. Another thread here suggests that courier might have server side thread sorting disabled, but this is not the case.

What's wrong with my installation? I thought I was not that new to RC anymore ...

Regards
Ruediger

Offline Paul

  • Jr. Member
  • **
  • Posts: 12
0.4beta way slower than 0.3
« Reply #1 on: June 08, 2010, 04:25:23 AM »
Quote from: Granada;27907
Hi everybody,



Logging into RC 0.3.1 gives me the message list nearly in an instant, selecting a single mail is also very fast, the preview opens right after selecting the mail. Doing the same in RC 0.4beta I can nearly wait forever until the message list appears. Selecting a single mail also takes an eternity and sometimes I get the strange error that there were no mails in the selected mailbox. Another thread here suggests that courier might have server side thread sorting disabled, but this is not the case.


I'm having the same problems, also with a courier imap server. Opening a mail is fast in the preview pane, but slow in the full window. And the message list sometimes times out, I get the message ("No messages found in this mailbox"). There was a bugreport for this (#1486761 ("No messages found" error with courier imap) ? Roundcube Webmail), but apparently it hasn't been fixed.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,161
0.4beta way slower than 0.3
« Reply #2 on: June 08, 2010, 04:56:49 AM »
Read my comments to this ticket, also you could try to disable check_all_folders option. Finally you should try svn-trunk version.

Offline Granada

  • Jr. Member
  • **
  • Posts: 34
0.4beta way slower than 0.3
« Reply #3 on: June 08, 2010, 05:53:52 AM »
The SVN-Version runs like hell compared to 0.4beta. So the problem seems to be fixed, but I did not yet install/enable any of the plugins I usually have in use, i.e. contextmenu, remember_me, calendar and compose_addressbook. But honestly I can't imagine these plugins being responsible for any kind of slowdown.

Regards
Ruediger

Offline maras

  • Newbie
  • *
  • Posts: 2
Same here..
« Reply #4 on: June 27, 2010, 05:21:43 PM »
Hi,

Currently our company runs RC 0.3 which works perfectly despite the fact that search does not work (it is not compatible with courier). I have found the solution for the search problem - the most recent SVN version of 0.4-beta fixes the problem.

Nevertheless I confirm the problem related to slow loading of inbox contents. My account has nearly 15k e-mails. Browsing e-mails in RC 0.3 is instant, loading time for inbox is really quick. After upgrading to 0.4-beta it takes approximately 3-5 times longer.
Both versions of RC use the same config and the same database.

As far as I remember I experienced similar problems in version 0.2.

Has anyone got a solution?