Author Topic: Maximum number of connections from user+IP exceeded  (Read 5693 times)

Offline gikach

  • Newbie
  • *
  • Posts: 8
Maximum number of connections from user+IP exceeded
« on: August 21, 2010, 07:53:05 AM »
Hello,
I'm having a problem with a webmail client, trying to move some emails with  atachments  from INBOX to SPAM folders (or any other folder).
I'm getting this error:
Quote
IMAP Error: Authentication for user failed (LOGIN): "a001 NO Maximum number of connections from user+IP exceeded (mail_max_userip_connections)"

Warning: Cannot modify header information - headers already sent in /var/www/localhost/htdocs/debug/program/include/rcmail.php on line 1066

Is round cube open a new connection for every operation (at this situation for every jpg file in atachments) ?
I had to increase the max_userip_connections limit  10->50, but this not solved the problem.

Thanks for any  advice.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,232
Maximum number of connections from user+IP exceeded
« Reply #1 on: August 22, 2010, 05:33:43 AM »
looking at my logs I dont think RC would make more than 1 connection for a user at a time, unless they had multiple sessions open. when moving messages they would be done as a whole so RC would not make new connections for every jpg in the attachments.

try enabling imap_debug in /config/main.inc.php it writes a log file of all the imap communication in the logs dir may be that will show where all the connections are coming from. also your dovecot logs should show all the connections so you can match them up.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline gikach

  • Newbie
  • *
  • Posts: 8
Maximum number of connections from user+IP exceeded
« Reply #2 on: August 27, 2010, 08:56:06 AM »
Thanks for reply.
I have enabled imap_debug , and i have some questions about it. This is part of imap log file:
Quote
[27-Aug-2010 15:25:37 +0300]: S: * CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS MULTIAPPEND UNSELECT IDLE CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS AUTH=PLAIN
[27-Aug-2010 15:25:37 +0300]: S: cp01 OK Capability completed.
[27-Aug-2010 15:25:37 +0300]: C: a001 LOGIN "gikach" "*****"

****

[27-Aug-2010 15:25:37 +0300]: S: cp01 OK Capability completed.
[27-Aug-2010 15:25:37 +0300]: C: a001 LOGIN "gikach" "*****"

****

[27-Aug-2010 15:25:37 +0300]: S: cp01 OK Capability completed.
[27-Aug-2010 15:25:37 +0300]: C: a001 LOGIN "gikach" "*****"

****

[27-Aug-2010 15:25:37 +0300]: S: cp01 OK Capability completed.
[27-Aug-2010 15:25:37 +0300]: C: a001 LOGIN "gikach" "*****"
[27-Aug-2010 15:25:37 +0300]: S: cp01 OK Capability completed.
[27-Aug-2010 15:25:37 +0300]: C: a001 LOGIN "gikach" "*****"

For 18 sec (from 15:25:37 till 15:25:51) i found twenty "C: a001 LOGIN" operations. Is this normal?

Maybe something wrong with my settings? Here are some of them:
...
$rcmail_config['session_lifetime'] = 60; (minutes?)
$rcmail_config['min_keep_alive'] = 20; (sec)
$rcmail_config['email_dns_check'] = false;
$rcmail_config['keep_alive'] = 30; (sec)
...