Author Topic: smtp issues  (Read 6733 times)

Offline zizaheer

  • Newbie
  • *
  • Posts: 5
smtp issues
« on: September 20, 2010, 02:42:38 AM »
Hi there, I have installed roundcube mail on my localhost and it was working fine. When I installed it on my web server, POP3 is working fine. But to send a mail to any recipient mail client says, "Message sent succesfully". But the recipient doesnt receive any message. I have tried many times, changing different parameter in smtp setting in main config file. Please note with the same smtp configuration it was working while I was using it from my local machine (localhost). Please help me on this if you can.

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
smtp issues
« Reply #1 on: September 20, 2010, 02:50:56 AM »
Hard to help without any log snippets. Check Roundcube logs and more important check smtp logs of your SMTP service.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline zizaheer

  • Newbie
  • *
  • Posts: 5
smtp issue
« Reply #2 on: September 20, 2010, 03:51:46 PM »
Hi, I have included main.inc.php file for your consideration. Plz note, I can logon to my webmail from mywebserver. I can receive email. I can't send email using the following SMTP settings, though it says 'Message sent successfully.' But from localhost sending mail works fine with the same settings.
***********
$rcmail_config['syslog_id'] = 'roundcube';

$rcmail_config['syslog_facility'] = LOG_USER;
$rcmail_config['smtp_log'] = true;
$rcmail_config['log_logins'] = false;
$rcmail_config['sql_debug'] = false;
$rcmail_config['imap_debug'] = false;
$rcmail_config['ldap_debug'] = false;
$rcmail_config['smtp_debug'] = false;

// ----------------------------------
// IMAP is fine and working. i can logon to my webmail. only problem is, it says message sent successfully
// whereas receipient doesnt receive any message when i run it from mywebserver, but it works for localhost
// ----------------------------------

//SMTP

$rcmail_config['smtp_server'] = 'mywebserver';
$rcmail_config['smtp_port'] = 25;
$rcmail_config['smtp_user'] = 'mail@mywebserver';
$rcmail_config['smtp_pass'] = 'smtp_user password';
$rcmail_config['smtp_auth_type'] = '';
 
$rcmail_config['smtp_helo_host'] = '';

// SMTP connection timeout, in seconds. Default: 0 (no limit)
$rcmail_config['smtp_timeout'] = 0;

// no other changes made on this config file

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
smtp issues
« Reply #3 on: September 21, 2010, 12:54:44 AM »
The config looks fine to me. But I asked for a snippet from the log of your smtp server.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline zizaheer

  • Newbie
  • *
  • Posts: 5
smtp issues
« Reply #4 on: September 21, 2010, 01:55:05 AM »
Hi, Plz dont mind. Im completely new in this. Im sending u all the log files created in my Log folder: .htaccess, error and sendmail.
----------------------------------------------------------
These are the log files created in my log folder. I have modified my servername as a security measure. Plz have a look

// .htaccess ****************************

Order allow,deny
Deny from all


//errors

[19-Sep-2010 14:17:29] Invalid response code received from server (550):


[19-Sep-2010 14:17:29] Invalid response code received from server (-1):


[19-Sep-2010 14:17:29 -0400]: SMTP Error: SMTP error: Failed to set sender 'abc@mywebserver.com' in /hermes/bosweb/web290/b2907/ipg.mywebserver/webmail/program/steps/mail/func.inc on line 1425 (POST /webmail/?_task=mail&_action=send)


[19-Sep-2010 14:17:29] Invalid response code received from server (-1):


[19-Sep-2010 14:17:41] Invalid response code received from server (550):


[19-Sep-2010 14:17:41] Invalid response code received from server (-1):


[19-Sep-2010 14:17:41 -0400]: SMTP Error: SMTP error: Failed to set sender 'abc@mywebserver.com' in /hermes/bosweb/web290/b2907/ipg.mywebserver/webmail/program/steps/mail/func.inc on line 1425 (POST /webmail/?_task=mail&_action=send)


[19-Sep-2010 14:17:41] Invalid response code received from server (-1):


[19-Sep-2010 14:17:49] Invalid response code received from server (550):


[19-Sep-2010 14:17:49] Invalid response code received from server (-1):


[19-Sep-2010 14:17:49 -0400]: SMTP Error: SMTP error: Failed to set sender 'abc@mywebserver.com' in /hermes/bosweb/web290/b2907/ipg.mywebserver/webmail/program/steps/mail/func.inc on line 1425 (POST /webmail/?_task=mail&_action=send)


[19-Sep-2010 14:17:49] Invalid response code received from server (-1):


[19-Sep-2010 14:17:57] Invalid response code received from server (550):


[19-Sep-2010 14:17:57] Invalid response code received from server (-1):


[19-Sep-2010 14:17:57 -0400]: SMTP Error: SMTP error: Failed to set sender 'abc@mywebserver.com' in /hermes/bosweb/web290/b2907/ipg.mywebserver/webmail/program/steps/mail/func.inc on line 1425 (POST /webmail/?_task=mail&_action=send)


[19-Sep-2010 14:17:57] Invalid response code received from server (-1):





//Sendmail

[18-Sep-2010 16:42:56 -0400]: User abc@mywebserver.com [180.234.52.18]; Message for kz@gmail.com; 250: OK id=1Ox4FM-0006C6-AT

[18-Sep-2010 16:48:40 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for kz@gmail.com; 250: OK id=1Ox4Kv-0004pL-5e

[18-Sep-2010 16:57:57 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for zizaheer@yahoo.com; 250: OK id=1Ox4Tt-0007YV-N9

[18-Sep-2010 17:04:03 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for kz@gmail.com; 250: OK id=1Ox4Zn-0008To-SZ

[18-Sep-2010 17:06:59 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for kz@gmail.com; 250: OK id=1Ox4cc-0005Fd-PM

[18-Sep-2010 17:11:30 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for info@mywebserver.com; 250: OK id=1Ox4h0-0005PQ-2F

[18-Sep-2010 17:15:19 -0400]: User abc@mywebserver.com [180.234.55.145]; Message for kz@gmail.com; 250: OK id=1Ox4ki-00031d-Ba

[19-Sep-2010 14:10:01 -0400]: User abc@mywebserver.com [180.234.0.174]; Message for kz@gmail.com; 250: OK id=1OxOKr-0000Xd-0V

[19-Sep-2010 14:25:33 -0400]: User abc@mywebserver.com [180.234.0.174]; Message for kz@gmail.com; 250: OK id=1OxOa3-0003Rb-2Z

[19-Sep-2010 14:31:44 -0400]: User abc@mywebserver.com [180.234.0.174]; Message for kz@gmail.com; 250: OK id=1OxOfz-0005gW-Ji

[20-Sep-2010 15:40:34 -0400]: User abc@mywebserver.com [180.234.50.64]; Message for kz@gmail.com; 250: OK id=1OxmE5-0004B1-MU

Offline rosali

  • Hero Member
  • *****
  • Posts: 2,533
smtp issues
« Reply #5 on: September 21, 2010, 06:21:45 AM »
Looks like the smtp user and the identity which is used for sending mails must be the same.

Try ...

$rcmail_config['smtp_user'] = '%u';
$rcmail_config['smtp_pass'] = '%p';

I can't give more assistance without the SMPT logs of the SMTP server backend. You have posted Roundcube's client logs.
Regards,
Rosali
__________________
MyRoundcube Project (commercial)

Offline zizaheer

  • Newbie
  • *
  • Posts: 5
smtp issues
« Reply #6 on: September 25, 2010, 02:51:55 AM »
Rosali,
My site is hosted on a shared hosting server. But they are not giving me the SMTP log. I tried every way possible to make it workable. but failed. the thing is it doesn't give me error message, in stead it says, message sent successfully. but recipient doesn't receive anything. any more clue would be helpful. thanks

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,568
    • http://SKaero.com/
smtp issues
« Reply #7 on: September 25, 2010, 03:58:09 AM »
To enable SMTP logging change $rcmail_config['smtp_debug'] to true in /config/main.inc.php

Offline zizaheer

  • Newbie
  • *
  • Posts: 5
smtp issues
« Reply #8 on: October 01, 2010, 04:58:58 PM »
so here is the smtp log, if u can help me.
==============================================


[01-Oct-2010 16:09:19 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:09:15 -0400: UCE strictly prohibited
[01-Oct-2010 16:09:19 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:09:19 -0400]: Recv: 250-bosauthsmtp13.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:09:19 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:09:19 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:09:19 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:09:19 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:09:19 -0400]: Recv: 250 HELP
[01-Oct-2010 16:09:19 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:09:19 -0400]: Recv: 550 bosauthsmtp13: Host 66.96.128.68: No unauthenticated relaying permitted
[01-Oct-2010 16:09:19 -0400]: Send: RSET

[01-Oct-2010 16:10:14 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:10:14 -0400: UCE strictly prohibited
[01-Oct-2010 16:10:14 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:10:14 -0400]: Recv: 250-bosauthsmtp14.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:10:14 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:10:14 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:10:14 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:10:14 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:10:14 -0400]: Recv: 250 HELP
[01-Oct-2010 16:10:14 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:10:14 -0400]: Recv: 550 bosauthsmtp14: Host 66.96.128.68: No unauthenticated relaying permitted
[01-Oct-2010 16:10:14 -0400]: Send: RSET

[01-Oct-2010 16:10:38 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:10:37 -0400: UCE strictly prohibited
[01-Oct-2010 16:10:38 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:10:38 -0400]: Recv: 250-bosauthsmtp02.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:10:38 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:10:38 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:10:38 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:10:38 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:10:38 -0400]: Recv: 250 HELP
[01-Oct-2010 16:10:38 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:10:38 -0400]: Recv: 550 bosauthsmtp02: Host 66.96.128.68: No unauthenticated relaying permitted
[01-Oct-2010 16:10:38 -0400]: Send: RSET

[01-Oct-2010 16:12:22 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:12:22 -0400: UCE strictly prohibited
[01-Oct-2010 16:12:22 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:12:22 -0400]: Recv: 250-bosauthsmtp13.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:12:22 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:12:22 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:12:22 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:12:22 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:12:22 -0400]: Recv: 250 HELP
[01-Oct-2010 16:12:22 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:12:22 -0400]: Recv: 550 bosauthsmtp13: Host 66.96.128.68: No unauthenticated relaying permitted
[01-Oct-2010 16:12:22 -0400]: Send: RSET

[01-Oct-2010 16:30:13 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:30:13 -0400: UCE strictly prohibited
[01-Oct-2010 16:30:13 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:30:13 -0400]: Recv: 250-bosauthsmtp16.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:30:13 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:30:13 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:30:13 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:30:13 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:30:13 -0400]: Recv: 250 HELP
[01-Oct-2010 16:30:13 -0400]: Send: AUTH LOGIN
[01-Oct-2010 16:30:13 -0400]: Recv: 334 VXNlcm5hbWU6
[01-Oct-2010 16:30:13 -0400]: Send: a2F6aUBmbG94c29sdXRpb24uY29t
[01-Oct-2010 16:30:13 -0400]: Recv: 334 UGFzc3dvcmQ6
[01-Oct-2010 16:30:13 -0400]: Send: cGFsYXNoMTEyMQ==
[01-Oct-2010 16:30:13 -0400]: Recv: 235 Authentication succeeded
[01-Oct-2010 16:30:13 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:30:13 -0400]: Recv: 250 OK
[01-Oct-2010 16:30:13 -0400]: Send: RCPT TO:
[01-Oct-2010 16:30:14 -0400]: Recv: 250 Accepted
[01-Oct-2010 16:30:14 -0400]: Send: DATA
[01-Oct-2010 16:30:14 -0400]: Recv: 354 Enter message, ending with "." on a line by itself
[01-Oct-2010 16:30:15 -0400]: Send: MIME-Version: 1.0
Content-Type: text/plain;
 charset=UTF-8;
 format=flowed
Content-Transfer-Encoding: 7bit
Date: Sat, 02 Oct 2010 02:30:13 +0600
From:
To:
Subject: ff
Message-ID: <1b70858d119aa248ce0da1f925fb88e5@mysite.com>
X-Sender: kazi@mysite.com
User-Agent: Roundcube Webmail/0.4

ff

.
[01-Oct-2010 16:30:15 -0400]: Recv: 250 OK id=1P1mFD-0006vn-4m
[01-Oct-2010 16:30:15 -0400]: Send: QUIT
[01-Oct-2010 16:30:15 -0400]: Recv: 221 bosauthsmtp16.eigbox.net closing connection
[01-Oct-2010 16:35:36 -0400]: Recv: 220 ESMTP Fri, 01 Oct 2010 16:35:36 -0400: UCE strictly prohibited
[01-Oct-2010 16:35:36 -0400]: Send: EHLO mysite.com
[01-Oct-2010 16:35:36 -0400]: Recv: 250-bosauthsmtp08.eigbox.net Hello mysite.com [66.96.128.68]
[01-Oct-2010 16:35:36 -0400]: Recv: 250-SIZE 34603008
[01-Oct-2010 16:35:36 -0400]: Recv: 250-PIPELINING
[01-Oct-2010 16:35:36 -0400]: Recv: 250-AUTH PLAIN LOGIN
[01-Oct-2010 16:35:36 -0400]: Recv: 250-STARTTLS
[01-Oct-2010 16:35:36 -0400]: Recv: 250 HELP
[01-Oct-2010 16:35:36 -0400]: Send: AUTH LOGIN
[01-Oct-2010 16:35:36 -0400]: Recv: 334 VXNlcm5hbWU6
[01-Oct-2010 16:35:36 -0400]: Send: a2F6aUBmbG94c29sdXRpb24uY29t
[01-Oct-2010 16:35:36 -0400]: Recv: 334 UGFzc3dvcmQ6
[01-Oct-2010 16:35:36 -0400]: Send: cGFsYXNoMTEyMQ==
[01-Oct-2010 16:35:36 -0400]: Recv: 235 Authentication succeeded
[01-Oct-2010 16:35:36 -0400]: Send: MAIL FROM:
[01-Oct-2010 16:35:36 -0400]: Recv: 250 OK
[01-Oct-2010 16:35:36 -0400]: Send: RCPT TO:
[01-Oct-2010 16:35:37 -0400]: Recv: 250 Accepted
[01-Oct-2010 16:35:37 -0400]: Send: DATA
[01-Oct-2010 16:35:37 -0400]: Recv: 354 Enter message, ending with "." on a line by itself
[01-Oct-2010 16:35:37 -0400]: Send: MIME-Version: 1.0
Content-Type: text/plain;
 charset=UTF-8;
 format=flowed
Content-Transfer-Encoding: 7bit
Date: Sat, 02 Oct 2010 02:35:35 +0600
From:
To:
Subject: cccfdc
Message-ID: <9cc0fbe4c4f039979c34ead6e360dea9@mysite.com>
X-Sender: kazi@mysite.com
User-Agent: Roundcube Webmail/0.4

cfccf

.
[01-Oct-2010 16:35:37 -0400]: Recv: 250 OK id=1P1mKP-0007Dg-8r
[01-Oct-2010 16:35:37 -0400]: Send: QUIT
[01-Oct-2010 16:35:37 -0400]: Recv: 221 bosauthsmtp08.eigbox.net closing connection