Author Topic: MDB2 Not Ok  (Read 2273 times)

Offline adamas

  • Newbie
  • *
  • Posts: 8
MDB2 Not Ok
« on: December 30, 2010, 12:38:43 PM »
dear all

i need help you,
i have error for install roundcubemail
for error like this

Warning: include_once(MDB2.php) [function.include-once]: failed to open stream: No such file or directory in /usr/share/psa-horde/new/installer/utils.php on line 41

Warning: include_once() [function.include]: Failed opening 'MDB2.php' for inclusion (include_path='/usr/share/psa-horde:/usr/share/psa-horde/lib:/usr/share/psa-pear:.') in /usr/share/psa-horde/new/installer/utils.php on line 41
MDB2:  NOT OK(Failed to load MDB2.php; See MDB2)
Net_SMTP:  OK
Mail_mime:  OK

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,557
    • http://SKaero.com/
MDB2 Not Ok
« Reply #1 on: December 30, 2010, 01:13:37 PM »
Try installing the standard version instead of the GPL version.

Offline adamas

  • Newbie
  • *
  • Posts: 8
MDB2 Not Ok
« Reply #2 on: December 30, 2010, 01:26:28 PM »
sorry I'm newbe, how to install the standard version  with GPL

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,557
    • http://SKaero.com/
MDB2 Not Ok
« Reply #3 on: December 30, 2010, 01:49:19 PM »
There are too versions listed on the RoundCube downloads page http://roundcube.net/download try using the first version (Beta: 0.5-RC) instead of the GPL (dependent *): 0.5-RC version.

Offline adamas

  • Newbie
  • *
  • Posts: 8
MDB2 Not Ok
« Reply #4 on: December 30, 2010, 02:15:21 PM »
I try Beta: 0.5-RC
why error

Fatal error: ini_set/set_include_path does not work

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,557
    • http://SKaero.com/
MDB2 Not Ok
« Reply #5 on: December 30, 2010, 02:18:06 PM »
Your server needs to have support for set_include_path in order for RoundCube to work, if you have root access to the server you can change the setting otherwise you'll have to ask your hosting provide to change it for you.

Offline adamas

  • Newbie
  • *
  • Posts: 8
MDB2 Not Ok
« Reply #6 on: December 30, 2010, 02:30:05 PM »
i tried Beta: 0.5-RC

still error ( same with stable version)
Checking PHP version
Version:  OK(PHP 5.2.6-1+lenny9 detected)
Checking PHP extensions

The following modules/extensions are required to run Roundcube:
PCRE:  OK
DOM:  OK
Session:  OK
XML:  OK
JSON:  OK

The next couple of extensions are optional and recommended to get the best performance:
FileInfo:  NOT AVAILABLE(See PHP: Fileinfo - Manual)
Libiconv:  OK
Multibyte:  OK
OpenSSL:  OK
Mcrypt:  OK
Intl:  NOT AVAILABLE(See PHP: intl - Manual)
Checking available databases

Check which of the supported extensions are installed. At least one of them is required.
MySQL:  OK
MySQLi:  OK
PostgreSQL:  NOT AVAILABLE(Not installed)
SQLite (v2):  NOT AVAILABLE(Not installed)
Check for required 3rd party libs

This also checks if the include path is set correctly.
PEAR:  OK

Warning: include_once(MDB2.php) [function.include-once]: failed to open stream: No such file or directory in /usr/share/psa-horde/roundcube/installer/utils.php on line 41

Warning: include_once() [function.include]: Failed opening 'MDB2.php' for inclusion (include_path='/usr/share/psa-horde:/usr/share/psa-horde/lib:/usr/share/psa-pear:.') in /usr/share/psa-horde/roundcube/installer/utils.php on line 41
MDB2:  NOT OK(Failed to load MDB2.php; See MDB2)
Net_SMTP:  OK
Mail_mime:  OK
Checking php.ini/.htaccess settings

The following settings are required to run Roundcube:
file_uploads:  OK
session.auto_start:  OK
zend.ze1_compatibility_mode:  OK
mbstring.func_overload:  OK
suhosin.session.encrypt:  OK

The following settings are optional and recommended:
date.timezone:  NOT OK(Could be set)