Author Topic: update MDB2  (Read 1875 times)

Offline adamas

  • Newbie
  • *
  • Posts: 8
update MDB2
« on: December 31, 2010, 05:08:25 PM »
dear all

how about update MDB2 because pear list :


Package           Version State
Archive_Tar       1.3.2   stable
Auth              1.6.1   stable
Console_Getopt    1.2.3   stable
MDB2              2.4.1   stable
MDB2_Driver_mysql 1.4.1   stable
PEAR              1.7.1   stable
Structures_Graph  1.0.2   stable

and php versin 5.2
so,, if read INSTALL file .. need MDB2 2.5 or newer

i use pearl install pear install MDB2-2.5.0b3, error
Ignoring installed package pear/MDB2

please help me...
thanks
rasito

thanks...

Offline alec

  • Hero Member
  • *****
  • Posts: 1,155
update MDB2
« Reply #1 on: January 01, 2011, 03:02:33 AM »
Just install full package of Roundcube (not dependent) and you want need to install any package. MDB2 package developers decided to require PHP 5.3 since 2.5.0b3. So, you can install 2.5.0b2 instead.

Offline adamas

  • Newbie
  • *
  • Posts: 8
update MDB2
« Reply #2 on: January 01, 2011, 06:44:41 AM »
for MDB has been change with 2.5.0b2 but still show error

Check for required 3rd party libs

This also checks if the include path is set correctly.
PEAR:  OK

Warning: include_once(MDB2.php) [function.include-once]: failed to open stream: No such file or directory in /usr/share/psa-horde/roundcube/installer/utils.php on line 40

Warning: include_once() [function.include]: Failed opening 'MDB2.php' for inclusion (include_path='/usr/share/psa-horde:/usr/share/psa-horde/lib:/usr/share/psa-pear:.') in /usr/share/psa-horde/roundcube/installer/utils.php on line 40
MDB2:  NOT OK(Failed to load MDB2.php; See MDB2)
Net_SMTP:  OK
Mail_mime:  OK