Author Topic: Loginproblem with trunk versions after 4385  (Read 5903 times)

Offline Jack!

  • Jr. Member
  • **
  • Posts: 34
Loginproblem with trunk versions after 4385
« on: January 07, 2011, 10:40:19 AM »
If I use the newest trunk version (4398 at the moment) I can't login anymore. On the login screen it shows shortly error "Login failure" and that's it. Nothing in the log file. If I use trunk 4385 there's no problem at all.

If I use trunk 4398 and replace file "\program\include\rcube_imap_generic.php" from this version with the same file from trunk 4385, I can login again. Problem gone. Probably an issue with the "improved get_capability() syntax"? Am I overlooking something?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,397
    • http://SKaero.com/
Loginproblem with trunk versions after 4385
« Reply #1 on: January 07, 2011, 12:12:08 PM »
Enable imap_debug and post the log here.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,103
Loginproblem with trunk versions after 4385
« Reply #2 on: January 07, 2011, 03:28:23 PM »
and what do you have in imap_auth_type option.

Offline Jack!

  • Jr. Member
  • **
  • Posts: 34
Loginproblem with trunk versions after 4385
« Reply #3 on: January 07, 2011, 05:11:46 PM »
Quote from: skaero;32286
Enable imap_debug and post the log here.


If I enable imap_debug, the following entries can be seen in the imap logfile (using trunk 4398):
Code: [Select]
[07-Jan-2011 22:57:01 +0100]: S: * OK IMAPrev1
[07-Jan-2011 22:57:01 +0100]: C: A0001 CAPABILITY
[07-Jan-2011 22:57:01 +0100]: S: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk
[07-Jan-2011 22:57:01 +0100]: S: A0001 OK CAPABILITY completed
[07-Jan-2011 22:57:01 +0100]: C: A0002 LOGOUT
[07-Jan-2011 22:57:01 +0100]: S: * BYE Have a nice day
[07-Jan-2011 22:57:01 +0100]: S: A0002 OK Logout completed


Quote from: alec;32287
and what do you have in imap_auth_type option.

'imap_auth_type' has still the default value:
Code: [Select]
$rcmail_config['imap_auth_type'] = null;

Offline alec

  • Hero Member
  • *****
  • Posts: 1,103
Loginproblem with trunk versions after 4385
« Reply #4 on: January 08, 2011, 03:38:10 AM »
Fixed in r4399.

Offline Jack!

  • Jr. Member
  • **
  • Posts: 34
Loginproblem with trunk versions after 4385
« Reply #5 on: January 08, 2011, 04:46:27 AM »
Quote from: alec;32293
Fixed in r4399.

Confirmed. Thanks!