Author Topic: can't send email  (Read 2987 times)

Offline anwoke8204

  • Newbie
  • *
  • Posts: 6
can't send email
« on: November 08, 2006, 03:36:23 AM »
Hi, when after I compose email, when I click on send, now all of a sudden I get "failed to send" I have checked my email server, and it is up and running(hmailserver), and the other domains on my website(each domain has its own mail subdomain with roundcube in it)they can all send mail, it is just my rooksystems.no-ip.biz domain that can't for some reason. any ideas. thanks

Offline tomekp

  • Jr. Member
  • **
  • Posts: 11
Re: can't send email
« Reply #1 on: November 08, 2006, 08:52:44 AM »
I had a similar problem, it was saying can't send, but was sending an email, can You please check if the email was sent?
escape from the execution is futile.

Offline jdcarr

  • Newbie
  • *
  • Posts: 3
Re: can't send email
« Reply #2 on: November 09, 2006, 12:37:54 AM »
I know the exact fix. It just was happening to me.

First, in the client, create yourself an "identity" if you don't already have one. You can do this through Personal Settings (upper left) | Identities.

This will probably solve your problem, as the issue (or my issue) was that there was no sender address. Oddly, manually typing one in to the from address did no good for me.

Secondly, you probably have your hMailServer setup not to allow "empty sender addresses." Open up the administrator and go to Settings | Protocol | SMTP | Spam protection. Check the "Allow empty sender address" box.

Hope this fixes your problem.

Jason

Offline tomekp

  • Jr. Member
  • **
  • Posts: 11
Re: can't send email
« Reply #3 on: November 09, 2006, 03:59:16 AM »
It won't fix the problem, it happend once or twice to me.
I'm running OpenBSD, postfix and courier-imap.
So what do you think?
escape from the execution is futile.

Offline da_loki

  • Newbie
  • *
  • Posts: 1
Re: can't send email
« Reply #4 on: November 09, 2006, 07:55:41 AM »
I would guess, that there is a problem with your smtpd, so first check your /var/log/mail.log.

I have the problem with my SASL authentication, as I connect with RC from localhost.

Code: [Select]
Nov 9 13:49:26 lira postfix/smtpd[2805]: connect from localhost[127.0.0.1]
Nov 9 13:49:26 lira postfix/smtpd[2805]: warning: SASL authentication failure: client response doesn't match what we generated
Nov 9 13:49:26 lira postfix/smtpd[2805]: warning: localhost[127.0.0.1]: SASL DIGEST-MD5 authentication failed

Maybe your error is similar...
I'll try to get nearer to this error, because sending mails from other accounts over RC is possible O.o

Offline tomekp

  • Jr. Member
  • **
  • Posts: 11
Re: can't send email
« Reply #5 on: November 09, 2006, 01:58:35 PM »
I didn't have this type of error, i'm actually looking deeper into this, to find the problem.
escape from the execution is futile.

Offline Tobi

  • Newbie
  • *
  • Posts: 3
Re: can't send email
« Reply #6 on: November 27, 2006, 12:27:27 PM »
I just had the same error - mail sent but failure message - and I could resolve it for me.

Look here
http://roundcubeforum.net/forum/index.php?topic=950.0,
maybe this does it for you as well.