Author Topic: problems using search.  (Read 7980 times)

Offline dogman2

  • Newbie
  • *
  • Posts: 4
problems using search.
« on: March 21, 2011, 08:50:38 PM »
Hi I am new to roundcube, but so far I am impressed.  I am however having one issue I have not been able to solve.  When I try to use the search feature I receive the following error message:

Server Error: Unable to send command: A0005 SEARCH CHARSET US-ASCII OR HEADER SUBJECT {5} imail HEADER FROM {5)

I have checked the error log but cannot find any information about this problem.  I would greatly appreciate any help you can offer.
Shen

Offline alec

  • Hero Member
  • *****
  • Posts: 1,178
problems using search.
« Reply #1 on: March 22, 2011, 04:19:42 AM »
what roundcube version? what php/os version? Enable imap_debug in Roundcube and provide the log.
« Last Edit: March 22, 2011, 04:26:47 AM by alec »

Offline dogman2

  • Newbie
  • *
  • Posts: 4
problems using search.
« Reply #2 on: March 22, 2011, 11:09:35 AM »
Sorry forgot the obvious stuff.
system:    Redhat Linux Fedora 13
php version: 5.3.5
roundcube: .5.1

Below is the IMAP log data when I attempted to use the search feature.  Thanks again!


[Mar-22-2011 11:04:40 -0400]: S: * OK IMAP4 Server (IMail 9.23)
[Mar-22-2011 11:04:40 -0400]: C: A0001 CAPABILITY
[Mar-22-2011 11:04:40 -0400]: S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN LOGINDISABLED
[Mar-22-2011 11:04:40 -0400]: S: A0001 OK CAPABILITY completed
[Mar-22-2011 11:04:40 -0400]: C: A0002 AUTHENTICATE CRAM-MD5
[Mar-22-2011 11:04:40 -0400]: S: + PDMyMTIuLTc3MjYxNDY4N0BoZXJtZXMtbWFpbD4=
[Mar-22-2011 11:04:40 -0400]: C: c2hlbiAwMzA0ZjcyODc2OTcwNGFkNzg4MTQ0MWYxODVhYTFkYw==
[Mar-22-2011 11:04:40 -0400]: S: A0002 OK AUTHENTICATION successful
[Mar-22-2011 11:04:40 -0400]: C: A0003 STATUS INBOX (MESSAGES UNSEEN)
[Mar-22-2011 11:04:40 -0400]: S: * STATUS INBOX (MESSAGES 1120 UNSEEN 134)
[Mar-22-2011 11:04:40 -0400]: S: A0003 OK STATUS completed
[Mar-22-2011 11:04:40 -0400]: C: A0004 LOGOUT
[Mar-22-2011 11:04:40 -0400]: S: * BYE IMAP4 Server logging out
[Mar-22-2011 11:04:40 -0400]: S: A0004 OK LOGOUT completed
[Mar-22-2011 11:05:40 -0400]: S: * OK IMAP4 Server (IMail 9.23)
[Mar-22-2011 11:05:40 -0400]: C: A0001 CAPABILITY
[Mar-22-2011 11:05:40 -0400]: S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN LOGINDISABLED
[Mar-22-2011 11:05:40 -0400]: S: A0001 OK CAPABILITY completed
[Mar-22-2011 11:05:40 -0400]: C: A0002 AUTHENTICATE CRAM-MD5
[Mar-22-2011 11:05:40 -0400]: S: + PDI1MzkuLTc3MjU1NDcwM0BoZXJtZXMtbWFpbD4=
[Mar-22-2011 11:05:40 -0400]: C: c2hlbiAxMzQzMzA1Y2U0YzBjYmNhMWJkNDE3ZWE0YTk1YjBjYQ==
[Mar-22-2011 11:05:40 -0400]: S: A0002 OK AUTHENTICATION successful
[Mar-22-2011 11:05:40 -0400]: C: A0003 STATUS INBOX (MESSAGES UNSEEN)
[Mar-22-2011 11:05:40 -0400]: S: * STATUS INBOX (MESSAGES 1120 UNSEEN 134)
[Mar-22-2011 11:05:40 -0400]: S: A0003 OK STATUS completed
[Mar-22-2011 11:05:40 -0400]: C: A0004 LOGOUT
[Mar-22-2011 11:05:40 -0400]: S: * BYE IMAP4 Server logging out
[Mar-22-2011 11:05:40 -0400]: S: A0004 OK LOGOUT completed
[Mar-22-2011 11:06:24 -0400]: S: * OK IMAP4 Server (IMail 9.23)
[Mar-22-2011 11:06:24 -0400]: C: A0001 CAPABILITY
[Mar-22-2011 11:06:24 -0400]: S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN LOGINDISABLED
[Mar-22-2011 11:06:24 -0400]: S: A0001 OK CAPABILITY completed
[Mar-22-2011 11:06:24 -0400]: C: A0002 AUTHENTICATE CRAM-MD5
[Mar-22-2011 11:06:24 -0400]: S: + PDE1NjY1Li03NzI1MTA1NDZAaGVybWVzLW1haWw+
[Mar-22-2011 11:06:24 -0400]: C: c2hlbiA1OWYyMWVlMmJiNjk3N2ViZDQ1OTc2OGY2ODVkMWJlNg==
[Mar-22-2011 11:06:24 -0400]: S: A0002 OK AUTHENTICATION successful
[Mar-22-2011 11:06:24 -0400]: C: A0003 SELECT INBOX
[Mar-22-2011 11:06:24 -0400]: S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
[Mar-22-2011 11:06:24 -0400]: S: * 1120 EXISTS
[Mar-22-2011 11:06:24 -0400]: S: * 0 RECENT
[Mar-22-2011 11:06:24 -0400]: S: * OK [UNSEEN 96] 134 Messages unseen
[Mar-22-2011 11:06:24 -0400]: S: * OK [UIDVALIDITY 1283421828] UIDs valid
[Mar-22-2011 11:06:24 -0400]: S: * OK [UIDNEXT 599814927] Predicted next UID
[Mar-22-2011 11:06:24 -0400]: S: A0003 OK [READ-WRITE] SELECT completed
[Mar-22-2011 11:06:24 -0400]: C: A0004 SEARCH CHARSET UTF-8 OR HEADER SUBJECT {7}
[Mar-22-2011 11:06:24 -0400]: S: A0004 NO [BADCHARSET (US-ASCII ISO-2022-JP)] SEARCH: Invalid charset specified
[Mar-22-2011 11:06:24 -0400]: C: A0005 SEARCH CHARSET US-ASCII OR HEADER SUBJECT {7}
[Mar-22-2011 11:06:24 -0400]: S: A0005 BAD SEARCH: Invalid Syntax
[Mar-22-2011 11:06:24 -0400]: C: A0006 LOGOUT
[Mar-22-2011 11:06:24 -0400]: S: * BYE IMAP4 Server logging out
[Mar-22-2011 11:06:24 -0400]: S: A0006 OK LOGOUT completed
[Mar-22-2011 11:06:40 -0400]: S: * OK IMAP4 Server (IMail 9.23)
[Mar-22-2011 11:06:40 -0400]: C: A0001 CAPABILITY
[Mar-22-2011 11:06:40 -0400]: S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN LOGINDISABLED
[Mar-22-2011 11:06:40 -0400]: S: A0001 OK CAPABILITY completed
[Mar-22-2011 11:06:40 -0400]: C: A0002 AUTHENTICATE CRAM-MD5
[Mar-22-2011 11:06:40 -0400]: S: + PDE4NjYuLTc3MjQ5NDcwM0BoZXJtZXMtbWFpbD4=
[Mar-22-2011 11:06:40 -0400]: C: c2hlbiBmMDc2YjkwMmMzYjdkYzVmOTA1YTNmMTZkNjQ5MzE0Yg==
[Mar-22-2011 11:06:40 -0400]: S: A0002 OK AUTHENTICATION successful
[Mar-22-2011 11:06:40 -0400]: C: A0003 STATUS INBOX (MESSAGES UNSEEN)
[Mar-22-2011 11:06:40 -0400]: S: * STATUS INBOX (MESSAGES 1120 UNSEEN 134)
[Mar-22-2011 11:06:40 -0400]: S: A0003 OK STATUS completed
[Mar-22-2011 11:06:40 -0400]: C: A0004 LOGOUT
[Mar-22-2011 11:06:40 -0400]: S: * BYE IMAP4 Server logging out
[Mar-22-2011 11:06:40 -0400]: S: A0004 OK LOGOUT completed

Offline dogman2

  • Newbie
  • *
  • Posts: 4
problems using search.
« Reply #3 on: March 22, 2011, 11:58:21 AM »
IMAP server lods the following:

(00001BAC) sending "A0004 NO [BADCHARSET (US-ASCII ISO-2022-JP)] SEARCH: Invalid charset specified

Offline alec

  • Hero Member
  • *****
  • Posts: 1,178
problems using search.
« Reply #4 on: March 22, 2011, 02:26:19 PM »
Quote from: dogman2;33828

S: * OK IMAP4 Server (IMail 9.23)
C: A0004 SEARCH CHARSET UTF-8 OR HEADER SUBJECT {7}
S: A0004 NO [BADCHARSET (US-ASCII ISO-2022-JP)] SEARCH: Invalid charset specified

It doesn't like UTF-8, that's ok, let's try with US-ASCII
Quote

C: A0005 SEARCH CHARSET US-ASCII OR HEADER SUBJECT {7}
S: A0005 BAD SEARCH: Invalid Syntax

That's wrong. The syntax is valid. You should ask iMail server support, if there's a solution for this issue.

Offline dogman2

  • Newbie
  • *
  • Posts: 4
problems using search.
« Reply #5 on: March 22, 2011, 05:19:52 PM »
We do not currently have an imail support contact.   Even with support they are pretty much useless with third party apps.  I believe the imail web client works through IMAP, and their search does work.

Where is the code for the round cube search function located?  If I can figure out what syntax imail wants maybe I can modify roundcube to accommodate it.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,178
problems using search.
« Reply #6 on: March 23, 2011, 03:11:41 AM »
include/rcube_imap_generic.php, search() method. I'd start with changing the search command string by adding ' ALL ' before 'OR', i.e. SEARCH CHARSET US-ASCII ALL OR HEADER SUBJECT ....

Offline tary

  • Newbie
  • *
  • Posts: 5
problems using search.
« Reply #7 on: September 28, 2011, 10:44:38 PM »
Hi, I'm also a newcomer and having trouble with the search feature. I get the following error: Server Error: Unable to send command: A0006 SEARCH CHARSET US-ASCII TEXT {5} jerry...Was there a resolution to the search issue? Should I be entering something other than the string to search on in that box?
Thank you so much!
Tary

Offline ugosweb

  • Newbie
  • *
  • Posts: 8
problems using search.
« Reply #8 on: December 12, 2011, 06:53:00 PM »
hi,
I'm having the same problem using my IMAP server.

[12-Dec-2011 15:43:15 -0800]: [DFCE] C: A0005 SEARCH CHARSET UTF-8 HEADER TO {9}
[12-Dec-2011 15:43:15 -0800]: [DFCE] S: A0005 NO [BADCHARSET (US-ASCII UTF-8)] Not supported charset.
[12-Dec-2011 15:43:15 -0800]: [DFCE] C: A0006 SEARCH CHARSET US-ASCII HEADER TO {9}
[12-Dec-2011 15:43:15 -0800]: [DFCE] S: A0006 BAD Error in arguments.
[12-Dec-2011 15:43:15 -0800]: [DFCE] C: A0007 LOGOUT

Did you find a solution to solve this problem?

Ugo

Offline alec

  • Hero Member
  • *****
  • Posts: 1,178
problems using search.
« Reply #9 on: December 13, 2011, 02:22:07 AM »
The command is correct, it looks like your IMAP server issue. What IMAP server do you use?

Offline ugosweb

  • Newbie
  • *
  • Posts: 8
problems using search.
« Reply #10 on: December 13, 2011, 04:57:36 AM »
Quote from: alec;37611
The command is correct, it looks like your IMAP server issue. What IMAP server do you use?


I'm using LumiSoft MailServer:
LumiSoft - Mail Server

I can use it with thunderbird and Outlook without any problem.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,178
problems using search.
« Reply #11 on: December 13, 2011, 06:07:49 AM »
http://www.lumisoft.ee/lsWWW/Download/Downloads/MailServer/version.txt I see this was probably fixed in 0.96 version.

Offline ugosweb

  • Newbie
  • *
  • Posts: 8
problems using search.
« Reply #12 on: December 13, 2011, 06:47:26 AM »
Quote from: alec;37616
http://www.lumisoft.ee/lsWWW/Download/Downloads/MailServer/version.txt I see this was probably fixed in 0.96 version.

 
Excellent!!
I installed the Devel version 0.96 and it works perfectly.

Thank you very much!

Ugo