Author Topic: Upgrading from 0.5.1 to 0.7.2 problems  (Read 4780 times)

Offline jomega

  • Jr. Member
  • **
  • Posts: 11
Upgrading from 0.5.1 to 0.7.2 problems
« on: April 10, 2012, 03:45:11 PM »
I updated my roundcube from 0.5.1 to 0.7.2.  I'm getting a weird problem where some users aren't able to log in
with roundcube reporting that it was unable to contact the IMAP server.  The imap server configuration is correct
and works for other users; currently my fix is to change the system password of the user and the user is then
able to log in and view their mail.

After the upgrade trying to solve this problem, I tried to remove all tmp files and even removed all entries from
the session table in the roundcube database.  The cache tables never seem to have anything in them so they are
always empty.  I was thinking of stale sessions or what not, but this doesn't seem to matter.

The logs for the system, apache and the roundcube logs never display any information when the users fail to
log in.

I have even gone to an extreme where I removed the account from the roundcube users table and they still weren't
able to log on after roundcube automatically created a new account.  It's not IMAP/POP3D because the accounts are
able to log in via outlook/thunderbird or any other mail client and this problem only surfaced after I conducted the
upgrade and it only affects some users.

I even tried to deploy my skills of using the poor mans debugger (printfs line by line in the php) to try to see where
the problem is.

Any help would be appreciated.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #1 on: April 10, 2012, 06:18:03 PM »
Its odd that the problem wouldn't be logged, have you check to make sure the host is correct for the users in the users table in the db?

Offline jomega

  • Jr. Member
  • **
  • Posts: 11
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #2 on: April 10, 2012, 07:23:50 PM »
Its odd that the problem wouldn't be logged, have you check to make sure the host is correct for the users in the users table in the db?

Some of the mail_host values were different than expected.  I must have missed that when looking at the descriptions of the tables before.

I changed them all back and issued a new password change for all the affected users.

Why does roundcube offer this per user setting, ultimately how do I see this option?
I took for granted the main configuration file and never thought this might be an per user option.

Thanks I think this solved the problem we'll see.
« Last Edit: April 10, 2012, 07:25:42 PM by jomega »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #3 on: April 11, 2012, 10:36:34 PM »
Its an option in the DB because one install of RoundCube can connect to multiple mail servers. I'm not sure how the values would have gotten changed though.

Offline jomega

  • Jr. Member
  • **
  • Posts: 11
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #4 on: April 12, 2012, 02:40:12 PM »
I'm still receiving 'Connection to IMAP server failed.' errors with some users.  This time however there is a log entry in errors, that's of the format:

[12-Apr-2012 11:33:49 -0700]: IMAP Error: Login failed for <user> from XXX.XXX.XXX.XXX. AUTHENTICATE PLAIN: Argument given to AUTHENTICATE when none expected in <roundcube path>/program/include/rcube_imap.php on line 205 (POST /?_task=login&_action=login)

It doesn't happen with most other users.  Any ideas on this?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #5 on: April 13, 2012, 06:20:54 AM »
Odd, I'd recommend turning on imap_debug and checking the authentication block of an affected user against a login that works.

Offline jomega

  • Jr. Member
  • **
  • Posts: 11
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #6 on: May 01, 2012, 01:09:58 PM »
Odd, I'd recommend turning on imap_debug and checking the authentication block of an affected user against a login that works.

Hi SKaero
Nothing shows up out of the ordinary when I turn on imap_debug except for the "AUTHENTICATE PLAIN: Argument given to AUTHENTICATE when non expected" shows up.  I noticed that the calendar module only works if roundcube is ran from php 5.3 and above, I'm still using PHP 5.2.5 could the PHP version be a problem with running 0.7.2?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #7 on: May 01, 2012, 06:03:46 PM »
When you turn on imap_debug it should create a new file (<RC root>/logs/imap) with all of the imap commands.

Offline jomega

  • Jr. Member
  • **
  • Posts: 11
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #8 on: May 04, 2012, 05:47:54 PM »
When you turn on imap_debug it should create a new file (<RC root>/logs/imap) with all of the imap commands.

It does, I also set the debug mode to 8.  There's a lot of information in the imap log file.  As for the users with the problem, the logs just show the connection and authentication attempt and gives  teh AUTHENTICATION error posted, it does seem that the hash passed is incomplete as it lacks the '==' at the end for the users that can't login via Round Cube, which is why I wondered if it was the version of PHP I was using.  It only happens with certain passwords, whether they are too long or some character combination, it's not quite clear.

So the temp fix is to find a password that works.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #9 on: May 04, 2012, 07:24:46 PM »
Can you post the login and authentication section of the imap log and with what the actual password is (an example password not in active use)

Offline dkorzhevin

  • Jr. Member
  • **
  • Posts: 16
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #10 on: May 21, 2012, 01:08:13 PM »
Hello, SKaero

I have same problem. I switch debul level to 4, and have this error:

IMAP Error in /var/PATH/rcube_imap.php (205): Login failed for dk@email.net from IP. AUTHENTICATE PLAIN: Authentication failed.

Can you advise, where problem is?

Also, i make select from users table:

SELECT * FROM users WHERE username='dk@email.net';

user_id | username        | mail_host            | alias | created             | last_login          | language | preferences

11675 | dk@email.net | hostname.net |       | 2011-04-12 09:55:59 | 2012-05-02 13:43:08 | ru_RU    | a:5:{s:12:"preview_pane";s:1:"0";s:12:"logout_purge";b:1;s:14:"logout_expunge";b:1;s:10:"dst_active";b:0;s:4:"skin";s:8:"mirohost";}

I use:

PHP 5.2.6-1+lenny16 with Suhosin-Patch 0.9.6.2 (cli) (built: Feb  3 2012 13:17:21) on Debian Linux


Exim version 4.69 #1 built 30-Jan-2011 20:48:20
Copyright (c) University of Cambridge 2006
Berkeley DB: Berkeley DB 4.6.21: (September 27, 2007)
Support for: crypteq iconv() IPv6 GnuTLS move_frozen_messages
Lookups: lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dnsdb dsearch nis nis0 passwd
Authenticators: cram_md5 plaintext
Routers: accept dnslookup ipliteral manualroute queryprogram redirect
Transports: appendfile/maildir/mailstore autoreply lmtp pipe smtp
Fixed never_users: 0
Size of off_t: 8
Configuration file is /etc/exim4/exim4.con

I use Arch Linux with latest stable Firefox 12.0


« Last Edit: May 21, 2012, 01:14:16 PM by dkorzhevin »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: Upgrading from 0.5.1 to 0.7.2 problems
« Reply #11 on: May 21, 2012, 11:15:29 PM »
Enable imap_debug in the RoundCube config and post the IMAP conversation for the login from the log file <RC root>/logs/imap