Author Topic: v0.8-rc - fixes problem with display of some HTML mails but "Settings" fails  (Read 7859 times)

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
People,
Is anyone else seeing this?  Is it a known problem?  The screen is blank and there are no error messages in any of the logs . .

Thanks,

Phil.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,501
    • http://SKaero.com/
So your saying that settings is just a white page? Make sure the logs folder is writable.

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
Correct - I changed  the permissions on the log dir to 777 and the error file to 666 but it did not make any difference . .

Thanks,

Phil.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,501
    • http://SKaero.com/
Hmm, anything in server Apache errors? Any plugin enabled? In the RoundCube installer does it say date.timezone is set?

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
There are errors of the form:

[17-Jun-2012 18:17:02 UTC] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Antarctica/Macquarie' for 'EST/10.0/no DST' instead in /home/ssl/webmail.0.8-rc/program/include/rcube_mdb2.php on line 606

So I restored from the currently working config (v0.7.2?):

$rcmail_config['timezone'] = +10;

but I still get the timezone errors and the settings no-show . .

Thanks,

Phil.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,501
    • http://SKaero.com/
Ah, I did have this problem with one of my test installs. You need to set date.timezone in your php.ini.

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
/etc/php.ini was still set from a previous debugging to:

date.timezone = "Australia.Sydney"

Thanks,

Phil.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,501
    • http://SKaero.com/
If you create a test.php file with the following:
Code: [Select]
<?php phpinfo(); ?>
What does it show the date.timezone as?

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
Interesting . . :

date/time support   enabled
"Olson" Timezone Database Version   0.system
Timezone Database   internal
Default timezone   Antarctica/Macquarie

- why isn't Australia.Sydney being recognised?

Thanks,

Phil.

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
I restarted apache and now see:

date/time support   enabled
"Olson" Timezone Database Version   0.system
Timezone Database   internal
Default timezone   Antarctica/Macquarie

Directive   Local Value   Master Value
date.default_latitude   31.7667   31.7667
date.default_longitude   35.2333   35.2333
date.sunrise_zenith   90.583333   90.583333
date.sunset_zenith   90.583333   90.583333
date.timezone   Australia.Sydney   Australia.Sydney

Thanks,

Phil.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,501
    • http://SKaero.com/
I just noticed that its "Australia.Sydney" it should be "Australia/Sydney".

Offline philip_rhoades

  • Jr. Member
  • **
  • Posts: 28
SKaero,

Yes!  That fixed it - thanks!  I wonder why I didn't have the same problem with earlier versions?

BTW, I tried to add "- FIXED" to the Subject line but there must be a character limit . .

Regards,

Phil.