Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / Can't Access Email
« Last post by HouseOfMud on Today at 02:25:55 PM »
I have entered three tickets with Support, but no response so hoping someone here can help. When I try to access my Freehosting.com email account via CPanel I get the following error message:

RC error: Unable to get token, is your RC link correct?
Warning: Invalid argument supplied for foreach() in /var/www/html/roundcubemail-1.4.4/direct_login/index.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/roundcubemail-1.4.4/direct_login/RoundcubeAutoLogin.php:97) in /var/www/html/roundcubemail-1.4.4/direct_login/RoundcubeAutoLogin.php on line 110

When I try to access directly from the Roundcube URL I've always used I get the following error message:

DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

Any suggestions?
2
Issues & Bugs / Print Font Size
« Last post by peterbata on Today at 09:58:39 AM »
Hello all. First time post. We have an IMAP mail account that is accessed by several of our users via Roundcube webmail and/or Microsoft Outlook. When we come to print an email message from within Roundcube the text that appears in the body of the message is so much smaller in the web based client than if it were opened and printed from within MS Outlook. This happens regardless of the browser that is being used (Chrome or Edge). I should also mention that we are running on a Windows 10 platform. Your time and assistance will be greatly appreciated. Thank you
3
Resolved Issues / I can't find reply to a message
« Last post by Henk on Today at 04:45:20 AM »
If I reply to a message I can't find it later then only see the reply arrow where is that message stored?
4
Hello,
I've been facing issues configuring Postfix on my VPS and noticed it didn't work at all.
I'm thinking to switch to Gmail SMTP, i would like to know if i can use it with Rouncube for professional emails and been able to send and receive emails.
Thank you
5
Pending Issues / Re: Password change for users
« Last post by x8 on Today at 02:21:49 AM »
Thx for your hint.
I have changed in /etc/roundcubemail/password.inc.php
Quote
<?php

// Password Plugin options
// -----------------------
// A driver to use for password change. Default: "sql".
// See README file for list of supported driver names.
//$config['password_driver'] = 'sql';
$config['password_driver'] = 'chpasswd';

but the roundcubemail still uses sql driver
drivers files are stored in /usr/share/roundcubemail/plugins/password/drivers
6
Pending Issues / Re: Upgrade Fail - 1.4.10 to 1.6.0
« Last post by EndUser on August 16, 2022, 03:05:23 PM »
In the meantime, is it a safe assumption that Roundcube 1.4.10 can't be made to support TLS 1.2+?
I'll answer this myself... 1.4.10 does support TLS 1.2+.

This thread helped shed some light on the STARTTLS config file entry... https://www.roundcubeforum.net/index.php/topic,29923.0.html

So adding TLS:// to the SMTP entry fixed my problem. I still need to figure out the PHP linking issue, but at least my webmail instance can send and receive email.

Thanks for the suggestions all.
7
Not sure why it would be bad form to respond to your own question, especially when it could help someone with the same issue.

That is the case here... I'm not sure why "forcing" TLS on the SMTP config entry works, but it does!

Thanks for updating your thread with this information.
8
Pending Issues / Re: Upgrade Fail - 1.4.10 to 1.6.0
« Last post by EndUser on August 15, 2022, 04:58:17 PM »
As an added thought, I'm a little surprised the installto.sh script doesn't do a quick PHP -v check to have a clean error report rather than just randomly crashing with a syntax error. The script checks a huge number of other things, so adding one more for PHP version seems simple enough.
9
Pending Issues / Re: Upgrade Fail - 1.4.10 to 1.6.0
« Last post by EndUser on August 15, 2022, 04:56:16 PM »
Thanks for responding JohnDoe.

Good catch... this does happen to be the case with my hosting provider. The CLI binary is symbolic linked to an ancient PHP version (4.4.9). I don't know why they are linking "php" to a binary that old as they have binaries up to 8.1 available. Unfortunately, I can't change the link as it is in a shared area (/usr/bin) and I don't have permissions. I'm not using a dedicated host. I've asked the hosting vendor to change the link to 7.4. We'll see if they do/can.

In the meantime, is it a safe assumption that Roundcube 1.4.10 can't be made to support TLS 1.2+?
10
Pending Issues / Re: Cannot send mail...
« Last post by JohnDoh on August 15, 2022, 12:14:06 PM »
What is the specific error you are trying told solve? Whats in the Roundcube error log and/or your SMTP logs?

The lack of an error code is a bit strange, if your SMTP server does not support/require authentication then set smtp_user and smtp_pass to empty strings to disable authentication.

If you are having certificate verification problems have a look at https://github.com/roundcube/roundcubemail/wiki/FAQ#problems-connecting-imapsmtp-server-via-ssltls
Pages: [1] 2 3 ... 10