Recent Posts

Pages: [1] 2 3 ... 10
1
Pending Issues / Re: custom_logo working partially after 1.3.0 upgrade
« Last post by lonestar on December 17, 2017, 09:09:46 AM »
I had a similar problem, it was easier to adjust the skin itself.

Hey, thank you for reply.
Yes of course this would be a good solution if I was using the same logo for all the hosted domains.
But I host different domains each with a different logo to be showing on the pages, and that's exactly the purpose that the custom_logo plugin addresses.

We are now at release 1.3.3 but nothing has changed from this point of view, the issue is still present.
2
Theme Releases / Re: Chameleon Blue - customization of Chameleon by Kolab Community
« Last post by Skolzyashiy on December 17, 2017, 07:41:36 AM »
Incorporated changes up to chameleon v 0.39
https://github.com/Anisotropic/Chameleon-blue/releases
3
API Based Plugins / Re: cpanel password extension - no CPanel pw reqd
« Last post by ElasticUser on December 15, 2017, 05:11:05 PM »
I still don't appear to be cating on to all the README steps for the password plugin.  I might have a friend look at that.  :--)
4
Pending Issues / Re: Malformed email results in Connection Error?
« Last post by pboehmer on December 15, 2017, 04:15:10 PM »
Stated above, 1.3.3
5
Pending Issues / Re: Malformed email results in Connection Error?
« Last post by SKaero on December 15, 2017, 12:31:18 PM »
What version of Roundcube are you running?
6
Pending Issues / Malformed email results in Connection Error?
« Last post by pboehmer on December 15, 2017, 12:17:00 PM »
I have a RC 1.3.3 install that serves several hundred customers.  We received a call yesterday that one customer was getting a "Connection Error (Failed to reach the server)!" error when checking their email.  No other reports of issues.  We successfully log into RC using the customer credentials and sure enough, inbox shows 40+ messages in the folder window, but nothing displayed in the message list window and immediately get the connection error.

Eventually, we figured out the issue was caused by a couple of emails in the user's account.  All of the problematic emails in this specific users account had subject lines with "=?UTF-8?Q?" or "=?UTF-32?B?" and had <style> sections containing garbage (Mailsploit?).  Deleting said emails results in a working account, no connection error and message list shows the correct information.  Copying a problematic email to one of our test accounts results in the same error. 

I have debug level set to 8, but there is nothing relevant being outputted to the log file. 

Is the connection error some kind of "fall through" error message that RC uses when no other errors are relevant?  Second, is there anything we can do from the RC side of things to prevent the error (don't display message/ignore UTF encoding?). 

I have attached one of the sanitized (server/account info altered) emails if someone wants to take a look.  We tried altering the subject line.  The only way we could get RC to work with the email was to alter the subject line *AND* remove the <style> section in the message body.
7
Release Discussion / I can't log into any of my accounts.
« Last post by stansmith on December 15, 2017, 07:44:54 AM »
Re: I can't log into any of my accounts.
« Reply #2 on: June 18, 2017, 03:55:18 AM »
Quote
Do you run your own Roundcube install or are you and end user?

If you run your own install then check the Roundcube error logs (typically in [rc root]/logs/errors) and check your IMAP server logs.

If you are an end user then you need to contact the people who run your email. Roundcube is the name of the webmail software they are using, it is not an email service.
8
API Based Plugins / Re: cpanel password extension - no CPanel pw reqd
« Last post by SKaero on December 14, 2017, 10:54:32 PM »
Its in the README file in the password plugin folder, there is a section for each password driver.
9
API Based Plugins / Re: cpanel password extension - no CPanel pw reqd
« Last post by ElasticUser on December 14, 2017, 06:23:41 PM »
Below is all the code that cpanel.php has.  I doesn't see to say to change any of it.  :--)

<?php

/**
 * cPanel Password Driver
 *
 * Driver that adds functionality to change the users cPanel password.
 * Originally written by Fulvio Venturelli <fulvio@venturelli.org>
 *
 * Completely rewritten using the cPanel API2 call Email::passwdpop
 * as opposed to the original coding against the UI, which is a fragile method that
 * makes the driver to always return a failure message for any language other than English
 * see http://trac.roundcube.net/ticket/1487015
 *
 * This driver has been tested with o2switch hosting and seems to work fine.
 *
 * @version 3.0
 * @author Christian Chech <christian@chech.fr>
 *
 * Copyright (C) 2005-2013, The Roundcube Dev Team
 *
 * This program is free software: you can redistribute it and/or modify
 * it under the terms of the GNU General Public License as published by
 * the Free Software Foundation, either version 3 of the License, or
 * (at your option) any later version.
 *
 * This program is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
 * GNU General Public License for more details.
 *
 * You should have received a copy of the GNU General Public License
 * along with this program. If not, see http://www.gnu.org/licenses/.
 */

class rcube_cpanel_password
{
    public function save($curpas, $newpass)
    {
        require_once 'xmlapi.php';

        $rcmail = rcmail::get_instance();

        $this->cuser = $rcmail->config->get('password_cpanel_username');

        // Setup the xmlapi connection
        $this->xmlapi = new xmlapi($rcmail->config->get('password_cpanel_host'));
        $this->xmlapi->set_port($rcmail->config->get('password_cpanel_port'));
        $this->xmlapi->password_auth($this->cuser, $rcmail->config->get('password_cpanel_password'));
        $this->xmlapi->set_output('json');
        $this->xmlapi->set_debug(0);

        return $this->setPassword($_SESSION['username'], $newpass);
    }

    /**
     * Change email account password
     *
     * @param string $address  Email address/username
     * @param string $password Email account password
     *
     * @return int|array Operation status
     */
    function setPassword($address, $password)
    {
        if (strpos($address, '@')) {
            list($data['email'], $data['domain']) = explode('@', $address);
        }
        else {
            list($data['email'], $data['domain']) = array($address, '');
        }

        $data['password'] = $password;

        $query  = $this->xmlapi->api2_query($this->cuser, 'Email', 'passwdpop', $data);
        $query  = json_decode($query, true);
        $result = $query['cpanelresult']['data'][0];

        if ($result['result'] == 1) {
            return PASSWORD_SUCCESS;
        }

        if ($result['reason']) {
            return array(
                'code'    => PASSWORD_ERROR,
                'message' => $result['reason'],
            );
        }

        return PASSWORD_ERROR;
    }
}
10
Roundcube Discussion / Re: Sync roundcube webmail to outlook
« Last post by ayeweb on December 14, 2017, 03:42:10 PM »
Hello,
I'm trying to connect to windows 10 and worked well.
But when i delete some email in windows 10, in roundcube not delete.
Anyone help?
Thanks
Pages: [1] 2 3 ... 10