Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / Re: LDAP Address Book
« Last post by alec on Today at 02:48:41 AM »
I'm afraid most people use LDAP addressbook in readonly mode, so there might be some bugs in the code that writes to LDAP. Any debug logs for this case?
2
General Discussion / LDAP Address Book
« Last post by sharbich on Today at 12:56:10 AM »
Hello,
I added an LDAP address book in Roundcube. That works so far. Only when I wanted to add my work address to my private address.
Code: [Select]
. . .
       // Roundcube   => LDAP
    'name'           => 'cn',
    'surname'        => 'sn',
    'firstname'      => 'givenName',
    'birthday'       => 'birthDate',
    'jobtitle'       => 'title',
    'email'          => 'mail',
    'phone:home'     => 'homePhone',
    'phone:work'     => 'telephoneNumber',
    'phone:mobile'   => 'mobile',
    'address:home'   => 'homePostalAddress',
    'address:work'   => 'postalAddress',
    'street'         => 'street',
    'zipcode'        => 'postalCode',
    'locality'       => 'l',
    'organization'   => 'o',
    'notes'          => 'description',
. . .
I got the following error message while saving:
Code: [Select]
Mai 15 06:48:16 dsme01 roundcube[480]: PHP Warning:  ldap_mod_replace(): Value array must have consecutive indices 0, 1, ... in /var/www/html/roundcube/program/lib/Roundcube/rcube_ldap_generic.php on line 153
Mai 15 06:48:16 dsme01 roundcube[480]: <id67ocms> PHP Error: ldap_mod_replace() failed with Success (POST /?_task=addressbook&_framed=1&_orig_source=Local&_action=save)
There's something wrong with the uniqueness. What am I doing wrong?

Greetings from Stefan Harbich
3
Hi there, I'm new here ... have run RC for years ...

I installed roundcube-toolbox primarily for forwarding/vacation messaging (I could only find this plugin, are there others?)

https://github.com/gianlucagiacometti/roundcube-toolbox/releases/tag/1.4.10

There are no obvious errors, no logged errors either.

I don't find anything that would allow me to forward emails when logged in to RC.

How is it intended to work?

Many Thanks, Caesar.
4
General Discussion / How to change email attachment file size ?
« Last post by seyfullahbaskoylu on May 14, 2021, 05:06:57 PM »
Hello all,
I installed Roundcube latest version on Redhat 8.3.
I want to use  Roundcube webmail for our Oracle-based MTA.
I edited upload_max_filesize and post_max_size to 30M in php.ini file.
I did not find any settings on default.php
But I did not upload an attachment file size of more than 2M.
I read a lot of attachment size change solutions. But I did not solve this problem.
Thank you for your help.
Best Regards.

 
5
Due to the corona lockdown we are offering you to enjoy latest movies @ Home with your family,  friends and childrens. So Enjoy :)

https://www.facebook.com/TheConjuring3flick/
https://www.facebook.com/PeterRabbit2flick/
https://www.facebook.com/BlackWidowFlicks
https://www.facebook.com/SpaceJamflick/
6
General Discussion / Re: LDAP Password Change
« Last post by sharbich on May 14, 2021, 01:53:14 PM »
Try %name instead of %login.
That was the solution. Thanks.
7
General Discussion / Re: User monitoring
« Last post by RachelAvery on May 14, 2021, 12:59:51 PM »
I haven't heard of it, probably not.
8
Pending Issues / Re: Roundcube 1.5 Beta - problems with template conditions
« Last post by alec on May 14, 2021, 09:54:25 AM »
It works for me in git-master. I put your template content at the end of skins/elastic/templates/mail.html and I get "Condition 3" only in the result.
9
Pending Issues / Roundcube 1.5 Beta - problems with template conditions
« Last post by chris_scott on May 14, 2021, 07:57:25 AM »
Hi,
I'm having some problems with the skin template conditionals (if/elseif/else) in RC 1.5 Beta (latest as of this post.) In some circumstances the html code from ALL the if clauses is included, even if the conditions don't match. (See the attached screenshot.)

I'm pasting the code that works in RC 1.4 but doesn't work in RC 1.5. I have it added to header.html of a custom skin. The odd thing is that if I make the text in the if clauses shorter, it starts working properly. For example, if I remove the last two sentences inside the span of condition 4, it works.

Does anyone have any ideas what's going on?

Code: [Select]
<roundcube:if condition="env:task == 'mail' && env:action == 'show'" />
    Condition 1
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse nulla quam, egestas
        posuere ac, tincidunt a purus. Ut ornare semper vehicula. Maecenas molestie laoreet elit. Suspendisse
        a accumsan ante, sit amet efficitur tellus. Nulla eget vehicula purus. Praesent gravida, nisl vitae
        egestas vestibulum, erat nulla eleifend leo, in feugiat quam elit vel nulla.
    </span>
<roundcube:elseif condition="env:task == 'mail' && env:action == 'compose'" />
    Condition 2
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse nulla quam, egestas
        posuere ac, tincidunt a purus. Ut ornare semper vehicula. Maecenas molestie laoreet elit. Suspendisse
        a accumsan ante, sit amet efficitur tellus. Nulla eget vehicula purus. Praesent gravida, nisl vitae
        egestas vestibulum, erat nulla eleifend leo, in feugiat quam elit vel nulla.
    </span>
<roundcube:elseif condition="env:task == 'mail' && !env:action == 'plugin.summary'" />
    Condition 3
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse nulla quam, egestas
        posuere ac, tincidunt a purus. Ut ornare semper vehicula. Maecenas molestie laoreet elit. Suspendisse
        a accumsan ante, sit amet efficitur tellus. Nulla eget vehicula purus. Praesent gravida, nisl vitae
        egestas vestibulum, erat nulla eleifend leo, in feugiat quam elit vel nulla.
    </span>
<roundcube:elseif condition="env:task == 'addressbook'" />
    Condition 4
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse nulla quam, egestas
        posuere ac, tincidunt a purus. Ut ornare semper vehicula. Maecenas molestie laoreet elit. Suspendisse
        a accumsan ante, sit amet efficitur tellus. Nulla eget vehicula purus. Praesent gravida, nisl vitae
        egestas vestibulum, erat nulla eleifend leo, in feugiat quam elit vel nulla. Nam ullamcorper sapien purus,
        vitae sollicitudin enim lobortis eget. Aliquam interdum fermentum turpis nec ultrices.
    </span>
<roundcube:elseif condition="env:task == 'settings'" />
    Condition 5
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse nulla quam, egestas
        posuere ac, tincidunt a purus. Ut ornare semper vehicula. Maecenas molestie laoreet elit. Suspendisse
        a accumsan ante, sit amet efficitur tellus. Nulla eget vehicula purus. Praesent gravida, nisl vitae
        egestas vestibulum, erat nulla eleifend leo, in feugiat quam elit vel nulla.
    </span>
<roundcube:else/>
    Condition 6
    <span style="display:none">
        Lorem ipsum dolor sit amet, consectetur adipiscing elit.
    </span>
<roundcube:endif />
10
General Discussion / Re: Where are user settings stored?
« Last post by sw2090 on May 14, 2021, 07:42:57 AM »
Ah thanks for the hint! moduserprefs.sh + userprefs reference made my day :)
Pages: [1] 2 3 ... 10