Roundcube Community Forum

Release Support => Older Versions => 0.1 Beta 1 => Topic started by: marksmith on July 12, 2006, 03:24:57 PM

Title: Deletion Problem
Post by: marksmith on July 12, 2006, 03:24:57 PM
Hello there.

I really love the Roundcube Mail Interface but am having a problem with the deletion of emails. When I click the delete icon, the email disappears from view but reappears on refreshing the inbox again.

I've tried all combinations of not specifying a Trash folder, changing the way emails are processed etc but all with the same result.

My configuration is:

Windows 2k3 Server
IIS 6.0
PHP 4.3.11
MailEnable IMAP Server

If anyone could offer me any advice or if you require any further information, please do not hesitate to contact me.

If you require an email account setting up on this server to experiment with, I'll create one in order for this issue to be resolved.

Thanks for any assistance in advance.


Title: Re: Deletion Problem
Post by: Prasad1337 on July 13, 2006, 05:50:41 AM
yea this happens to me too sometimes.
but most of the times i logout and log back in again and the mail is then deletable.
Title: Re: Deletion Problem
Post by: onlydavid on August 17, 2006, 06:57:35 PM
I have the exact same issue with my installation which is on a completely different system.

Apache 1.3.x

Though I have not been able to solve my issue, I was able to get the delete button to work properly by changing this from the default value of 'Trash' to '' in

Code: [Select]
$rcmail_config['trash_mbox'] = '';
So I'll assume that roundcube is having a problem in moving the mail to the Trash folder. Maybe someone else might be able to fix this, but this could be a temporary workaround for you.
Title: Re: Deletion Problem
Post by: onlydavid on August 21, 2006, 10:44:46 AM
Just an FYI, in case anyone else has this problem. My issue was that my IMAP Server was storing Directories like this on the server:


Rather than the way some IMAP servers use which is by using a system like this.


The reason that the deletion was "hanging" was because, Roundcube could not move the piece of mail to the folder "Trash" on my system. So of course changing the values to something like this worked for me.
Code: [Select]
$rcmail_config['trash_mbox'] = 'INBOX/Trash';
Hopefully this helps!