Author Topic: After 0.8.0 upgrade, date column is blank  (Read 10792 times)

Offline knobbysideup

  • Newbie
  • *
  • Posts: 2
After 0.8.0 upgrade, date column is blank
« on: August 09, 2012, 11:06:58 AM »
Hi all,

Been using roundcube awhile now, and it works beautifully.  Thank you!

Now a problem.  I searched the forums with no luck in finding anybody with the same issue.

Since upgrading to 0.8, the date column in any of my folders is now blank, as is the date header in all messages.  Things seem to sort by date ok, but the dates are not displayed.  This worked in 0.7.2.  See attached image.  There is also no date in the header display for messages.  This happens for all messages, including new ones, and happens with both themes.

I get the following errors in my logs, but I had the same errors with 0.7.2, IIRC.  Of course, it'd be nice to get rid of these as well:


Aug  9 11:00:09 webmail roundcube: PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /var/www/html/roundcube/program/include/rcube_mdb2.php on line 606
Aug  9 11:00:09 webmail roundcube: PHP Warning:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /var/www/html/roundcube/program/include/rcube_session.php on line 135


My server is running Centos 5.8, PHP 5.3.3:

[root@webmail ~]# uname -a
Linux webmail.freefall.homeip.net 2.6.18-308.11.1.el5.centos.plus #1 SMP Tue Jul 10 16:44:19 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@webmail ~]# rpm -qa | grep php
php-pear-Net-Socket-1.0.10-1.el5
php53-mcrypt-5.3.3-1.el5
php53-pdo-5.3.3-13.el5_8
php-pear-1.4.9-8.el5
php53-process-5.3.3-13.el5_8
php-pear-Mail-Mime-1.4.0-1.el5.centos
php53-common-5.3.3-13.el5_8
php53-xml-5.3.3-13.el5_8
php-pear-Net-SMTP-1.4.4-1.el5
php53-5.3.3-13.el5_8
php53-ldap-5.3.3-13.el5_8
php53-pspell-5.3.3-13.el5_8
php53-devel-5.3.3-13.el5_8
php-pear-MDB2-2.4.1-2.el5.centos
php53-mysql-5.3.3-13.el5_8
php53-imap-5.3.3-13.el5_8
php-pear-Auth-SASL-1.0.4-1.el5
php53-cli-5.3.3-13.el5_8


Any help is appreciated.  Seeing when things came in is kind of important :-)

One other thing of note:
The upgrade script screwed up the permissions in my roundcube tree.  I had to manually fix this.  I didn't look at the installer, but assume this is because it is copying files from an archive rather than using 'install'

-- Greg
« Last Edit: August 09, 2012, 11:23:44 AM by knobbysideup »

Offline alec

  • Hero Member
  • *****
  • Posts: 1,154
Re: After 0.8.0 upgrade, date column is blank
« Reply #1 on: August 09, 2012, 03:50:49 PM »
Since upgrading to 0.8, the date column in any of my folders is now blank, as is the date header in all messages.  Things seem to sort by date ok, but the dates are not displayed.  This worked in 0.7.2.  See attached image.  There is also no date in the header display for messages.  This happens for all messages, including new ones, and happens with both themes.

I get the following errors in my logs, but I had the same errors with 0.7.2, IIRC.  Of course, it'd be nice to get rid of these as well:


Aug  9 11:00:09 webmail roundcube: PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /var/www/html/roundcube/program/include/rcube_mdb2.php on line 606

I think all you need is to set date.timezone in php.ini file.

Offline knobbysideup

  • Newbie
  • *
  • Posts: 2
Re: After 0.8.0 upgrade, date column is blank
« Reply #2 on: August 09, 2012, 05:24:56 PM »
That did it.  Thank you!!

I'm not a PHP guy.  I've done all of my own work with mod_perl and embedded perl.  I should look through that file and see what else I should be setting, I guess.

-- Greg