Author Topic: Password Plugin (SOLVED)  (Read 4276 times)

Offline ilie_alexandrov

  • Newbie
  • *
  • Posts: 2
Password Plugin (SOLVED)
« on: August 15, 2012, 04:43:59 PM »
Hello. I I've read already all posts but didn't solve my problem with password plugin.

I see everytime this error in logs:
Quote
[15-Aug-2012 14:36:27 -0600]: PHP Error: Password plugin: Broken driver cpanel in /home6/artzluxc/public_html/test/plugins/password/password.php on line 258 (POST /test/?_task=settings&_action=plugin.password-save?_task=&_action=)

I'm user of Bluehost hosting.

I'm using a custom Cpanel.php driver (see attached) because default is not working + Here are my configs:

config.inc.php:
$rcmail_config['password_driver'] = 'cpanel';

// cPanel Driver options
// --------------------------
// The cPanel Host name
$rcmail_config['password_cpanel_host'] = 'box800.bluehost.com';

// The cPanel admin username
$rcmail_config['password_cpanel_username'] = 'username';

// The cPanel admin password
$rcmail_config['password_cpanel_password'] = 'password';

// The cPanel port to use
$rcmail_config['password_cpanel_port'] = 2083;

// Using ssl for cPanel connections?
$rcmail_config['password_cpanel_ssl'] = true;

// The cPanel theme in use
$rcmail_config['password_cpanel_theme'] = 'bluehost';


Who can help me? Thank you very much in advance. Sorry for my english!
« Last Edit: August 16, 2012, 02:51:52 PM by ilie_alexandrov »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,691
    • http://SKaero.com/
Re: Password Plugin
« Reply #1 on: August 15, 2012, 05:26:31 PM »
The cpanel driver you are using is for an old version of the password plugin, it wont work with the current version. Why is the default cpanel driver is not working?

Offline ilie_alexandrov

  • Newbie
  • *
  • Posts: 2
Re: Password Plugin
« Reply #2 on: August 16, 2012, 02:51:07 PM »
with standart driver i get everytime this error:
"[15-Aug-2012 13:36:47] PHP Warning:  fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://box706.bluehost.com:2083 (Время ожидания соединения истекло) in /home6/artzluxc/public_html/test/plugins/password/drivers/cpanel.php on line 67"


But is very strage, i tried to install roundcube once again (the 4-th time) and now plugin is working properly with default cpanel driver. But it work only on Bluehost. Fatcow shows me an error. But it was important for me a properly work on Bluehost.

So I thank You very much for attention to my post and for reply=) We can close this subject=)