Author Topic: Your browser does not accept cookies  (Read 8013 times)

Offline bluecrescent94

  • Newbie
  • *
  • Posts: 3
Your browser does not accept cookies
« on: August 16, 2007, 04:41:50 PM »
Hello all.

First let me say, I have combed the forums and google for a solution to this issue and none resolved or fit the issue. I know the browsers in IE and firefox in testing accept all cookies, there is not a firewall in place (hardware firewall only completely open to LAN traffic) and all folder permissions are everyone full control for roundcube. OK, enough disclaimer, down to the problem

2003 server
IIS6
latest Roundcube
PHP 5.2.3
MySQL 5.0.37
latest PEAR
Mercury/32 4.51 located on different server on the same network
http://roundcube.williams2000.com (test lab)

I can get the login page just fine. However, regardless of what is inputted, I get the error "Your browser does not accept cookies". There is no log created, no temp files created and there is not an atttempt to connect to mercury/32

Any assistance is greatly appreciated as I want to compare Roundcube to my Horde/IMP installation which operates flawlessly.

Offline bluecrescent94

  • Newbie
  • *
  • Posts: 3
Re: Your browser does not accept cookies
« Reply #1 on: August 18, 2007, 07:01:54 PM »
UPDATE: I feel that an a troubleshooting update is necessary because it is looking the web rumors of this forum being useless is coming to pass.... :-\

All problems still persist but I do see sessions being created in MYSQL with every attempt. This is the only data going into the db.

Any asistance is greatly appreciated.

Offline EraserTwo

  • Newbie
  • *
  • Posts: 1
Re: Your browser does not accept cookies
« Reply #2 on: August 20, 2007, 08:42:32 AM »
HI

I think you simply deactivated cookies on php level.

Take a look in your php.ini file. There should be something like
Code: [Select]
; Whether to use cookies.
session.use_cookies = 1

but in your case its probably like
Code: [Select]
session.use_cookies = 0
Simple change this and restart IIS

Offline rsmith85

  • Newbie
  • *
  • Posts: 1
Re: Your browser does not accept cookies
« Reply #3 on: August 20, 2007, 10:49:33 AM »
Check the above post. It may make the difference to your setup.

However if you are still having problems try deleting all your cookies, temporary files and history. I had a similar problem and this solved it. I wouldn't have noticed on Firefox as this is done automatically for me, but on IE6 I needed to do this manually to get the webmail to work.

Rob

Offline bluecrescent94

  • Newbie
  • *
  • Posts: 3
Re: Your browser does not accept cookies
« Reply #4 on: August 20, 2007, 09:24:03 PM »
THANKS FOR THE REPLIES. My faith is restored.

I turned off cookies in php.ini, restarted IIS and even rebooted the server to cover all bases. I cleared my cookies from both test browsers and even tested offsite and received the same results. It is still not producing and log files, any temp files or any errors other than "Your browser does not accept cookies" with no attempt to connect to the IMAP server.

Offline speed47

  • Newbie
  • *
  • Posts: 3
Re: Your browser does not accept cookies
« Reply #5 on: September 11, 2007, 05:11:06 AM »
I have EXACTLY the same problem. The interesting thing to note is that roundcube previously worked. I can't figure out why it started some day to tell me I was refusing cookies, whatever computer and browser and login and password I would use, even if I DO accept cookies.
Well, I won't describe the whole thing again, this has already been well described above.

Here's my config, for reference :

Ubuntu 7.04 Server (kernel 2.6.21.5)
Apache 2.2.3
Roundcube SVN rev 791
PHP 5.2.1
MySQL 5.0.38