Author Topic: IMAP login Problem after upgrade to v1.2  (Read 5655 times)

Offline quwax

  • Jr. Member
  • **
  • Posts: 24
IMAP login Problem after upgrade to v1.2
« on: May 26, 2016, 02:20:37 AM »
Hello,
after upgrading to v1.2 I get an login error that the Krb5 modul is necessary for login with imap, although I changed in the config file the login method to CRAM-MD5. After that I installed Authen::Krb5 via CPAN on that machine, but it still doesn't seam to work.
On trying to login I get a message - connection to "Speicherserver" failed - probably to IMAP server.
When I run Test IMAP config from the installer I get:
IMAP connect:  NOT OK(Login failed for ..... The krb5 extension is required for GSSAPI authentication)
in the config.inc.php I set:
$config['imap_auth_type'] = CRAM-MD5;
Dovecot is set to Kerberos, CRAM-MD5, Login.

when I set $config['imap_auth_type'] = LOGIN;
it works.
So what's wrong with CRAM-MD5?
I'm not surprised that kerberos is not really working under 10.6
cheers
quwax
The box this is running on is a MacOS 10.6.8 Server with Dovecot and Postfix

Offline alec

  • Hero Member
  • *****
  • Posts: 1,299
Re: IMAP login Problem after upgrade to v1.2
« Reply #1 on: May 26, 2016, 03:50:42 AM »
This is a string and need to be quoted. So, 'CRAM-MD5' not CRAM-MD5.

Offline quwax

  • Jr. Member
  • **
  • Posts: 24
Re: IMAP login Problem after upgrade to v1.2
« Reply #2 on: May 26, 2016, 03:57:55 AM »
Alec,
thanks, that works  :)
Just wondering why the default setting of nul is not working anymore (it did until v1.1).
cheers
quwax

Offline alec

  • Hero Member
  • *****
  • Posts: 1,299
Re: IMAP login Problem after upgrade to v1.2
« Reply #3 on: May 26, 2016, 05:57:06 AM »
1.1 did not support GSSAPI, so the capability was just ignored and CRAM-MD5 selected as a default. In 1.2 we have code for GSSAPI and as you noticed it requires some php module and additional configuration.