Author Topic: [SOLVED] Invalid request. No data was saved  (Read 24685 times)

Offline lperkins2

  • Newbie
  • *
  • Posts: 2
[SOLVED] Invalid request. No data was saved
« on: September 09, 2017, 12:21:02 AM »
I spent several hours today trying to get roundcube webmail to let me log in.  The eventual error was 'Invalid request. No data was saved'.  That error message is less than useful, but I traced the program (index.php) and found it was not setting the cookies properly.  Had the CGI server dump out what it thought was going on, and spotted that the cookie was getting set, and promptly deleted.  Anyway, if you're trying to get this working via CGI (php7,  debian),  grab the latest version off github (current commit is afa03008c7da4162e1705f0e27179802001f589d), it just works with no issues. 

Offline ruller90

  • Newbie
  • *
  • Posts: 1
Re: [SOLVED] Invalid request. No data was saved
« Reply #1 on: September 20, 2017, 06:03:45 AM »
Maybe you have a Incorrect webmail configuration
On the webmail node you have:
# grep https /usr/share/psa-roundcube/config/ | grep -v '/'
$rcmail_config['force_https'] = true;
$rcmail_config['use_https'] = true;
You should set one of the option to false
Try and let me know if it helped
Co robić, aby jelita nie były zapchane? Musisz odpowiednio o nie dbać.