Author Topic: RoundCube 1.1.9 from EPEL  (Read 6210 times)

Offline coec

  • Newbie
  • *
  • Posts: 5
RoundCube 1.1.9 from EPEL
« on: October 28, 2023, 02:27:41 AM »
Hi

As per ${SUBJECT}, we're currently running roundcube v1.1.9 on RHEL7 and want to upgrade to a version that has the latest security patches.

I want to build a new RHEL 9 server and install v1.5.5 from EPEL.

The question is, how would I migrate the data from v1.1.9 to v1.5.5?

Thanks

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,831
Re: RoundCube 1.1.9 from EPEL
« Reply #1 on: October 28, 2023, 04:09:35 AM »
have a look at https://github.com/roundcube/roundcubemail/wiki/Upgrade. its easiest to use the installto script if you can.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline coec

  • Newbie
  • *
  • Posts: 5
Re: RoundCube 1.1.9 from EPEL
« Reply #2 on: October 28, 2023, 05:37:02 AM »
Thank you but can I upgrade from v1.1.9 directly to v1.5.5?  If not, do I need to go to v1.2 then v1.3 etc?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,831
Re: RoundCube 1.1.9 from EPEL
« Reply #3 on: October 29, 2023, 04:40:55 AM »
I think your current db version is 2015030800, it will be in the `system` table of the Roundcube database. It is important to execute all the database updates in order. As long as you do that then going all the way to 1.5.3 should not be a problem.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline coec

  • Newbie
  • *
  • Posts: 5
Re: RoundCube 1.1.9 from EPEL
« Reply #4 on: November 02, 2023, 12:55:23 AM »
Hi

I've been working on this but it seems I'll need to do the below on an interim server:
- download PHP v5 and install to a custom location
- install roundcube v1.1.19
- import the MySQL DB from the production server
- get all that working together
- remove the references to PHP v5
- install roundcube v1.5.5
- upgrade the DB
- export the DB to the new prod server

Does that sound about right?

Thanks again

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,831
Re: RoundCube 1.1.9 from EPEL
« Reply #5 on: November 02, 2023, 01:06:17 PM »
I forgot about the PHP version support. There is just overlap between 1.1 and 1.5, both support 5.6. If you have an interim server you could install PHP 1.5 on that and the dump of the database from 1.1, run the various schema updates and then everything should work. You don't need a full Roundcube 1.1 install just to update the database.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline coec

  • Newbie
  • *
  • Posts: 5
Re: RoundCube 1.1.9 from EPEL
« Reply #6 on: November 06, 2023, 05:34:42 PM »
Hi

I've been  working on this and I've had issues with installing some php modules (pspell, imagick, mcrypt).  I've resolved the issues with imagick and mcrypt but I can;t get pspell installed.

It looked like enchant was required for pspell but I can't get it installed.  https://pecl.php.net/package/enchant says "This package is not maintained anymore and has been superseded. Package has moved to channel https://www.php.net/enchant" but no indication of what it is superceded by.

Apologies but I've not been able to google my way out of this.

Thanks for your help so far

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,831
Re: RoundCube 1.1.9 from EPEL
« Reply #7 on: November 08, 2023, 12:55:58 PM »
This might not be a very helpful answer but pspell is an optional dependency, only needed if you want to run your own pspell server for spell checking. I don't use it myself so I can't really comment on the best solution but may be you could skip that dependency for now, get everything working and up to date and then revisit it?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…