Author Topic: Can't send - smtp error 250  (Read 10849 times)

Offline jgijanto

  • Newbie
  • *
  • Posts: 3
Can't send - smtp error 250
« on: August 05, 2010, 10:09:57 AM »
Hello,

I'm doing some testing with roundcube and hoping that it will prove to be a solid webmail client that I can roll out to my users (I administer an email server for a small ISP).  I'm really liking what I see so far, but I'm having some issues getting mail to send.

I am able to log in and access my emails.  When I try to send a message, though, I get an smtp error 250: authentication failed.  The strange part is that my test messages sent out no problem with the installer.

Anyone have thoughts on where I should start with this?  The server is running postfix, and does not require authentication to send.

Any tips are greatly appreciated!

Joe
« Last Edit: August 05, 2010, 10:13:35 AM by jgijanto »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,461
    • http://SKaero.com/
Can't send - smtp error 250
« Reply #1 on: August 05, 2010, 11:50:59 AM »
Try changing $rcmail_config['smtp_auth_type'] in /config/main.inc.php to PLAIN if you have no authentication, if that doesn't work try using LOGIN.

Offline jgijanto

  • Newbie
  • *
  • Posts: 3
Can't send - smtp error 250
« Reply #2 on: August 05, 2010, 01:24:15 PM »
Hi Skaero,

I tried what you suggested but that doesn't seem to help, either with PLAIN or LOGIN.  I found in the rc/logs folder the following error message:

SMTP Error: SMTP error: Authentication failure: SMTP server does not support authentication (Code: ) in /var/www/rc/program/steps/mail/func.inc on line 1365 (POST /rc/?_task=mail&_action=send)

So it seems like its still trying to use some type of SMTP authentication?

Offline alec

  • Hero Member
  • *****
  • Posts: 1,125
Can't send - smtp error 250
« Reply #3 on: August 05, 2010, 02:03:01 PM »
Enable smtp_debug option and attach logs/smtp file here.

Offline jgijanto

  • Newbie
  • *
  • Posts: 3
Can't send - smtp error 250
« Reply #4 on: August 06, 2010, 08:36:39 AM »
Ok, with the SMTP debug added here's what I get from a single attempt to send email:

[06-Aug-2010 08:13:22 -0400]: Recv: 220 mail3.primelink1.net ESMTP server ready.
[06-Aug-2010 08:13:22 -0400]: Send: EHLO 10.100.0.75
[06-Aug-2010 08:13:22 -0400]: Recv: 250-mail3.primelink1.net
[06-Aug-2010 08:13:22 -0400]: Recv: 250-PIPELINING
[06-Aug-2010 08:13:22 -0400]: Recv: 250-SIZE 20240000
[06-Aug-2010 08:13:22 -0400]: Recv: 250-ETRN
[06-Aug-2010 08:13:22 -0400]: Recv: 250 8BITMIME
[06-Aug-2010 08:13:22 -0400]: Send: RSET
[06-Aug-2010 08:13:22 -0400]: Recv: 250 Ok
[06-Aug-2010 08:13:22 -0400]: Send: QUIT
[06-Aug-2010 08:13:22 -0400]: Recv: 221 Bye

I also verified that the server this is running on has relay access to the mail server.  Strange too, I looked up the smtp codes and 250 isn't even an error.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,125
Can't send - smtp error 250
« Reply #5 on: August 06, 2010, 09:41:02 AM »
Your SMTP server doesn't returns AUTH response. If you really would like to send mail without authentication then you should set smtp_user, smtp_pass and smtp_auth_type to null.

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #6 on: September 06, 2010, 04:15:19 PM »
Same error for me : SMTP ERROR (250) : authentication problem

I just want to tell that if i use the previous version roundcubemail-0.3-stable (always installed) everything works well.
With the new version roundcubemail-0.4 I can't send an email

An authentication error. Logs enabled in roundcube tells :
SMTP Error: SMTP error: Authentication failure: SMTP server does not support authentication (Code: ) in /var/wws/roundcubemail-0.4/program/steps/mail/func.inc on line 1425 (POST /mail/?_task=mail&_action=send)


I cheked the main.inc.php file twice; put the previous main.inc.php (0.3-stable)
Nothing works.

I have to use the old version 0.3-stable.
I'm disapointed because I would like to use the very interesting feature :  threaded view in messages boxes.

Thanks for your help

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,461
    • http://SKaero.com/
Can't send - smtp error 250
« Reply #7 on: September 06, 2010, 10:51:01 PM »
Can you post a imap_debug log?

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #8 on: September 07, 2010, 03:12:23 AM »
From my mail.log. Ask me if you want more

With roundcube4 (send an email failure) :

Sep  7 09:03:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=23/398
Sep  7 09:03:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=31/1836
Sep  7 09:03:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=408/17090
Sep  7 09:03:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=2305/18353
Sep  7 09:03:59 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:59 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=34/359
Sep  7 09:03:59 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:03:59 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=31/1836
Sep  7 09:04:10 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:04:10 net1 postfix/smtpd[7207]: connect from net1.domain.net[192.168.0.111]
Sep  7 09:04:10 net1 postfix/smtpd[7207]: disconnect from net1.domain.net[192.168.0.111]
Sep  7 09:04:10 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=8/331

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #9 on: September 07, 2010, 03:15:47 AM »
With roundcube3-stable (send an email to gmail successfull)

Sep  7 09:05:39 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:39 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=23/398
Sep  7 09:05:39 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:40 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=368/18164
Sep  7 09:05:40 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:40 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=2455/18703
Sep  7 09:05:44 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:44 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=8/331
Sep  7 09:05:44 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:44 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=31/1836
Sep  7 09:05:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:56 net1 postfix/smtpd[7207]: connect from net1.domain.net[192.168.0.111]
Sep  7 09:05:56 net1 postfix/smtpd[7207]: setting up TLS connection from net1.domain.net[192.168.0.111]
Sep  7 09:05:56 net1 postfix/smtpd[7207]: net1.domain.net[192.168.0.111]: TLS cipher list "ALL:+RC4:@STRENGTH"
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:before/accept initialization
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 read client hello B
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write server hello A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write certificate A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write key exchange A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write server done A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 flush data
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 read client key exchange A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 read finished A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write session ticket A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write change cipher spec A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 write finished A
Sep  7 09:05:56 net1 postfix/smtpd[7207]: SSL_accept:SSLv3 flush data
Sep  7 09:05:56 net1 postfix/smtpd[7207]: Anonymous TLS connection established from net1.domain.net[192.168.0.111]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Sep  7 09:05:56 net1 postfix/smtpd[7207]: 6CF146E043: client=net1.domain.net[192.168.0.111], sasl_method=PLAIN, sasl_username=jc2010@domain.net
Sep  7 09:05:56 net1 postfix/cleanup[7211]: 6CF146E043: message-id=<9f068022cf61699d0c59ff3fd9a591bf@localhost>
Sep  7 09:05:56 net1 postfix/qmgr[1524]: 6CF146E043: from=, size=828, nrcpt=1 (queue active)
Sep  7 09:05:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=605/1894
Sep  7 09:05:56 net1 postfix/smtpd[7207]: disconnect from net1.domain.net[192.168.0.111]
Sep  7 09:05:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=368/18164
Sep  7 09:05:56 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:56 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=368/18164
Sep  7 09:05:57 net1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, TLS
Sep  7 09:05:57 net1 dovecot: IMAP(jc2010@domain.net): Disconnected: Logged out bytes=2455/18727
Sep  7 09:05:57 net1 postfix/smtp[7272]: 6CF146E043: to=, relay=gmail-smtp-in.l.google.com[209.85.227.27]:25, delay=0.66, delays=0.01/0.02/0.3/0.33, dsn=2.0.0, status=sent (250 2.0.0 OK 1283843157 v14si8128784weq.13)
Sep  7 09:05:57 net1 postfix/qmgr[1524]: 6CF146E043: removed

Offline alec

  • Hero Member
  • *****
  • Posts: 1,125
Can't send - smtp error 250
« Reply #10 on: September 07, 2010, 03:36:06 AM »
Better use imap_debug and smtp_debug options in Roundcube. Also what do you have in smtp configuration section in main.inc.php?

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #11 on: September 07, 2010, 11:28:27 AM »
// SMTP username (if required) if you use %u as the username RoundCube
// will use the current username for login
$rcmail_config['smtp_user'] = 'jc@domain.net';

// SMTP password (if required) if you use %p as the password RoundCube
// will use the current user's password for login
$rcmail_config['smtp_pass'] = 'Mypassword';

// SMTP AUTH type (DIGEST-MD5, CRAM-MD5, LOGIN, PLAIN or empty to use
// best server supported one)
$rcmail_config['smtp_auth_type'] = '';

I also tryed with PLAIN or LOGIN unsuccessfully.

I turned on imap_debug and smtp_debug
And the log is :
[07-sept.-2010 17:21:24] SMTP server does not support authentication ():
[07-Sep-2010 17:21:24 +0200]: SMTP Error: SMTP error: Authentication failure: SMTP server does not support authentication (Code: ) in /var/wws/roundcubemail-0.4/program/steps/mail/func.inc on line 1425 (POST /mail/?_task=mail&_action=send)

Nothing more
Don't hesitate to ask me more.
Regards

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,461
    • http://SKaero.com/
Can't send - smtp error 250
« Reply #12 on: September 07, 2010, 11:37:26 AM »
Have you tried with it with a blank $rcmail_config['smtp_user'] and $rcmail_config['smtp_pass']

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #13 on: September 07, 2010, 12:41:08 PM »
OK it works when i leave
$rcmail_config['smtp_user'] and $rcmail_config['smtp_pass']  blank

But if i understand wenn there's no more smtp authentication.
It's not really a problem because mail server accept to relay mail from localhost  but the feature is no more.
Am I wrong ?

Regards.

Offline jissou

  • Jr. Member
  • **
  • Posts: 16
Can't send - smtp error 250
« Reply #14 on: September 13, 2010, 02:58:28 PM »
OK i had some time to watch carefully the problem.
And activating tls
$rcmail_config['smtp_server'] = 'tls://net1.domain.net';
smtp authentication work properly.

tls protocol was optionnal in 0.3-stable release and must be noted on 0.4 config.