Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Try ssl://example.com instead of tls://example.com
12
Issues & Bugs / Connection to storage server failed after configuring roundcube for TLS
« Last post by weizm2 on February 20, 2018, 02:41:00 PM »
Hi All

We are using Roundcube Webmail 1.2-beta on Ubuntu with Postfix and Dovecot.   Everything was running fine until we modified Roundcube to use TLS.
After configuring Postfix for TLS, we modified these settings in Roundcube's config.inc.php:

# $config['default_host'] = 'localhost';
$config['default_host'] = 'tls://localhost';

# $config['smtp_server'] = 'localhost';
$config['smtp_server'] = 'tls://mail.ourdomain.com';

The # commented lines are the original settings.
We had to specify the Fully Qualified Domain Name: mail.ourdomain.com for TLS to work.   We also added mail.ourdomain.com to the hosts file on the server.
After making these changes, TLS worked fine, but we cannot login to Roundcube anymore.  Keeps getting the "Connection to storage server failed" error.

Found this error in the Roundcube error log:
[20-Feb-2018 09:56:19 -0800]: <1c08ao0m> IMAP Error: Login failed for tommy@mail,ourdomain.com from 192.168.6.1. Unable to negotiate TLS in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 193 (POST /?_task=login?_task=login&_action=login)

We reverted our configuration to no TLS, and we can login to Roundcube again.

Probably a Dovecot IMAP setting issue?


Thank you very much in anticipation.

WZM





13
Deutsch / roundcube.knu-systems.net öffnet nicht
« Last post by Mariusmarius on February 20, 2018, 01:56:06 PM »
Hallo zusammen,

bisher habe ich immer die Domain roundcube.knu-systems.net genutzt, um mein Mailkonto zu öffnen. Seit ein paar Tagen kommt beim Öffnen der domain die Fehlermeldung 403 forbidden.

Was kann ich machen, um an meine Mails zu kommen?

Güße, Marius
14
General Discussion / roundcube.knu-systems.net
« Last post by Mariusmarius on February 20, 2018, 01:53:43 PM »
Hey guys,

have been using Roundcube since a coupe of years. Couple of days ago, i couldn't open the domain roundcube.knu-systems.net, and still can't do it. Which is weird, because I logged into my emailaccount via this domain.

Does anybody know how I can access my mails? The ending is @present-e.org, which is a non-profit-organization I worked for.

Cheers, Marius

edit: When I open the domain, this text appears: Forbidden

You don't have permission to access / on this server.
Apache/2.2.9 (Debian) DAV/2 mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.9 OpenSSL/0.9.8g Server at roundcube.knu-systems.net Port 80

--> I can't even type my mailadress and password
15
Pending Issues / Re: users can not change their passwords (version 1.3.4)
« Last post by murdocklawless on February 20, 2018, 08:26:43 AM »
Ok.  Roundcube Core doesn't have a password change utility.  That is provided by a third-party plugin.  Vesta would be the best place to seek answers.  I saw your post in their little forum, but you might have better success opening an issue at Vestra Developer Serghev's github page: https://github.com/serghey-rodin/vesta/issues.  As for your error: "DB Error: [1305] FUNCTION roundcube.update_passwd does not exist (SQL Query: SELECT update_passwd('$1$cpSPQLYD$Q/YC/LIMdjAxYiCRpb7991', 'mail@domain.com')) in /usr/share/roundcube/program/lib/Roundcube/rcube_db.php on line 543 (POST /webmail/?_task=settings&_action=plugin.password-save)", something isn't quite as it seems.  The way I understand it, you should have downloaded Serghev's vestra.php file into the password plugin's "drivers" folder.  You should then ensure that "vestra" is selected as the driver in the password plugin's config.inc.php file.  Serghev's Vesta module doesn't modify a database directly.  By default, unless otherwise configured, it does a web logon to "localhost" port "8083" to accomplish the password change.  The fact that you're getting SQL errors tells me that the config.inc.php file is not properly setup.  In other words, you're not using the Vesta driver file.  You can find the Vesta driver file here:  https://github.com/serghey-rodin/vesta/blob/master/install/rhel/7/roundcube/vesta.php.  Hope this helps.

I've already changed vesta.php with link you gave me and config.php shows vesta driver. something wrong but I coundn't figured out.
16
Pending Issues / Re: Enigma problem
« Last post by telecom2k3 on February 20, 2018, 07:32:11 AM »
The configuration file is: config.inc.php.  The generally accepted practice is to copy any config.inc.php.dist files to config.inc.php, then modify the config.inc.php file.  That way, you always have the configuration references supplied by the distribution's author (.dist).
17
Resolved Issues / SMTP Problem
« Last post by MatMac System on February 20, 2018, 04:07:17 AM »
Hi guys,
I have installed Roundcube as a Webmail for my macOS server but I have some problem with send messages.
If I configure my mail address in a device it works perfectly but if I try to send a message from the webmail to an external address I said: "Errore SMTP (454): inserimento del destinatario "matev1998@gmail.com" non riuscito (4.7.1 <matev1998@gmail.com>: Relay access denied)".
The server works and I don't know why the webmail not.
Anyone can help me?

Thanks
18
General Discussion / Re: messages not being sent out
« Last post by XyZd9F7 on February 19, 2018, 09:24:14 PM »
Hi Skaero
thank you very much for the advice and info. I am kind of new to the whole web hosting and related things and appreciate any advice I can get.
Thanks . . .
19
General Discussion / Re: Recalling a sent message
« Last post by XyZd9F7 on February 19, 2018, 09:20:06 PM »
Thanks
20
General Discussion / Php Busqueda Automatica con valor Post.
« Last post by Daniel Chairez on February 19, 2018, 06:14:32 PM »
Como hacer una busqueda automatica con el valor enviado por variable post.
Pages: 1 [2] 3 4 ... 10