Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Pending Issues / users can not change their passwords (version 1.3.4)
« Last post by murdocklawless on February 19, 2018, 06:37:21 AM »
I've installed vestacp to my vps and roundcube mail came with version 1.20 beta. then I've upgraded roudcube to 1.3.4 but users can not change their passwords. I've tried a lot of things which I've seen on other forums but nothing changed. It's working like a charm except password change.

is there any solutions for versiyon 1.3.4 ?
22
General Discussion / messages not being sent out
« Last post by XyZd9F7 on February 19, 2018, 04:57:25 AM »
Hi
I have a website through i-page.com and they also provide email services with that website. Their webmail service is roundcube. I am not sure how you guys fit into the picture but maybe you can help me anyway.
I am experiencing a lot of problems with the email:
* My website stopped sending out self generated messages, e.g. when people register for a class they are supposed to get a confirmation email but the system doesn't send it out anymore.
* Quite often when I send messages from my email account they don't arrive in the recipient's inbox, likewise a lot of messages that are being sent to me don't arrive in my inbox. This problem is intermittent so I never know when my email system works properly and when not. This is way to unreliable to use for business.

The customer service at i-page has run me through the same "set-up" protocol a dozen times already and can't fix the problem but also don't let me speak to a knowledgeable tech support member. I was wondering if you guys have any solutions or at least ideas what to look for.

THANKS . . .
23
General Discussion / Recalling a sent message
« Last post by XyZd9F7 on February 19, 2018, 04:37:35 AM »
How do I recall a message that I sent out?
Thanks . . .
24
Roundcube Discussion / Re: How do generate Event UID
« Last post by mdegive on February 17, 2018, 12:50:43 PM »
It's from the calendar, I think kolab/calendar. I will contact them. Thx.
25
Roundcube Discussion / Re: How do generate Event UID
« Last post by JohnDoh on February 17, 2018, 12:47:31 PM »
there is no table called events in the standard roundcube schema. is this a table from a plugin? if so the plugin devs might be able to help you.
26
API Based Plugins / Re: New Plugin: CalDAVZap
« Last post by rebeldu31 on February 16, 2018, 02:43:12 PM »

Guy,

When and where have I say that I had asked for help to configure Nextcloud or other?  :o
When we do not know the volume of an exchange (on Github) we do not make remarks, thank you.  ;)

I had simply asked him how to configure HIS PLUGINS, nothing more!!!
Then, this kind of answer, in others, thank you well!!!

Anyway, problem settled for me: I uninstalled this plugin because I had no help to its configuration on behalf of the developer.
Thus closed subject!!!
 8)
27
API Based Plugins / Re: New Plugin: CalDAVZap
« Last post by telecom2k3 on February 16, 2018, 01:50:58 PM »
1) This is a Javascript application.  So, the calendar data transfer occurs between the user's web browser, and the calendar server itself; in your case, between whatever web browser you use, and your Nextcloud server.  When an application on one server wants your browser to access resources on another server, this presents a major security problem.  This is known as XSS, or Cross-Site Scripting.  All major web browsers prohibit this today.  Firefox has a Developer under Settings -> Web Developer -> Web Console.  Chrome has the same thing under Tools -> Developer Tools.  These consoles will display XSS, and any other, errors.
2) A Proxy Server is just another potential work-around around for this problem.   In the plugin configuration, you would program in your local webserver address  for the CalDAV server address.  Your proxy server forwards the requests to the actual CalDAV (NextCloud) server.   So to your end-user Web Browser, everything looks like its coming and going to the same server (Roundcube).
3) If you wish to post a question here requesting configuration information, then do so.  But as you can see, this is a new plugin that doesn't have a lot of active installations yet.  You will probably get better support from Synology.   Synology is a commercial product; you should expect to get good service from them.
4) Your expectations are unreasonable.  The developer's job is to make a working plugin with Roundcube.  That is all.  It is not his/her job to tell you how to configure it for OwnCloud, PureCloud, NextCloud, or WhoEversCloud.  It is not his/her job to tell you how to configure it for Apache 2.2, Apache 2.4, Apache Whatever, NGINX, LightHTTP, Node.js, IIS, or anything else.  The plug-in works fine.  It is very good.  There is no reason to insult the developer.
28
General Discussion / Roundcube LDAP addressbook / 389-DS / Let's Encrypt
« Last post by Polle on February 16, 2018, 07:24:34 AM »
Hi
I'm having a problem connecting the RoundCube address book to my 389-DS LDAP server over SSL (port 636).
I first set up things non-encrypted (port 389) - works fine. Got all my addresses and groups, browsing ...
Then I installed a Let's Encrypt certificate on my 389-DS server. The certificate / certificate chain looks fine
on the LDAP server.
I opened a ssh session to my website account which is hosting the RoundCube webmail and tried:
openssl s_client -connect <my ldap server>:636 -showcerts </dev/null | more
and it returns the cert chain with at the end:
....
---
Server certificate
subject=/CN=<my LDAP server>
issuer=/C=US/O=Let's Encrypt/CN=Let's Encrypt Authority X3
---
Acceptable client certificate CA names
/O=Digital Signature Trust Co./CN=DST Root CA X3
Client Certificate Types: RSA sign, ECDSA sign, DSA sign
Requested Signature Algorithms: ECDSA+SHA256:ECDSA+SHA384:ECDSA+SHA512:ECDSA+SHA1:RSA+SHA256:RSA+SHA384:RSA+SHA512:RSA+SHA1:DSA+SHA256:DSA+SHA384:DSA+SHA512:DSA+SHA1
Shared Requested Signature Algorithms: ECDSA+SHA256:ECDSA+SHA384:ECDSA+SHA512:ECDSA+SHA1:RSA+SHA256:RSA+SHA384:RSA+SHA512:RSA+SHA1:DSA+SHA256:DSA+SHA384:DSA+SHA512:DSA+SHA1
---
SSL handshake has read 3607 bytes and written 661 bytes
---
New, TLSv1/SSLv3, Cipher is AES256-SHA
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : AES256-SHA
    Session-ID: 2391A453F991235060AEAD242330F4EE3D647735A5B8E73F08C4B8041362D3A5
    Session-ID-ctx:
    Master-Key: 9A2225DFE6DA8822364ED3401F6F96D3F25D0E73C122DD449BDE504D93F61EFDF9C36A4CFB2642D00D9251E247DAC09A
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1518783016
    Timeout   : 300 (sec)
    Verify return code: 0 (ok)
---
So all that is looking fine - but when I open the address book it's empty.
The RoundCube LDAP log shows:
[16-Feb-2018 05:47:04 -0600]: <59b69vl1> C: Connect [ldaps://<my LDAP server>:636]
[16-Feb-2018 05:47:04 -0600]: <59b69vl1> S: OK
[16-Feb-2018 05:47:04 -0600]: <59b69vl1> C: Bind [dn: cn=Directory Manager]
[16-Feb-2018 05:47:04 -0600]: <59b69vl1> S: Can't contact LDAP server
[16-Feb-2018 05:47:04 -0600]: <59b69vl1> C: Close


That doesn't say much, just that it is able to reach the server but can't bind/authenticate, in the LDAP server log:
[16/Feb/2018:12:47:04.601950788 +0100] conn=1040 fd=65 slot=65 SSL connection from <source IP>  to <ldap IP>
[16/Feb/2018:12:47:04.633176695 +0100] conn=1040 op=-1 fd=65 closed - Peer does not recognize and trust the CA that issued your certificate.


So it looks to me that RoundCube (the peer) is not trusting the CA although things seem to be OK if I check with openssl ...
Hope someone can shed a little light on this - I spent hours in searching - no luck so far ...

29
Roundcube Discussion / How do generate Event UID
« Last post by mdegive on February 14, 2018, 02:15:59 PM »
I have an internal PHP program that sets reminders for people and I would like to add those reminders to the events table in roundcubemail database.

The problem is that the UID column in the events table is somehow generated from, I am guessing, the username in the users table.

Anybody knows how that UID is generated?

Thank you.
30
Roundcube Discussion / Re: Upload size limit
« Last post by JohnDoh on February 14, 2018, 11:29:35 AM »
Have a look in your roundcube error log and/or your smtp server log. persumably the SMTP server is the issue. That is a really big attachment for an email. I dont think any of the major email providers would accept an email with such an attachment
Pages: 1 2 [3] 4 5 ... 10