Recent Posts

Pages: [1] 2 3 ... 10
General Discussion / Re: Your session is invalid or expired.
« Last post by sm69th on Today at 07:42:20 AM »
OK...I will start with upgrading Roundcube and see if that helps. I was previously on PHP 5.3 and it was more or less a forced upgrade as the SQL Server drivers were giving me a massive headache.  I will report back if upgrading solves the problem (fingers crossed).
General Discussion / Mailbox on different Server
« Last post by SirSutter on Today at 03:57:38 AM »
Hello Roudcube community

I have an exchange, which mainly handles the mail-flow.
I set it up to relay messages, where the mailbox is not on the exchange, to a Linux machine with roundcube (plesk).
This works without a problem except for the return way.
When I send a mail from roundcube to the exchange, it's searching for the mailbox on roundcube, and cannot find it.
Is there a way to configure roundcube like the exchange?
Like: "If mailbox not here, send it to exchange"

Thank you very much
General Discussion / Re: Your session is invalid or expired.
« Last post by JohnDoh on Today at 03:22:04 AM »
IMO finding out why you cant login now is a waste of time. Roundcube 0.8.4 is not compatible with PHP7, it is too old. Roundcube 0.8.4 was released 15th November 2012 while PHP7 was released 3rd December 2015 and 7.1 1st December 2016. Formal compatibility with PHP7 was added to Roundcube in version 1.2, released 22nd May 2016. Even if PHP compatibility was not an issue running such out of date software is never a good idea. You are missing out on security fixes as well as many functional improvements.
General Discussion / Your session is invalid or expired.
« Last post by sm69th on Today at 12:50:42 AM »
Using PHP Version 7.1.25 on Windows 2008 Server SP2, connecting to SQL Server 2014 via loaded extension "php_sqlsrv_7_nts.dll" .

Before I wasn't able to connect to the I get the login screen, however, whenever I try to login, I get the error "Your session is invalid or expired."

This is running Roundcube Version 0.8.4.

I have checked and I am correctly setting the timezone in php.ini (date.timezone= "America/New_York")

In the PHP logs I see this:
[20-Mar-2019 00:21:44 America/New_York] PHP Warning:  session_start(): Failed to read session data: user (path: C:\Windows\temp) in D:\websites\XXXXXXXXXXXXXX\program\include\rcmail.php on line 786

I have checked and the IUSR account has read/write permissions on the Temp folder (c:\Windows\Temp).

Any suggestions? I could obviously update roundcube since I am behind in versions, but I would prefer figuring out why it can't login now...

Thank you!

Pending Issues / Database Connection Error after uninstalling MS SQL 2008
« Last post by sm69th on March 19, 2019, 03:45:08 PM »
I have roundcube Version 0.8.4 installed on a Windows 2008 Server, SP2 64 Bit machine. This  server also has MS SQL 2008 & 2014 installed.

The database was migrated off of 2008 and put on MS SQL 2014. I updated the file to point to the MSSQL 2014. It worked fine. I know it was workign off the 2014 instance because I detached the 2008 database and everything still worked.

Now the problem...I un-installed MS SQL 2008 as I had moved all databases. Roundcube has never been able to find the database since then, throwing this error:

Unable to connect to the database!
Please contact your server-administrator.

The connection string should be right because it worked prior to the software un-install of MS SQL 2008.

Any suggestion? I am at a loss as to why roundcube cannot find the database anymore?
log directory have 755 permission 
If your getting a blank page there should be an error, I recommend checking the permissions on the logs directory. 
we dont have anything recorded in the roundcube error log
Whats in the Roundcube error log?
Hi ,

We have a iredmail server with 2 domain names , and
With the roundcube client of the mail server we are able to login with both domain names.

When we try to configure roundcube client on a seperate server , with we are able to login and see the inbox but with we are able to login but getting blank page , we are not able to load the mailbox.

Roudcube version : 1.3.6

Any help is much appreciated!
Pages: [1] 2 3 ... 10